Disabled every device in acpi/wakeup and my Logi Bolt receiver still wakes computer immediately after suspend

Hi everyone, this is driving me insane. I’ve disabled every device in /proc/acpi/wakeup

Device  S-state   Status   Sysfs node
GPP0      S4    *disabled  pci:0000:00:01.1
GPP2      S4    *disabled
GPP3      S4    *disabled
GPP4      S4    *disabled
GPP5      S4    *disabled
GPP6      S4    *disabled
GPP7      S4    *disabled
GPP8      S4    *disabled  pci:0000:00:03.1
GPP9      S4    *disabled
GPPA      S4    *disabled
GPPB      S4    *disabled
GPPC      S4    *disabled
GPPD      S4    *disabled
GPPE      S4    *disabled
GPPF      S4    *disabled
GP10      S4    *disabled
GP11      S4    *disabled
GP12      S4    *disabled  pci:0000:00:07.1
GP13      S4    *disabled  pci:0000:00:08.1
XHC0      S4    *disabled  pci:0000:2f:00.3
GP30      S4    *disabled
GP31      S4    *disabled
BXBR      S4    *disabled  pci:0000:00:01.2

And yet my Logitech Bolt receiver will not stop waking the computer. When I remove the receiver from the computer it will stay suspended. This issue does not happen in Windows. I’ve tried switching the kernel from 6.1.23-1 to 6.2.10-1 and 6.3.0rc5-1 but they all have the same issue.

Below is my software version information as well as hardware.
Screenshot_20230409_215335
Screenshot_20230409_215615

Disable Wake-on-LAN in BIOS?

PS your soft/hard info is woefully incomplete (ex - the reciever in question).
Please see the following or any similar thread.