Dell XPS 9500 with Kernel 5.15 and 6.1 both, restarts randomly and stuck on initial boot screen


I have been facing this random restart and screen freeze on boot for more than 7 months now, first I was on 5.15 LTS, then I tried installing 6.1 to see if this issue disappears but issue still persists.

I updated my system on 10 Oct 2023.

Any help/idea/suggestion would be much appreciated.


sudo dmesg | grep error
[ 4.148934] ucsi_acpi USBC000:00: unknown error 0

journalctl --catalog --priority=3 --boot=-1

Oct 11 11:36:32 shah-xps159500 kernel: ucsi_acpi USBC000:00: unknown error 0
Oct 11 11:36:32 shah-xps159500 kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-5)

inxi --full

  Host: shah-xps159500 Kernel: 6.1.55-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.8 Distro: Manjaro Linux
  Type: Laptop System: Dell product: XPS 15 9500 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0HH6JF v: A00 serial: <superuser required> UEFI: Dell
    v: 1.22.0 date: 03/16/2023
  ID-1: BAT0 charge: 48.5 Wh (100.0%) condition: 48.5/84.3 Wh (57.6%)
  Info: 8-core model: Intel Core i9-10885H bits: 64 type: MT MCP cache:
    L2: 2 MiB
  Speed (MHz): avg: 818 min/max: 800/5300 cores: 1: 800 2: 800 3: 875 4: 800
    5: 800 6: 800 7: 800 8: 799 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800
    15: 1027 16: 799
  Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nvidia
    v: 535.113.01
  Device-3: Logitech Webcam Pro 9000 driver: snd-usb-audio,uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting,nvidia
    unloaded: nouveau dri: iris gpu: i915 resolution: 1: 3840x2160~60Hz
    2: 3840x2400~60Hz
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    renderer: Mesa Intel UHD Graphics (CML GT2)
  API: Vulkan v: 1.3.264 drivers: nvidia,intel surfaces: xcb,xlib
  Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel
  Device-2: Logitech Webcam Pro 9000 driver: snd-usb-audio,uvcvideo
    type: USB
  Device-3: JMTek LLC. MICUSB driver: hid-generic,snd-usb-audio,usbhid
    type: USB
  API: ALSA v: k6.1.55-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Qualcomm QCA6390 Wireless Network Adapter driver: ath11k_pci
  IF: wlp108s0 state: up mac: 9c:b6:d0:3e:aa:70
  Local Storage: total: 953.87 GiB used: 308.51 GiB (32.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM981a NVMe 1024GB
    size: 953.87 GiB
  ID-1: / size: 229.89 GiB used: 82.52 GiB (35.9%) fs: ext4
    dev: /dev/nvme0n1p3
  ID-2: /boot/efi size: 499 MiB used: 74.2 MiB (14.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 702.09 GiB used: 225.87 GiB (32.2%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-1: swap-1 type: partition size: 4.88 GiB used: 40 MiB (0.8%)
    dev: /dev/nvme0n1p2
  System Temperatures: cpu: 46.0 C pch: 53.0 C mobo: 39.0 C
  Fan Speeds (rpm): cpu: 0 fan-2: 0
  Processes: 346 Uptime: 13m Memory: total: 64 GiB note: est.
  available: 62.42 GiB used: 7.6 GiB (12.2%) Shell: Zsh inxi: 3.3.30

Old thread: Dell 9500 with Kernel 5.15 and 6.1 both, randomly restarts and stuck on boot screen

Does this thread help at all? Not exactly the same error message but seems to indicate there may be some problem with the Nouveau driver on various laptops including Dell XPS 9500. Try switching to the non-free Nvidia driver.

I’m not an Nvidia user so maybe someone else can give you exact instructions on how to do that.

Previous thread solution did not work. Therefore I had to create a new post.

Read the thread I linked.

Probably because of heat? And no, that is not a restart then, but a crash.

  • restart → controlled and initiated reboot
  • crash → unforeseen event

How does the System manage the fans? By the UEFI firmware or by OS?

It looks like by OS (because if managed by UEFI you would see N/A here):

Fans are not working. So you need to configure the fans yourself then: Fan speed control - ArchWiki

Probably also send the output of: sensors

If possible switch to UEFI fan control in the UEFI Settings.

1 Like

@megavolt Thanks, let me try this, will get back to you with outcome.

@megavolt Here you go sensors output:

» inxi -s    
  System Temperatures: cpu: 63.0 C pch: 67.0 C mobo: 50.0 C
  Fan Speeds (rpm): cpu: 3904 fan-2: 4187

UCSI_GET_PDOS failed” indicates a communication issue between the USB Type-C (USB-C) and the Power Delivery (PD) subsystem.
– this is not strictly a Manjaro issue.

The best I can offer are some basic troubleshooting steps. Assuming the device actually is external, here are some things you could try:

  • Boot without the USB-C device connected: See if the issue remains. Note there may be other issues as a result of multiple failed boot attempts.

  • Update any applicable drivers/firmware: The latest update may have already done that; it may be prudent to do some research from a compatibility perspective.

  • Check the USB-C connection: It’s possible there’s an intermittent fault with the cable, or connector; and it doesn’t connect securely – try a different cable and see if the problem persists. Indeed, try a different type of cable and connect it to another port.

  • Hardware Issues: It could be a hardware problem related to the USB-C port, or the USB-C and PD controllers – contact your local computer repair dude/dudette to perform diagnostics and/or repair; or the manufacturer, if still under warranty.

  • Software Conflicts: This is where the forum can potentially help. Be mindful that if issue has been going on for this long, it’s likely related to software you installed about the time it started; possibly from the AUR, or another non-Arch/Manjaro source.

  • Check your BIOS/UEFI Settings: Resetting BIOS to the default/safe values and then testing each subsequent change in configuration may help.

I hope this is helpful to some extent. Cheers.

1 Like

@soundofthunder It does seem like what you described, I have tried starting up without the usb c connected error seems to go away, but this freezon screen issue still does come up even without usb c connected.

I will give it a go again, and see what sort of error do I get without USB-C connected, will then post here.

Thanks for your detailed analysis, I really appreciate it.

@soundofthunder I tried without USB-C connected, did not see any error. So this confirmed it is to with either USB-C cable itself or connection vice versa.

But…, I’m still facing the screen freeze after boot up and before login screen render.
Screen freezes goes blank with just only cursor on it.

Any idea / suggestion for that please?


I saw no accepted solution in that thread; renaming the thread title might have been a better idea. No matter, it’s history now.

You might also try booting without your external webcam connected.

You could start by providing more extended log information without the offending USB-C device connected. What you describe could be caused by many things; and I note that many have tried to help previously without any definitive result.

One suggestion I saw was to try using proprietary Nvidia drivers instead of Nouveau; though, I’m aware that could potentially introduce greater complication. Additionally, I’m not a great fan of Nvidia to begin with, ergo, not the ideal person to ask about that.

Is the cursor able to move normally; despite the black screen?
(I ask this in case it points someone else in the right direction).

Cursor freezes as well.

I’m using proprietary Nvidia drivers.

Will try this, and post the detailed logs as well.


Also, I noticed the ioremap related errors in your previous thread. What resolved that; or is it still happening occasionally?

Check for possible bios updates and make sure that the following bios options are set:

  • Turn off legacy ROM
  • System → SATA: change to AHCI
  • Disable Secure Boot
  • Set the POST Behavior: Fastboot to Thorough
  • Thunderbolt security and Thunderbolt Boot support disabled

“use dell-bios-fan-control-gitAUR utility to disable BIOS control of fans which conflicts with i8k. You may also want to enable and start dell-bios-fan-control.service to ensure BIOS control of fans is disabled at boot.”
(Dell XPS 15 (9550) - ArchWiki)

Tried booting without USB-C and external cam connected.
Had same screen frozen with frozen cursor.

After 3 retries, was able to boot.

» journalctl --catalog --priority=3 --boot=-1
Oct 14 21:01:08 xps159500 kernel: i2c_hid_acpi i2c-DELL097D:00: failed to fetch HID descriptor: -121
Oct 14 21:01:08 xps159500 kernel: i2c_hid_acpi i2c-DELL097D:00: Failed to fetch the HID Descriptor
Oct 14 21:01:09 xps159500 kernel: 

Do you have an external monitor connected via a USB-C to DisplayPort cable? If so, disconnect that as well and try booting; then check the logs again for errors.

Previous result was produced without USB-C display cable connected.