Dell 9500 with Kernel 5.15 and 6.1 both, randomly restarts and stuck on boot screen


I have been facing this random restart and screen freeze on boot for sometime, first I was on 5.15 LTS, then I tried installing 6.1 to see if this issue disappears but issue still persists.

Would be much appreciate if somebody could help please.

sudo desg | grep error

[    2.091241] ioremap error for 0x4fe7b000-0x4fe7c000, requested 0x2, got 0x0
[    2.096083] ucsi_acpi: probe of USBC000:00 failed with error -12

journalctl --catalog --priority=3 --boot=-1

Apr 23 15:23:35 shah-xps159500 kernel: Spectre V2 : WARNING: Unprivileged eBPF is enabled with eIBRS on, data leaks possible via Spectre v2 BHB attac>
Apr 23 15:23:35 shah-xps159500 kernel: ioremap error for 0x4fe7b000-0x4fe7c000, requested 0x2, got 0x0
Apr 23 15:23:36 shah-xps159500 kernel: 
Apr 23 15:23:52 shah-xps159500 bluetoothd[1907]: src/plugin.c:plugin_init() Failed to init vcp plugin
Apr 23 15:23:52 shah-xps159500 bluetoothd[1907]: src/plugin.c:plugin_init() Failed to init mcp plugin
Apr 23 15:23:52 shah-xps159500 bluetoothd[1907]: src/plugin.c:plugin_init() Failed to init bap plugin

inxi --full

  Host: shah-xps159500 Kernel: 5.15.108-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.4 Distro: Manjaro Linux
  Type: Laptop System: Dell product: XPS 15 9500 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0HH6JF v: A00 serial: <superuser required> UEFI: Dell
    v: 1.22.0 date: 03/16/2023
  ID-1: BAT0 charge: 20.3 Wh (41.9%) condition: 48.5/84.3 Wh (57.6%)
  Info: 8-core model: Intel Core i9-10885H bits: 64 type: MT MCP cache:
    L2: 2 MiB
  Speed (MHz): avg: 800 min/max: 800/5300 cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 801 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800
    15: 800 16: 800
  Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nvidia
    v: 530.41.03
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting,nvidia
    unloaded: nouveau dri: iris gpu: i915 resolution: 1: 3840x2160~60Hz 2: N/A
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel UHD Graphics (CML GT2)
  Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel
  Device-2: JMTek LLC. MICUSB type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  API: ALSA v: k5.15.108-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Qualcomm QCA6390 Wireless Network Adapter driver: ath11k_pci
  IF: wlp108s0 state: up mac: 9c:b6:d0:3e:aa:70
  Local Storage: total: 953.87 GiB used: 296.69 GiB (31.1%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM981a NVMe 1024GB
    size: 953.87 GiB
  ID-1: / size: 229.89 GiB used: 90.08 GiB (39.2%) fs: ext4
    dev: /dev/nvme0n1p3
  ID-2: /boot/efi size: 499 MiB used: 74.2 MiB (14.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 702.09 GiB used: 206.54 GiB (29.4%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-1: swap-1 type: partition size: 4.88 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p2
  System Temperatures: cpu: 39.0 C pch: 53.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 330 Uptime: 46m Memory: 62.42 GiB used: 5.17 GiB (8.3%)
  Shell: Zsh inxi: 3.3.26

Just to add on to this, I have recently tried updating the firmware as well but found no difference.

Hi @alijay110,

Just checking, when last did you update?

If I’m not wrong, it was a week ago when I updated.

Hmmm…and your kernels all seem updated. At least to me.

It almost looked like the cause was that you need ibt=off flag for your kernel(s). But it has been sorted with the latest kernel updates, so I don’t know what else it can be.

After some Googling, I found this page that references this page:

And since it’s Dell, I figured it might be worthy checking out…


Thanks @Mirdarthos
I’ll give it a go then post the update.

I have tried disabling the psmouse, but still see this error:
ioremap error for 0x4fe7b000-0x4fe7c000, requested 0x2, got 0x0

Hi @Mirdarthos
I’m still having the same issue, its become quite frequent now, It started giving me problem in startup as well, does not start in one go I have to hard switch / reset at least 3 - 4 times to achieve the stable start of my machine.

Any help would be much appreciated


Hi again @alijay110,

I see this message was 6 months after the previous one. So let me start by asking when last you updated?

Also, it might be a good idea to start a new topic about this, as I don’t know what it could be, and that’ll get you more exposure. Feel free to reference this one.

Also, see if the problem persis with a later kernel (perhaps 6.1, which is the newest LTS.)