Delay autostart with plasma

Hello! before a few updates I got working a delay of seconds on a few apps with plasma to fix things that won’t work correct if instant autostart. But after a few updates I lost the possibility, I could recover disabling again the new autostart system, but again it’s the same and they are not working how it’s supppose to work.
So simply, how do you get a delay in your autostart apps when in plasma?
I mean a delay after logging in my session, that i think it’s the time when the autostart system has to start working… but idk anything more.

Usually you use something like

sleep 5 && things you launch

But … you havent provided what you are currently trying to use.
What are you trying to start and how?

1 Like

I tried that before. Actually it was working before the updates. But not now, either on autostart either on “edit applications” on the app menu plasma widget.

simply it doesnt start never.

Create a shell script to execute those commands, and use the script in that dialog :wink:

Open “Edit applications” dialog:

Program: sleep
Arguments: 5 && qbittorent


Program: bash
Arguments: -c ‘sleep [put number of seconds to sleep here] && [path to the program to execute]’

Don’t miss the single quotes.

I launch conky this way:

  1. Create and make it executable. Keep it in ~/Scripts or something tidy/easy.

  2. Autostart that script.

sleep 10
        conky -d -c /home/ben/Dropbox/Admin/conky/c0-time.conky
        conky -d -c ~/Dropbox/Admin/conky/c2-network.conky
        conky -d -c /home/ben/Dropbox/Admin/conky/c0-date.conky
        conky -d -c ~/Dropbox/Admin/conky/c4-disk.conky
        conky -d -c /home/ben/Admin/conky/c1-information.conky


Scripts are nice. You can also use something like kAlarm to launch them at specific times if you have a regular schedule… then you want a script to check if something’s running, and if it isn’t then launch it.

So for Dropbox this time, you could revise the script (still works for startup)


if pgrep -x "dropbox"
        then killall dropbox

This means it’ll launch or kill all, so it’s a toggle. I use it to run Dropbox for a couple of hours each day.

Have you tried to include the full path instead of only “qbittorrent”?

I think I can learn to do it. But I want to search, not only for me, but another ones. More easier…

it doesnt work.

it doesnt work eitehr…

i think I can do it simply, but… are something like gnome does? before was much simplier… why we complicate things!.-.-

yeah, I have do it right now trying the things I have replied. Nothing. Can you in your systems with plasma? have you tried?

Does sudo journalctl | grep qbittorrent spit something (watch the date, it could be an output in the past)?

I noticed that is not the same as '.


Program: bash
Arguments: -c “sleep 5 && qbittorent”

Make sure to TYPE it self and not copy paste, the forum sometimes changes quotes…

may 11 22:34:30 albertosobremesa plasmashell[1219]: QString::arg: 2 argument(s) missing in qbittorrent test

may 11 22:36:33 albertosobremesa plasmashell[1219]: QString::arg: 2 argument(s) missing in qbittorrent test

it doesnt work :frowning:

I think it is correct… right?

are these things working for you?