Default screen resolution gone after update. "error: target not found: linux65-nvidia"

Hello.
This text will be hidden
After updating and restarting the system, I got my default screen resolution
(1920x1080 what it should be) broken (1024x768 what it is now)!

I read around before posting this, so I tried to give as much information as I could!

Th reason why I did not want to do anything silly is because as I understood,
it might be a kernel related thing (upgrade & delete stuff), and I do not
fancy messing stuff up :slight_smile:

My system:

[me@me-me ~]$ uname -a
Linux me-me 6.5.13-7-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Dec 20 07:15:58 UTC 2023 x86_64 GNU/Linux
[me@me-me ~]$ uname -r
6.5.13-7-MANJARO
[me@me-me ~]$ mhwd-kernel -li
Currently running: 6.5.13-7-MANJARO (linux65)
The following kernels are installed in your system:
   * linux419
   * linux65

inxi -xxG

Graphics:
  Device-1: NVIDIA TU104GL [Quadro RTX 4000] driver: N/A arch: Turing pcie:
    speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1eb1
  Display: x11 server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    compositor: xfwm4 v: 4.18.0 driver: X: loaded: modesetting,nouveau
    alternate: fbdev,nv,vesa gpu: N/A display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1024x768
  Monitor-1: Unknown-1 mapped: None-1 res: 1024x768 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: swrast x11: drv: swrast inactive: wayland
  API: OpenGL v: 4.5 vendor: mesa v: 23.3.5-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
    device-ID: ffffffff:ffffffff

The issue:
I tried to lookup drivers in the “start menu”, and found through
Manjaro SettingsHardware Configuration
I then tried to apply the proprietary drivers to see if that would fix the issue,
however in a GUI box, I get the same message as the one for the
command below (I found the command in a post where someone had
a similar issue Link).

sudo mhwd -i pci video-nvidia

> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronising package databases...
 core downloading...
 extra downloading...
 multilib downloading...
warning: nvidia-utils-545.29.06-4 is up to date -- skipping
warning: libxnvctrl-545.29.06-1 is up to date -- skipping
error: target not found: linux65-nvidia
Error: pacman failed!
Error: script failed!

mhwd -l -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
   network-broadcom-wl            2018.10.07               false            PCI


Warning: No installed USB configs!
> 0000:49:00.0 (0200:14e4:43b1) Network controller Broadcom:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
   network-broadcom-wl            2018.10.07               false            PCI


> 0000:01:00.0 (0300:10de:1eb1) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Checking for updates:

sudo pacman-mirrors -f && sudo pacman -Syu

[sudo] password for me: 
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
  0.150 Sweden         : https://mirror.zetup.net/manjaro/
  0.142 Sweden         : https://ftpmirror1.infania.net/mirror/manjaro/
  0.155 Sweden         : https://ftp.lysator.liu.se/pub/manjaro/
::INFO Writing mirror list
::Sweden          : https://ftpmirror1.infania.net/mirror/manjaro/stable/$repo/$arch
::Sweden          : https://mirror.zetup.net/manjaro/stable/$repo/$arch
::Sweden          : https://ftp.lysator.liu.se/pub/manjaro/stable/$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronising package databases...
 core is up to date
 extra is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

Thanks for reading, all your tips or help is appreciated :slight_smile:

Kernel is EOL since last year. Please search before you post.

2 Likes

Hi @wreckchimpanzee,

This kernel is EOL, and has been for some time, if I’m not mistaken. So it, along with everything that uses it, has been removed from the repository.

You need to install a supported one. I recommend 6.6 as it’s an LTS version:

sudo mhwd-kernel --install linux66

Also install the headers, while you’re at it, since the headers are required for anything *-dkms related:

pamac install linux66-headers

See if that helps!

Edit:

This also means you haven’t updated your system since ±last year, which mean you’ve been a bad, bad boy. You need to maintain your system better, it seems.

So if my guess is correct, you’ll have quite a lot of .pacnew filed to deal with, which you should do, like, yesterday already. OK, just joking, but you _should _ have done it after every update, so do it now, too:

https://wiki.archlinux.org/title/Pacman/Pacnew_and_Pacsave

3 Likes

Thank you for the reply :slight_smile:

  1. sudo mhwd-kernel --install linux66

Done

  1. pamac install linux66-headers

Done

  1. [me@me-me ~]$ uname -a

Linux i-i 6.6.16-2-MANJARO #1 SMP PREEMPT_DYNAMIC Sat Feb 10 09:40:02 UTC 2024 x86_64 GNU/Linux

  1. [me@me-me ~]$ mhwd-kernel -li

Currently running: 6.6.16-2-MANJARO (linux66)

The following kernels are installed in your system:

  • linux419

  • linux65

  • linux66

  1. No changes happened compared the 1. post in the output of both

inxi -xxG

and

mhwd -l -li

  1. Finally, the issue stil persist:

[me@me-me ~]$ sudo mhwd -i pci video-nvidia


[sudo] password for me:

> Installing video-nvidia...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

:: Synchronising package databases...

core downloading...

extra downloading...

multilib downloading...

warning: nvidia-utils-545.29.06-4 is up to date -- skipping

warning: libxnvctrl-545.29.06-1 is up to date -- skipping

error: target not found: linux65-nvidia

Error: pacman failed!

Error: script failed!

pacman, yay, flatpak & snap has nothing to offer of updates either!

Define deal with!

I found 3 that I have by:

find /etc -name '*.pacnew' -o -name '*.pacsave'

Compare with:

vimdiff /etc/pacman.conf /etc/pacman.conf.pacnew

found that here:

https://bbs.archlinux.org/viewtopic.php?id=53532

This is a tangent that I can use some more time on later, but if you have a

short explanation, then it is appreciated.

That’s why it’s failing. And:

…you’ve still got it installed. So remove it:

sudo mhwd-kernel --remove linux65

Then try reinstalling the failures again:

Reinstall the nvidia driver:

sudo mhwd --force --install pci video-nvidia

More here:

I hope that’s everything, as I’d have to be off now.

2 Likes

Oh my GOD! So many more pixels <3

Going from 1024x768 to 1680x1050 feels like seeing 8k :smiley:

I now have to lookup .packnew and how to maintain it!

I need examples to understand!

Thank you for the help and the patience @Mirdarthos <3

2 Likes

Get in the habit or reading through the update Announcements, and thus preparing for any eventualities before applying the update.

Edit:

This is probably one of the best explanations I’ve ever read about what a .pacnew file is and why it has to be dealt with:

Packages include default configs to provide sane defaults. As software changes, the default config also changes. Old options get removed, new options get added, etc. But what if you change your config and the default config also changes? Arch doesn’t overwrite your configuration. It creates a .pacnew file containing the new recommended configuration and notifies you about it. It’s up to you to merge the upstream changes with your changes. If you don’t do that, your config might over time shift from sane to insane. Options were replaced by new ones, but your config still has old ones. Stuff breaks.

Also see:

https://wiki.archlinux.org/title/pacman/Pacnew_and_Pacsave

And:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.