Default file association is "Software Installer" for everything


I installed Manjaro a few weeks ago on my laptop, and I noticed that any time I double-click a text file in Dolphin, it tries to open it in the “Software Installer” application. This happens for everything I haven’t manually associated with something else.

Is there any way to change this globally? Currently, it seems like my only option is to manually change the file associations for everything one by one (in System Settings->Applications->File Associations).

I would much rather have something like Kate be the default for all text files.

What is the content of ~/.config/mimeapps.list and maybe also the content of ~/.local/share/applications/mimeinfo.cache ?

Here is ~/.config/mimeapps.list:

[Added Associations]
[Default Applications]

The file ~/.local/share/applications/mimeinfo.cache doesn’t exist.

It looks like that file includes the manual file associations I created in the system settings app. Deleting that file and relaunching dolphin seems to have made everything sane again; text files open in Kate, PDFs open in Okular, etc.

I wonder what broke it?


This was the problematic line, but yeah, deleting the file should permit you to start over with file association.

You probably made a file association yourself doing something at some point, I guess.

//EDIT: I had a similar issue at some point Application adds itself as default open action

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.