Dbus update, now system "failed to start"


NB: I cannot access the system on which this problem has occurred. I am posting from a different laptop.

I tried to do a standard update. It would not work due to a Dbus conflict. I searched the forum and found a topic that advised to re-install Dbus, which I did. Then I tried to restart, but I’m stuck at the “failed to start” screen.

  • Failed to start virtual console setup
  • Failed to start Load/Save Screen Backlight…
  • Failed to listen on Dbus system message bus socket
  • and lots more ‘failed to start’ messages, mostly Dbus

Please help, it’s my my partner’s computer and she needs it for work!

That would also have provided you with with a Y/n question - to replace with dbus-broker.

So I suggest you reinstall dbus-broker

Thanks. I can’t get into the system - could you advise or link to instructions?

Use a live ISO to boot and

manjaro-chroot -a
1 Like

Thanks linux-aarhus, I’ve never chrooted before! Now I know!

This topic was very helpful for the chroot and Dbus fix process: Manjaro breaks after failed system update - #2 by Mirdarthos

More about this:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Then, once inside the chroot environment, install the dbus-broker:

pamac install dbus-broker

If successful, exit chroot:


… and reboot:


It should be OK now. Theoretically

Hope this helps!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.