Cursor Lag/Stuttering

Hey All,

I just installed a fresh copy of Manjaro XFCE on my desktop at home and the only issue I am running into so far is a lag/stutter that is more visibly noticeable in the mouse. This happens even when i have just one app running or a simple file manager window, so I do no believe it is specific app issue. I have a strong feeling it has something to do with the latest nvidia 470 driver but I am no expert and wanted to see if anyone could help me troubleshoot this issue before switching back to another stable distro.

I was previously on Ubuntu/Kubuntu. I experienced this similar issue when I tried EndeavourOS.

Here are my PC specs. When I get home I can gather further information, outside of hardware if needed:

Intel Core i5-8600K CPU @3.6GHz (Coffee Lake)
Z370 Gaming Plus MSI Motherboard
EVGA GeForce GTX 1060 Superclocked 6GB DDR5
Samsung SSD 970 Evo 1TB
32GB DDR4/2400MHz TridentZ RGB
Logitech G Pro Wireless Mouse
LG 32" UltraGear QHD (2560x1440) 165Hz HDR 10 Monitor with FreeSync - 32GN600-B.AUS

Things I installed after the OS: Brave, Snap, Flatpak, 1Password, Piper, Standard Notes, Discord, Spotify

I also do not dual boot. This is a fresh install utilizing the entire M.2 SSD. After install I did do all of the updates that was suggested through the Apps & Software application. I believe that is it. Let me know if there is anything else I can provide. I can try doing a screen capture when I get home to show the issue and my system resources open if that helps.

1 Like

Welcome here, @thefireguy :wave:

Have a look into these threads, maybe there is a solution for you:

Yeah I did a lot of research into the issue before creating my account and gathering information regarding my system. None of the items you listed from that search ended up working for me.

I am just gonna switch back to Windows for stability sadly. Manjaro was my last ditch effort to stay with linux. Thanks for your time!

window magager tweaks, turn off the compositor

1 Like

I disabled the compositor, but I’d prefer not to do that as a solution. It strips away all the transparency in windows etc.

Also you will notice i have two DMs installed. I tried that last night to see if LightDM was the issue. Not sure how to uninstall GDM since that did not work. Another note is that I wish I saw the post on how to capture this info from the terminal before I started tinkering with the system to figure out the issue. The issue I am having was right after a fresh install with no modifications to the system.

      Kernel: 5.10.52-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
      parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
      root=UUID=384d6233-7e02-43be-9c40-d33ff01dd284 rw quiet apparmor=1 
      security=apparmor udev.log_priority=3 
      Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 2 
      dm: GDM 40.0, LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
      Type: Desktop System: Micro-Star product: MS-7B61 v: 1.0 serial: <filter> 
      Mobo: Micro-Star model: Z370 GAMING PLUS (MS-7B61) v: 1.0 serial: <filter> 
      UEFI: American Megatrends v: 1.B1 date: 04/19/2021 
      ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 4.1 min: N/A 
      model: Logitech G Pro Wireless Gaming Mouse type: N/A serial: <filter> 
      status: Discharging 
      RAM: total: 31.3 GiB used: 1.95 GiB (6.2%) 
      RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
      Info: 6-Core model: Intel Core i5-8600K bits: 64 type: MCP arch: Kaby Lake 
      note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: EA 
      cache: L2: 9 MiB bogomips: 43212 
      Speed: 1600 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 1600 2: 1600 
      3: 1600 4: 1600 5: 1600 6: 1600 
      Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
      avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
      cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
      flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
      hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
      mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
      pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
      rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 
      sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
      tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
      xsaves xtopology xtpr 
      Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
      Type: l1tf 
      mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
      Type: mds mitigation: Clear CPU buffers; SMT disabled 
      Type: meltdown mitigation: PTI 
      Type: spec_store_bypass 
      mitigation: Speculative Store Bypass disabled via prctl and seccomp 
      Type: spectre_v1 
      mitigation: usercopy/swapgs barriers and __user pointer sanitization 
      Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
      IBRS_FW, STIBP: disabled, RSB filling 
      Type: srbds mitigation: Microcode 
      Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
      Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: 
      driver: nvidia v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
      chip-ID: 10de:1c03 class-ID: 0300 
      Device-2: Logitech HD Pro Webcam C920 type: USB 
      driver: snd-usb-audio,uvcvideo bus-ID: 1-9:9 chip-ID: 046d:082d 
      class-ID: 0102 serial: <filter> 
      Display: x11 server: X.Org 1.20.11 compositor: xfwm4 v: 4.16.1 driver: 
      loaded: nvidia display-ID: :1.0 screens: 1 
      Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") 
      s-diag: 777mm (30.6") 
      Monitor-1: DP-4 res: 2560x1440 dpi: 93 size: 700x390mm (27.6x15.4") 
      diag: 801mm (31.5") 
      OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 
      v: 4.6.0 NVIDIA 470.57.02 direct render: Yes 
      Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI 
      driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0 
      class-ID: 0403 
      Device-2: NVIDIA GP106 High Definition Audio vendor: 
      driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f1 
      class-ID: 0403 
      Device-3: SteelSeries ApS Arctis Pro Wireless type: USB 
      driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-11.3:8 chip-ID: 1038:1294 
      class-ID: 0300 
      Device-4: Logitech HD Pro Webcam C920 type: USB 
      driver: snd-usb-audio,uvcvideo bus-ID: 1-9:9 chip-ID: 046d:082d 
      class-ID: 0102 serial: <filter> 
      Sound Server-1: ALSA v: k5.10.52-1-MANJARO running: yes 
      Sound Server-2: JACK v: 0.125.0 running: no 
      Sound Server-3: PulseAudio v: 14.2 running: yes 
      Sound Server-4: PipeWire v: 0.3.32 running: no 
      Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
      v: kernel port: f000 bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200 
      IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
      IP v4: <filter> type: dynamic noprefixroute scope: global 
      broadcast: <filter> 
      IP v6: <filter> type: noprefixroute scope: link 
      Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 
      bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280 
      IF: wlp3s0 state: down mac: <filter> 
      WAN IP: <filter> 
      Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 
      bus-ID: 1-13:6 chip-ID: 8087:0029 class-ID: e001 
      Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
      Message: No logical block device data found. 
      Message: No RAID data found. 
      Local Storage: total: 1.36 TiB used: 19.36 GiB (1.4%) 
      SMART Message: Required tool smartctl not installed. Check --recommends 
      ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB 
      size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
      lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 31.9 C scheme: GPT 
      ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital 
      model: WDS500G2B0A-00SM50 size: 465.76 GiB block-size: physical: 512 B 
      logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 30WD 
      scheme: GPT 
      Message: No optical or floppy data found. 
      ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%) 
      used: 19.36 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
      label: N/A uuid: 384d6233-7e02-43be-9c40-d33ff01dd284 
      ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
      used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
      label: NO_LABEL uuid: 73DB-4933 
      Alert: No swap data was found. 
      ID-1: /dev/sda1 maj-min: 8:1 size: 465.76 GiB fs: ntfs label: N/A 
      uuid: 21D0DADF1CF7194B 
      Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
      speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
      Device-1: 1-2:2 info: Logitech USB Receiver type: Keyboard,Mouse,HID 
      driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
      power: 98mA chip-ID: 046d:c539 class-ID: 0300 
      Device-2: 1-7:3 info: Kingston HX-KB4BL1-US [HYPERX Alloy FPS Pro] 
      type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
      speed: 12 Mb/s power: 480mA chip-ID: 0951:16d2 class-ID: 0300 
      Device-3: 1-9:9 info: Logitech HD Pro Webcam C920 type: Video,Audio 
      driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
      power: 500mA chip-ID: 046d:082d class-ID: 0102 serial: <filter> 
      Hub-2: 1-11:5 info: Texas Instruments TUSB2036 Hub ports: 3 rev: 1.1 
      speed: 12 Mb/s chip-ID: 0451:2036 class-ID: 0900 
      Device-1: 1-11.2:7 info: SteelSeries ApS Arctis Pro Wireless type: HID 
      driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
      power: 500mA chip-ID: 1038:1290 class-ID: 0300 
      Device-2: 1-11.3:8 info: SteelSeries ApS Arctis Pro Wireless type: Audio,HID 
      driver: hid-generic,snd-usb-audio,usbhid interfaces: 6 rev: 1.1 
      speed: 12 Mb/s power: 100mA chip-ID: 1038:1294 class-ID: 0300 
      Device-3: 1-13:6 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
      interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029 
      class-ID: e001 
      Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s 
      chip-ID: 1d6b:0003 class-ID: 0900 
      System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 48 C 
      Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
      Processes: 265 Uptime: 6m wakeups: 2 Init: systemd v: 248 tool: systemctl 
      Compilers: gcc: N/A Packages: 1081 pacman: 1067 lib: 299 flatpak: 6 snap: 8 
      Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06

What happens if you disconnect your various hubs and devices connected via USB? Any improvement? Also, do you have a cabled mouse to compare?

nvidia doesn’t play well with compositors.
i did see a blip about them having it working with gnome/mutter, but it’s just something i glanced over.
use your google foo.

1 Like

Can you see if this happens with KDE then?

Note this is not recommended.


I’ve had this same exact issue back when I had an EVGA GTX 1060 6GB. For me, it occured more prominently while opening just about any window. The stutters annoyed me so much that I posted about it in the old Manjaro forums last year but never got any solution.

I then slowly learned that Nvidia drivers, both proprietary and Nouveau, have poor desktop performance in Linux in general, especially with KDE. The performance issues got so bad that after I installed the Plasma 5.21 update earlier this year, the compositor would just crash unexpectedly every few hours. Luckily, I swapped my Nvidia card with a Windows gamer friend’s Radeon RX 570 almost two months ago, and I’ve never been happier since. Other than the rare glitchy effects for a split second when opening Firefox, the compositor crashes and cursor and animation stuttering have stopped entirely.

I totally agree with @kerry_s here, and it’s unfortunately the truth. It’s a shame that Nvidia’s lackluster support for Linux severely limits the full potential of their powerful GPUs unlike on Windows, and that was the other reason why I decided to switch to an AMD card. So, the best advice I can give you at this time is if you plan to stay on Linux full-time, you should switch to an AMD graphics card whenever you can.

Edit: I forgot I saw that you’re new here, so allow me to welcome you to the Manjaro forums.

Thanks everyone for helping on this. I did a lot of research on this and I knew that Linux struggled with Intel/Nvidia PCs but I went ahead and tried it anyways to see if I could in fact make a full switch. After distro hopping, playing with different display managers and desktop environments I came to the conclusion that my PC is just not supported well enough for what I am looking for right now.

As much as I despise windows it works out of the box for me and my hardware right now. I will continue to keep my eyes on Nvidia/Intel news with Linux and hope that in the near future I can return to a Manjaro setup.

Ubuntu out of the box worked the best for my system but it felt like MacOS and I wasn’t looking for that. I tried changing Desktop environments but the moment I did that the problems started to surface.

Again, thanks everyone for chiming in and trying to help on this one. I basically needed someone to reaffirm that Nvidia and Compositors don’t play nicely and that is enough for me to hold on making a full switch at this moment.

1 Like

Nvidia does play nicely with compositors if you disable vsync in those compositors. I’m using Nvidia 470 and XFCE.

In the XFWM4 settings (accessible via “Settings Editor”, the xfconf GUI), I have:

  • use_compositing set to true (boolean value)
  • sync_to_vblank set to false (boolean value)
  • vblank_mode set to "off" (string value)

In nvidia-settings, I have “Force Composition Pipeline” enabled, and saved to my /etc/X11/mhwd.d/nvidia.conf file.

After setting those options and rebooting, everything will be smooth as silk.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.