Mouse cursor stutter/lag

Installed Manjaro XFCE a few weeks ago. It was going so well! And yet, over the past couple of days, I’ve developed mouse stuttering issues independent of CPU/GPU load or application usage. Periodically (about once per secondish?) the mouse will lag, then jump, no matter the speed of the cursor.

OS: Manjaro Linux x86_64
Kernel: 5.15.32-1-MANJARO
CPU: Intel i7-9700F (8) @ 4.700GHz
NVIDIA drivers: Proprietary (video-linux)

What I’ve tried so far for the stutter:

  • Swapping mice. Occurs on both wired and wireless mice
  • Swapping ports. Occurs both when plugged into a powered USB hub and when plugged directly to a port on the motherboard
  • Swapping mouse pads. No joy.
  • Swapping operating systems. Issue does NOT occur on Windows on the same hardware.
  • Disabling mouse acceleration. Problem persists.
  • Disabling compositor. Problem persists.
  • Rolling back my OS a couple days with Timeshift when this problem didn’t happen (same kernel). No improvement.

No errors or notable output in dmesg now that I can perceive. X is maaaaaaaybe running a little hot on htop (25-35% CPU is a little higher than I’m used to on XFCE, but not outlandish)? I’m not seeing any spikes in CPU or memory usage when I move my mouse around. At this point, I’ve run out of likely suspects in search results, and I don’t even know what hardware/software system might be implicated in the issue.

Any help would be appreciated!

I am newbie, I hope it doesn’t sound so obvious :nerd_face: but still:

Did you try another kernel? Does the problem persist?

No not at all! Really good check, and I hadn’t yet! The problem did persist on another kernel, though.

I’m also getting some strange frame rate issues when I tested a game (vsync locked to 75% of my refresh rate), so I’m beginning to think NVIDIA drivers are implicated somehow. That said, I hadn’t updated them since the issues began, and the Timeshift restore didn’t fix the issue, so I have no idea how it might be the drivers’ fault…

Well try maybe disabling vsync:

xfconf-query -c xfwm4 -p /general/vblank_mode -s off

Tried that while following suggestions from a previous support thread for a similar issue—it was actually part of why I tried hopping into a game to see how it ran, which was how I noticed the vsync issue. Anyway, disabling it had no effect.

Prior to my issues the past couple days, I’ve had no issues either with or without vsync, and when vsync was enabled, it worked perfectly.

Erm… can you post your full system info?

inxi --admin --verbosity=7 --filter --width
mhwd -l && mhwd -li

video-linux is not the proprietary nvidia driver.

You’re totally right; I was looking at “video-linux” while trying to TYPE “video-nvidia.” FWIW, video-nvidia is what I have installed.

At any rate, the problem seems solved for now. For posterity’s sake to anyone seeking solutions in future? ALWAYS double check your cables, even if it makes no sense to do so. I unplugged one of the two HDMI cables attached to my monitor in case there was an electrical interference thing going on somehow. That did nothing, but in the process of plugging it back in, I think I re-seated my computer’s HDMI cable. Now everything’s smooth. Go figure.

I don’t fully understand why a graphical stutter caused by a cable issue didn’t show up on Windows; maybe I had some triple buffer or something activated to smooth out the stutter. Either way, crossing my fingers and thanking the Manjaro support community for your kind assistance!

I tried this on Linux Mint and literally this solved my issue. I wanted to hop on here and say thank you because I was fretting over possibly having to hop ships again. I am grateful to have found this answer, thank you so much!
-also might have made this account solely to thank you-