Ctrl+Alt+F2 showing boot splash screen

Not sure what you mean by this, but I have been thinking about it all night, had a hard time sleeping. Do I upset people by not understanding? Now I’m starting to be afraid to ask, this is still very unclear to me.

Is this the expected behavior by using nvidia and manjaro (not being able to use ctrl+alt+f?)?
Where is the fault/bug casuing this? Is it nvidia? Manjaro? Plasma? Kde? SDDM?

I changed back to the drivers I originally ran, video-hybrid-amd-nvidia-prime and I get EXACTLY the same result whether I run with prime-run prefix or not, it only reports the nvidia card.

$ glxinfo | grep 'renderer string'
OpenGL renderer string: NVIDIA GeForce RTX 3090/PCIe/SSE2

$ prime-run glxinfo | grep 'renderer string'
OpenGL renderer string: NVIDIA GeForce RTX 3090/PCIe/SSE2

I ask again, because this is VERY weird to me, is this not fixable? Are you guys saying I should give up on this and go back to windows? I REALLY DON’T WANT TO, but I do NOT want to rely on an os where one of the core mechanics are broken, and nobody seems to know WHY it’s broken. It just seems very… not smart and a crash waiting to happen.

I’m so scared to ask now. Went from being super impressed to not trusting the os at all… :frowning:

previously you said you used video-nvidia. So of course it would work like that, you don’t have hybrid support installed. Since video-nvidia did not fix your issue, just go back to the hybrid driver. Maybe even test the older series 470xx version just to rule out one possible reason for your VT problem.

OR just use video-linux, if i understood correctly it made your VT work. But you miss out on many features of your gfx card.

I never said I “used video-nvidia” I followed YOUR advice and bugtested, ie, testing all different drivers and happened to end up with the video-nvidia because I saw no difference in performance no matter what driver I was using (prime or “normal”). I REMOVED my nvidia drivers and fell back to video-linux (thats when I realized changing tty WORKS with video-linux drivers and asked what drivers to install and understood it as I was recommended to try them all. I just HAPPENED to end up with video-nvidia because that was the last I tested.

I don’t want to upset ppl any more, I give up I guess.

just keep calm and try installing video hybrid amd nvidia prime 470xx

if it works, congratulations: you just located the problem to be latest nvidia driver. If it does not work, then you only know something with at least 2 series of nvidia driver is causing an issue for you… And you can live with it, use video-linux, throw away the nvidia card and use integrated one, or switch to windows to “fix it” :smiley:

I have already answered that the only driver working is video-linux, no other drivers no matter how old or new works with other ttys.

Great comment! Yeah, I’m out.

Ok, if that is what you recommend I guess windows it is.

Edit. If anybody actually want the solution, dm me. Nvidia is not the “problem” here.

That’s not how open source or forums work, please be kind enough to post the cause/solution so everyone can see.

1 Like

If linux open source drivers work, nvidia ones don’t, does it not seem that the problem is with nvidia’s closed drivers? That nvidia is responsible for.

I removed solution marking from post #46 because response does not explain how to resolve the original problem

This is a Civilized Place for Public Discussion | forum.manjaro.org/guidelines


I have the same problem - what was the solution?

Why wouldn’t you have provided it in the first place?

Please provide it by adding to this thread.

I was also having this problem on my PC. Started … maybe a couple of months ago and a few kernels back?
Anyway, I had 2 GPUs - one nVidia, one AMD. I yanked the AMD one out as I was no longer really using it and the problem went away. What I suspect happens is that it was actually outputting the TTY on the AMD videocard somehow. I tried removing the hybrid drivers, that didn’t help.
So if you have a dual GPU setup - this is probably the reason - as for the fix, if you can, get rid of one, or try to blacklist its GPU if you are not using it(I should have done that, but in my case that GPU was just wasting power in my PC).
P.S. if the integrated GPU is enabled, try disabling it as well.

1 Like

Thanks! black listed i915 in grubs kernel cmd line, and now it works.

This is a weird bug - why would the tty decide to render to a different GPU than X? I feel like black listing the second GPU is a decent workaround for most - but what if I wanted one GPU for rendering, and the other for compute? This bug should be reported - the question is: where?

You can mark @crazyquark’s reply as the answer.

tty is handled by kernel, long before X or DE starts. So the priority should be handled on the driver/kernel level.

In your case the problem might have been fixed by a common BIOS/UEFI option called “graphics init first” “video output priority” or similar, where you choose integrated or pcie. This would however not work with two graphics cards, maybe then the order is determined by the physical slot number the card is installed in on the motherboard? If there is no way to determine it via kernel/driver config.

I remember having one motherboard where the manual said that if one card is installed, then it must be in slot#1 as slot#2 is only for additional cards.

But tty gets started only after I press ctrl+alt+FN to change to VTN (except for tty1, which starts at boot). And X is also started in a VT (in my case 7), so it’s possible to tell the VT what GPU it’s supposed to use after the fact.

I think once tty gets started upon switching to the relevant VT, it should render to whatever GPU X renders to.

I think it used to be the behavior not long ago. I remember having both iGpu and dGpu enabled and having no problems rendering tty.

Also, if it was the iGpu rendering during boot, I would have gotten no signal on my monitor, as it is connected to the dGpu… So it does render correctly up until X starts…
And yet another weird thing that doesn’t add up - when it was “stuck” because of the wrong gpu being utilized, it wouldn’t get any input from the keyboard either - I’ve tried blindly putting in my user name and password and checking for open sessions - and only my X session showed up… So it wasn’t running and just outputting the video to the wrong place, it was stuck.