Ctrl+Alt+F2 showing boot splash screen

Oh, THOSE, they are very old, but not open source right? They are just older version of the drivers no longer being updated if I understand it correctly?

The question is, Have I really tried the open source drivers, the button fails.
Again, sorry for nagging.
“Now thinking about it, when pressing the “run with open source drivers” in the boot menu of the live usb stick, does it actually run with those drivers or is it only marking the “install” for that? I didn’t check the drivers when running the stick, but now thinking about it, don’t you think the reason it worked is because it is running the video-linux drivers?”

Ah, that 470 is old version, while the other is the current? Then it would be bad to stick to old version, but trying it might help troubleshoot…

As i said in the edit of my previous post, yes, using basic fallback driver is a possibility, it works with your tty problem, but your graphics card works like one from 10 years ago.

until nvidia comes to their senses, you need a proprietary driver for your modern card to work properly. Older cards work well with open source driver. Modern ones don’t.

Aaah, I see.

So… Does anybody know how to change to open source drivers to just try? Because running old unsupported non-free nvidia drivers is not something I’m willing to do, even if the tty works. Up to date open source I’m more than willing to try, if I just knew how to do it without reinstalling manjaro.

I feel this has less to do with nvidia and more to do with kernel or smthn. If tty2 was pitch black and my monitor went to sleep, yes I would blame the gpu or drivers, but it doesn’t, the video card still works on all ttys, its just that the shell is not starting.

Just realized, there are a lot of ports to connect monitors on the gpu, I dont have converters so I can only use the hdmi out, but could it be that the shell is run on another output?

if you uninstall the proprietary driver then you will boot with open source nouveau kernel driver (video-linux)

edit: that might be one of the best things to try. It should not matter, but who knows?

Yes, that is working, that conclusion came when uninstalling the drivers.

I think we are talking about different things, you keep mentioning the video-linux divers.
When I say open source drivers. I’m not talking about the linux drivers, I’m talking about nvidia open source drivers.

the fact it has no checked box tells you it is not open source


i don’t understand, see here

I’ll try this.

I think you missed this. I TRIED uninstalling, rebooting, and then trying the open source button but it did not work.

I know little about hybrid GPUs but you’re “guessing” what is that you’re running. Just list the inxi -G as you did at the start, there it shows you have 2 drivers, nvidia and amdgpu (look or grep for ‘driver’). So whatever you do, before and after test what’s actually loaded (or after reboot). You can also use lsmod to list modules (and drivers) loaded (e.g. grep -i ‘nvidia’ or amdgpu or so, try different things).

Also you could try unloading one of the drivers by doing e.g. the modprobe -r amdgpu - that’s temporary (after restart all is back or you can load it modprobe amdgpu but there may be more modules so might not work) - and see how it goes (but also check w/ inxi and/or lsmod to test what’s actually loaded/running).

Just wanted to add this in case it helps.

most probaby because you already use it. To me it seems it’s function is “if you are using proprietary/VESA/modesetting, press here to switch to nouveau”

Because without doing anything, you should already run nouveau after first boot (like with live usb free option)

Maybe (read. most likely) I’m an idiot here. I removed my nvidia drivers and figuered I should install them in cli instead.

So after a reboot:
mhwd -l --pci does not list any nvidia drivers that ARE open source, is that what you have been trying to tell me the whole time?
Or is there a repository I should install from?

I’m probably an idiot.

i think video-linux is the open source nvidia driver, aka nouveau kernel driver.

Well, it’s not the driver in that checbox I circled in my picture. I guess that does not exist?

that would most probably be latest proprietary nvidia without hybrid

Now you are confusing me again.

I want to install the open source drivers. I do not know how, do they exist??

mhwd -l --pci

> 0000:01:00.0 (0300:10de:2204) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2023.03.23               false            PCI
video-hybrid-amd-nvidia-470xx-prime            2023.03.23               false            PCI
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:15:00.0 (0300:1002:164e) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2023.03.23               false            PCI
video-hybrid-amd-nvidia-470xx-prime            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Is this it?

OK … everyone take a breath.

Its very simple … video-linux is an umbrealla for all open drivers … nouveau, intel, amdgpu, etc.
If you have 2 open driver powered cards, ex intel+nouveau then you dont need to do anything else … PRIME will work with DRI_PRIME=1 … just like nvidia+intel would work with prime-run, just different drivers for the nvidia card and slightly different invocation.

So … no, your image with the arrows is incorrect. The columns show what they mean … a check in the ‘open-source’ column means open source … the ‘installed’ column means whether or not its installed.
Currently you have one installed profile, which is open source, video-linux. The arrows point at video-nvidia which is neither open nor installed. It is also not what you want … because you dont just have an nvidia card. Things will likely not work if you attempt to use that profile.

If you want to saty with open drivers (amd+nouveau) then keep it as is … if you want the ‘best’ for your proprietary nvidia card … then use one of the hybrid profiles. Likely you want the most current one video-hybrid-amd-nvidia-prime.

All of this is pretty well documented at the wiki.

And just to touch on your firmware thing…

If you think you have those devices, want that firmware, etc … then see this:
(install the applicable packages if desired)


Thank you!
I have studied that wiki a lot since starting this.
I’m still a little confused though, and have a question.

The reason I made the picture with the arrows was because that was what I wanted and was asking how to get to that point, but now I kinda see it doesn’t exist if I understand you correctly?

I used to run the video-hybrid-amd-nvidia-prime drivers but because I wanted to fix obs have now changed to video-nvidia and at the same time looked into why I can’t change tty.
Everything works as before, same performance etc. Or are you saying the hybrid prime driver will utilize my onboard card when not needing the power and sending the output through the gpu port, ie saving valuable electricity? Then I’ll change back because I think I can get obs working with both drivers now, I just went with the “normal” one because I don’t have anything connected to the onboard hdmi.

Now, again so I really understand (this is what is making me so confused) there is no way to get the checkbox for “open source” checked (the one I marked as open source in the picture) correct?

So, then I have a question, is there no way to force the use of specific drivers in certain situations, like when pressing ctrl+alt+f2? Becuse if I run with the video-linux drivers, other tty:s work. And that is why I have been nagging so much about the checkbox for open source next to the nvidia drivers.

They arent checks you need to make … they are checks showing what is. Those profiles (*“nvidia”*) are not open source - hence they will never have a check in that column.

The way prime works (though this can go the other way - ‘reverse prime’) by using the iGPU by default and using the dGPU when you call it. Ex:

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

Assuming all is working correctly … While using one of the ‘prime’ profiles your system should be running the same as if you were using ‘video-linux’ until you use prime-run, because in both cases it should be running the (open) amd by default.

amdgpu by default - prime-run - proprietary nvidia

amdgpu by default - DRI_PRIME=1 - opensource nouveau

So this gfx card switching works also on desktop computers, not only laptops with hybrid installs? Should the monitor be connected to the internal gfx card’s port, or the discrete cards’s, or does it not matter?