Ctrl+Alt+F2 showing boot splash screen

I write this here because I think this is related both to kde/plasma and graphics. If this is in wrong forum, please inform me.

As stated in topic, changing tty does not mean it goes black, it shows my boot splash screen on all other than f1 witch is not the same as it going pitch black, ie the gpu outputs a signal, but no shell is loaded I guess?

Been trying to find anything about this but all I find is about ppl not having any output at all when trying ctrl+alt+f2.

System:
  Kernel: 6.1.23-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=6995920c-67a8-4f61-a8a6-fc263b415d1f rw rootflags=subvol=@ quiet
    splash resume=UUID=96dd6227-32fb-440a-8ba4-507515ed9f19
    udev.log_priority=3 acpi_enforce_resources=lax
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: X670 AORUS ELITE AX v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: X670 AORUS ELITE AX v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F8a
    date: 03/22/2023
CPU:
  Info: 12-core AMD Ryzen 9 7900X [MT MCP] arch: Zen 4 speed (MHz): avg: 3221
    min/max: 3000/5733
Graphics:
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com. driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
  Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1, DP-2, DP-3,
    HDMI-A-1 bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 45.0 C
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: amdgpu,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    dri: radeonsi gpu: nvidia,amdgpu resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
    3090/PCIe/SSE2 direct-render: Yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0f:00.0
    chip-ID: 14c3:0616 class-ID: 0280
Drives:
  Local Storage: total: 4.09 TiB used: 1.34 TiB (32.6%)
Info:
  Processes: 468 Uptime: 6h 10m wakeups: 0 Memory: 30.5 GiB
  used: 7.64 GiB (25.1%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1309
  pm: pacman pkgs: 1303 libs: 358 tools: pamac pm: flatpak pkgs: 6 Shell: Zsh
  v: 5.9 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.26

journald output when trying to change tty:

16 Apr 2023 00:03:44	pulseaudio	Error opening PCM device front:2: No such file or directory
16 Apr 2023 00:03:44	plasmashell	org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_01_00.1.hdmi-stereo"
16 Apr 2023 00:03:55	kwin_x11	kwin_core: XCB error: 152 (BadDamage), sequence: 8229, resource id: 17846696, major code: 143 (DAMAGE), minor code: 3 (Subtract)
16 Apr 2023 00:03:56	xembedsniproxy	Container window visible, stack below
16 Apr 2023 00:03:56	kwin_x11	OpenGL vendor string:                   NVIDIA Corporation
16 Apr 2023 00:03:56	kwin_x11	OpenGL renderer string:                 NVIDIA GeForce RTX 3090/PCIe/SSE2
16 Apr 2023 00:03:56	kwin_x11	OpenGL version string:                  3.1.0 NVIDIA 530.41.03
16 Apr 2023 00:03:56	kwin_x11	OpenGL shading language version string: 1.40 NVIDIA via Cg compiler
16 Apr 2023 00:03:56	kwin_x11	Driver:                                 NVIDIA
16 Apr 2023 00:03:56	kwin_x11	Driver version:                         530.41.3
16 Apr 2023 00:03:56	kwin_x11	GPU class:                              Unknown
16 Apr 2023 00:03:56	kwin_x11	OpenGL version:                         3.1
16 Apr 2023 00:03:56	kwin_x11	GLSL version:                           1.40
16 Apr 2023 00:03:56	kwin_x11	X server version:                       1.21.1
16 Apr 2023 00:03:56	kwin_x11	Linux kernel version:                   6.1.23
16 Apr 2023 00:03:56	kwin_x11	Requires strict binding:                no
16 Apr 2023 00:03:56	kwin_x11	GLSL shaders:                           yes
16 Apr 2023 00:03:56	kwin_x11	Texture NPOT support:                   yes
16 Apr 2023 00:03:56	kwin_x11	Virtual Machine:                        no
16 Apr 2023 00:03:56	kwin_x11	GlideConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	BlurConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	ZoomConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	WindowViewConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	SlidingPopupsConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	SlideConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	OverviewConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	KscreenConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	kwin_x11	DesktopGridConfig::instance called after the first use - ignoring
16 Apr 2023 00:03:56	plasmashell	Could not find the Plasmoid for Plasma::FrameSvgItem(0x55866c295e50) QQmlContext(0x55866ba15640) QUrl("file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml")
16 Apr 2023 00:03:56	plasmashell	Could not find the Plasmoid for Plasma::FrameSvgItem(0x55866c295e50) QQmlContext(0x55866ba15640) QUrl("file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml")
16 Apr 2023 00:03:56	plasmashell	[GFX1-]: GFX: RenderThread detected a device reset in PostUpdate
16 Apr 2023 00:03:56	kcminit	Initializing  "/usr/lib/qt/plugins/plasma/kcms/systemsettings/kcm_mouse.so"
16 Apr 2023 00:03:56	kcminit	Initializing  "/usr/lib/qt/plugins/plasma/kcms/systemsettings/kcm_touchpad.so"
16 Apr 2023 00:03:56	kcminit	kcm_touchpad: Using X11 backend

I have had this behavour since install but never really cared, but now I wanted to get OBS running and it didn’t ofc. And fixing it seems to involve removing and reinstalling drivers, and that might force me to use other ttys if something fails. Sooo, here we are.

Help please.

I wonder …

In /etc/systemd/logind.conf is there option NAutoVTs=6 or similar ?
(maybe tinker with it?)

You can also try to temporarily start a getty@ttyN.service service directly.

cat /etc/systemd/logind.conf | grep -i nautovts 
#NAutoVTs=6

Witch according to the wiki means it defaults to 6.
So I looked into the services running, and there are indeed 6, 5 of them were running, maybe because I had already pushed f2-f6 or maybe because they spawn at boot, but the one NOT running is getty@tty1.service. Is that correct?
I also stopped tty2.service and then tried ctrl+alt+f2 but the same behavior, only boot splash screen.

Edit. They were started because I had pressed the f keys. After a reboot tty1 is loaded/inactive (dead), preset enabled and service is enabled. The rest, 2-6 loaded/inactive (dead), preset enabled but the service is disabled???

sudo systemctrl status getty@tty1.service

○ getty@tty1.service - Getty on tty1
     Loaded: loaded (/usr/lib/systemd/system/getty@.service; enabled; preset: enabled)
     Active: inactive (dead)
       Docs: man:agetty(8)
             man:systemd-getty-generator(8)
             http://0pointer.de/blog/projects/serial-console.html

sudo systemctrl status getty@tty2.service

○ getty@tty2.service - Getty on tty2
     Loaded: loaded (/usr/lib/systemd/system/getty@.service; disabled; preset: enabled)
     Active: inactive (dead)
       Docs: man:agetty(8)
             man:systemd-getty-generator(8)
             http://0pointer.de/blog/projects/serial-console.html

So I just went through this myself a few hours ago and this is what I did that fixed it.

  • Reboot PC and enter BIOS setup

  • Once in BIOS setup look for an option labeled “Splash Screen” or “Fast Boot” and disable them. (For me I only had the “Splash Screen” enabled)

  • Save changes and reboot PC, now try accessing TTY console

I don’t have any logs or really any other information as to how it worked. But it solved the exact issue you are describing. Using ctrl+alt+f2-f6 all would take my to my splash screen. And then ctrl+alt+f1 would bring me right back to my desktop. I also had the same issue as you and couldn’t find a single thing on it anywhere, so hopefully this works for you as well.

That is not it.
Disabling the boot splash removes the picture, but the screen is still black when changing tty but its not “turned off”, the gpu is clearly trying to send something, it just seems the shell is not loaded.

Where do I report this because its clearly a bug? Kde? Nvidia? Arch?

Now it has turned into something that is blocking my usage of manjaro and I REALLY don’t want to drop linux and go back to windows.

first thing to do is probably switching from nvidia to kernel (nouveau) gfx driver and see if problem persists.

After that it narrows down quite significantly where to direct the bug report.

Well, that was my plan to do when this thread started. I wanted to play around with the gpu drivers and for me to feel safe I wanted to have access to a terminal if the gpu output fails somehow.

But ok, lets just dive into it without safety nets. :frowning:
I guess I have an ssh server running, worst case scenario I have to use my android and read the 4px big text. xD

When you say “change to kernel drivers”, do you mean remove “video-hybrid-amd-nvidia-prime” drivers and use “video-linux”?

Maybe video-nvidia ? Video-linux sounds like most generic driver.

Since you have rtx3090 nouveau probably won’t work “properly” as it lacks many features, but what you can most probably do is to ascertain if the issue is with graphics driver, or deeper in the stack/with your install.

Another thing you could try is to just use the straight-up nvidia driver, without the hybrid part. Are you using the integrated GPU for a monitor? If not, i see no need for the hybrid.

I thought the hybrid was needed if I had internal graphics card, and prime is their latest drivers for their latest lineup (even though im 30 series) that’s why I choose it.

Cross your fingers, I’ll make myself a cup of coffee and then start playing around and come back with results to see if we can get to the bottom of this.

AFAIK only if you use the internal card. As in connect a monitor to it. At least i have never needed to care about the internal card ever, as i never connected a monitor to it.

ok. I uninstalled the hybrid-prime drivers and installed video-nvidia (afak it is not open source, I selected proprietary drivers on install.

Broke a ■■■■■■■■ of other programs that depended on stuff the old driver installed, but I’ll deal with that later.
And when installing:

==> WARNING: consolefont: no font found in configuration
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'

It did not change anything, I still get the exact behavior when changing tty.
How do I continue from here.

Graphics:
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com. driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0
    chip-ID: 10de:2204 class-ID: 0300
  Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1, DP-2,
    DP-3, HDMI-A-1 bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300
    temp: 43.0 C
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia,amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
    s-diag: 693mm (27.28")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 79
    size: 621x341mm (24.45x13.43") diag: 708mm (27.89") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
    3090/PCIe/SSE2 direct-render: Yes

EDIT.
I Have found the culprit, I think.
I had a USB stick with a manjaro install, booted with it and ran proprietary drivers, same behavior.
Well, now that I have the stick here, lets reboot and try the open source drivers and behold, other ttys work.
So, how do I move forward? I’m really out of my comfort zone here. :open_mouth:
Do I just click “auto install open source driver”? Is it really that simple??!?

possibly missing firmware is normal, you most probably had that all along, i do as well.

Yes, boot your normal install and click auto install open drivers, no use in doing it in live install.

If that works, then issue is with nvidia-hybrid. If it does not work, then issue is with your main system config.

only thing i can think of left at that point is to try install proprietary driver without hybrid. (this only if live usb uses hybrid by default for you, if it just uses plain driver, no need to try as it did not work in live usb for you)

But I don’t use the hybrid any more, I changed to “video-nvidia”.
The “video-linux” driver has always been installed on my system since install so I figured it was something needed. Are you saying I don’t really need them? And on the picture I uploaded of my drivers, I never use the internal card (ATI technologies), can/should I uninstall them. I have 2 drivers installed (see pic) on the 3090 apparently, how do I know witch one is being used? And same question here, should I remove “video-linux”?

Edit. When running my usb manjaro install, I can choose between open source and not. Only if using open source can I use other ttys.

did you try “auto install”?

video-linux is afaik fallback when other fails. It cannot/should not be uninstalled AFAIK

Not yet, I’m in the middle of something and cant reboot now. I’ll come back with an update in a short while.
I REALLY appreciate you holding my hand here. <3

i’m not holding your hand, just shooting ideas without really knowing :smiley:

anyhow, in the end, trying “auto install open source” is just for troubleshooting. You pretty much NEED the proprietary driver as nvidia is such a POS with their support. IF you use open drivers with your card, 80% of it’s performance won’t be there.

I’m about to try to autoinstall open source now.

Is there any way of having both installed and manually changing them somehow? I really want to get my full potential, otherwise my stupidly powerful computer was a stupid buy. :frowning:
Or will this in some way let me find the reason why the drivers im running right now are not working with other ttys?

Ok, so here is what is happening.
I tried pushing the auto open source button but it just reported that drivers were already installed and did nothing.
So I removed the nvidia drivers and tried pushing the button, but then it only identified my onboard ATI card.
Rebooted and tried, same thing, only finding the ATI card with the button so I installed the video-nvidia again.
But before rebooting I tried tty2 and it works flawlessly with the video-linux drivers so that got me thinking. Is there a way to force the new tty to use the linux drivers instead of nvidia, that would probably solve my problem.

Edit.
Now thinking about it, when pressing the “run with open source drivers” in the boot menu of the live usb stick, does it actually run with those drivers or is it only marking the “install” for that? I didn’t check the drivers when running the stick, but now thinking about it, don’t you think the reason it worked is because it is running the video-linux drivers?

most probably not.

you only have one thing left to try, install the proprietary nvidia driver without hybrid. If it does not work with your tty’s then you need to “try” bug report to nvidia, so pretty far-fetched any solution could come from that.

edit: yes, it works there as you said it works now. This way you are wasting most of the potential of the graphics card.

I AM running those, or what do you mean? I uninstalled them and is now running video-nvidia. I must be missing something?

I edited this in above post but better posting again.
“Now thinking about it, when pressing the “run with open source drivers” in the boot menu of the live usb stick, does it actually run with those drivers or is it only marking the “install” for that? I didn’t check the drivers when running the stick, but now thinking about it, don’t you think the reason it worked is because it is running the video-linux drivers?”

video-nvidia-470xx