Crash when moving pointer in live usb

Trying to launch Manjaro KDE/GNOME with live cd in a XPS 9520. Version = 21.3.0-220617

  • Intel i7 12700H

  • Nvidia 3050 ti

  • 4k screen

I’m getting a crash when I just move the pointer with touchpad or mouse and after that I can’t do anything but shut down holding power button. Screen goes black when I move the pointer but it works when I use just the keyboard.

I tried minimal and full version, with open and proprietary drivers with always the same result. Ubuntu/Kubuntu 22.04 works out of the box.



Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Same problem here, I managed to get the infos needed:

  Kernel: 5.15.55-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=de_DE keytable=de tz=UTC
    misobasedir=manjaro misolabel=MANJARO_GNOME_2135 quiet
    systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
  Console: tty 3 DM: GDM v: 42.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9520 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0YD3W1 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.4.0 date: 06/09/2022
  ID-1: BAT0 charge: 82.6 Wh (100.0%) condition: 82.6/84.3 Wh (98.0%)
    volts: 13.1 min: 11.4 model: BYD DELL M59JH21 type: Li-poly serial: <filter>
    status: full
  RAM: total: 31.03 GiB used: 3.95 GiB (12.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 built: 2021 process: Intel 7 (10nm ESF)
    family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x41B
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 414 high: 481 min/max: 400/4679:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 445 2: 421 3: 436 4: 424
    5: 400 6: 401 7: 401 8: 401 9: 424 10: 427 11: 481 12: 427 13: 400 14: 400
    15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 bogomips: 107560
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2 bts
    cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault
    cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap
    smep smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:4626 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell
    driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:25a0 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:2 chip-ID: 0c45:6732 class-ID: 0e02
  Display: server: v: with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa gpu: i915 tty: 240x75
  Monitor-1: eDP-1 model: Sharp 0x1516 built: 2021 res: 3840x2400 dpi: 290
    gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6") ratio: 16:10
    modes: 3840x2400
  Message: GL data unavailable in console. Try -G --display
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.55-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: down mac: <filter>
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 983.29 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 3400 NVMe 1024GB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 34000050 temp: 26.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Transcend
    model: JetFlash 32GB size: 29.42 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/dm-0 maj-min: 254:0 mapped: ventoy size: 3.29 GiB fs: iso9660
  ID-2: /dev/nvme0n1p1 maj-min: 259:1 size: 240 MiB fs: vfat label: ESP
    uuid: 1636-F0CB
  ID-3: /dev/nvme0n1p2 maj-min: 259:2 size: 128 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/nvme0n1p3 maj-min: 259:3 size: 469 GiB fs: ntfs label: OS
    uuid: 01D89CC8EE2EB3E0
  ID-5: /dev/nvme0n1p4 maj-min: 259:4 size: 465.56 GiB fs: ext4 label: N/A
    uuid: 8796c906-bb48-43ca-85f2-35262bb64747
  ID-6: /dev/nvme0n1p5 maj-min: 259:5 size: 1.01 GiB fs: ntfs
    label: WINRETOOLS uuid: F476A3CF76A39142
  ID-7: /dev/nvme0n1p6 maj-min: 259:6 size: 16.5 GiB fs: ntfs label: Image
    uuid: E0ACA3FCACA3CAFC
  ID-8: /dev/nvme0n1p7 maj-min: 259:7 size: 1.43 GiB fs: ntfs
    label: DELLSUPPORT uuid: 8414620C14620212
  ID-9: /dev/sda1 maj-min: 8:1 size: 29.39 GiB fs: exfat label: Ventoy
    uuid: F45D-E35D
  ID-10: /dev/sda2 maj-min: 8:2 size: 32 MiB fs: vfat label: VTOYEFI
    uuid: 75B8-7B4D
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-6:2 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6732 class-ID: 0e02
  Device-2: 3-9:3 info: Shenzhen Goodix USB2.0 MISC type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 27c6:63ac class-ID: ef00 serial: <filter>
  Device-3: 3-10:4 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 4-1:2 info: Transcend Information JetFlash type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 304mA
    chip-ID: 8564:1000 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 42 C
  Fan Speeds (RPM): N/A
  Processes: 496 Uptime: 15m wakeups: 805 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
  Packages: pacman: 1263 lib: 296 flatpak: 0 Shell: Zsh (login) v: 5.9
  running-in: tty 3 inxi: 3.3.19

Command used as described in the post before.

It doesn’t matter which desktop env you are using, I’ve tried KDE, xfce and GNOME Live USB, as soon as I start using the touchpad the screens starts flickering and turns black. Using only the keyboard this problem wont’ arise.

Thx, Andreas

@panabuntu @akiss

Could be an issue with the latest gpu and the power management.

Add this:

i915.enable_psr=0 i915.enable_fbc=0

to to the kernel parameter.

I experienced the same issues that panabuntu and akiss see. I attempted these kernel parameters in the installer and while the experience is marginally more stable (I previously found that the screen would just go blank unrecoverably after moving the mouse for too long), there is still extreme flickering/video corruption/tearing present when the mouse is moved, making the system unusable.

Laptop is Dell XPS 15 9520 (2022), same as panabuntu and akiss. Installer is manjaro-gnome-21.3.6-minimal-220729-linux515.iso.



Is there anything specific I should be looking for there? The only thing that looks potentially relevant is the i915.edp_vswing=2 boot parameter, which a) doesn’t seem to help, and b) is advice for a model from 2016.


without any information from your side it’s almost impossible to give better advice. please open your own thread, give a detailed information of the problem and provide us with basic information as the inxi that has been a basic info for everybody !


I have exactly the same problem as the previous two commenters and exactly the same laptop. There’s nothing to add, except that the mitigations suggested by @megavolt—whilst preventing the system from locking up outright—provide only a marginal fix.


@panabuntu @akiss hey! anyone found a solution to this problem?

@klim This bug is resolved in the current installer (2022-12-24) however I required the following kernel parameters to boot with linux61-nvidia drivers:

ibt=off nvidia.modeset=0

No other issues detected thus far.

1 Like