CPU temperature sensor in Plasma System Monitor

Hello everyone.

I updated to KDE Plasma 5.22.3 today. After this update I have problems with System Monitor, specifically with the CPU temperature sensor.

I had a graph with the CPU temperature added to History page in System Monitor. After the update, the data stopped coming into the graph and the sensor that was used is no longer in the list of available sensors. Now I can only display the temperatures of a specific processor core, but not the entire processor.

In KSysGuard this sensor is available and working:
Hardware Sensors → coretemp-isa-0000 → Package_id_0

There is no more such sensor in System Monitor:

The CPUs → All tab does not contain such sensor:

My processor is Intel Core i7-8750H, if it’s important.

Can anyone suggest how to make this sensor available for use in System Monitor again?
Thanks in advance.

I have a similar issue on my laptop (with AMD), so this might be a general bug in KDE plasma.

Apparently, this is a known issue: KDE bug
But I haven’t found a solution yet.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. What’s the output to:



P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

1 Like

Hello, Fabby.
There are no errors related to this problem in all of the reviewed logs.


inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 5.13.1-3-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 wm: kwin_wayland vt: 2 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 9 MiB bogomips: 52815 
  Speed: 2200 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 2200 2: 2200 
  3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 
  12: 2200 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 352 wakeups: 24 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: 1535 pacman: 1513 lib: 428 
  flatpak: 22 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.05


Adapter: ISA adapter
Package id 0:  +44.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +41.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +41.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +39.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +47.0°C  

Adapter: ACPI interface
in0:          16.98 V  
curr1:       1000.00 uA 

Adapter: Virtual device
temp1:        +51.0°C  

Adapter: PCI adapter
Composite:    +34.9°C  (low  =  -0.1°C, high = +117.8°C)
                       (crit = +149.8°C)

Adapter: ACPI interface
temp1:        +25.0°C  (crit = +107.0°C)

The result of the sensors command obviously shows that the required sensor (Package_id_0) is functioning correctly.

I will continue to look for a possible solution to this problem.

Have you tried one of the LTS kernels already, because if there is a bug in the stable version, Plasma will not know about it and just report what the kernel says…


I tried to start with Linux 5.10.49-1 LTS, the problem remained.

I assume that in the new version of Plasma, some change was made in the principle of creating sensor groups for System Monitor, but so far I have not been able to find the specific code/configuration responsible for this.

The reason for this behavior was found: KDE Bugs comment
This will probably be fixed by the KDE team.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.