Cpu struggling to play some high res mp4 video

There have to be a better configuration for my laptop graphich related setting:
This is normal 1920x1080 h264 youtube video. everything fine with this type of video.

3840x1920; libdav1d decoder
This stresses the cpu up to 80% - 90%. Only with 1 firefox , 1 gnome system monitor, 1 kate and 1 smplayer running.
The cpu is on such high loading for a gaming laptop (not the newest one, but still gaming laptop), when the video playing… when i paused or stop the video, everything back to normal.

3840x1920; libdav1d decoder
Whenever i play this video, the whole video started display slide lagging. Horrible to watch.

Any explanation or fine tuning to this ?


System:    Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Memory:    RAM: total: 15.55 GiB used: 2.68 GiB (17.2%)
           RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:       Info: Dual Core model: Intel Core i5-4210H bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 3C (60)
           stepping: 3 microcode: 28 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB bogomips: 23154
           Speed: 887 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1088 2: 990 3: 1004 4: 1058
           Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid
           cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
           fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr
           nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp
           rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
           tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Micro-Star MSI driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
           Device-2: NVIDIA GM108M [GeForce 940M] vendor: Micro-Star MSI driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1347 class-ID: 0302
           Device-3: Acer MSI Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-1.4:4 chip-ID: 5986:014c class-ID: 0e02
           Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: modesetting,nvidia
           alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x2160 s-dpi: 96 s-size: 506x570mm (19.9x22.4") s-diag: 762mm (30")
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 305 size: 160x90mm (6.3x3.5") diag: 184mm (7.2")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 21.2.5 compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
           v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c class-ID: 0403
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
           bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
           Device-3: Plantronics Plantronics .Audio 622 USB type: USB driver: plantronics,snd-usb-audio,usbhid
           bus-ID: 3-1.1.4:9 chip-ID: 047f:c014 class-ID: 0300
           Sound Server-1: ALSA v: k5.10.79-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Drives:    Local Storage: total: 6.82 TiB used: 42.67 GiB (0.6%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD5000LPVX-22V0TT0 size: 465.76 GiB block-size:
           physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1A01 scheme: MBR
           ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDS100T2B0A-00SM50 size: 931.51 GiB block-size:
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD scheme: GPT
           Message: No optical or floppy data found.
Partition: ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%) used: 42.67 GiB (4.7%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
           label: N/A uuid: 0eef34c8-7ed8-4eb2-bffe-5f7e04864898
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat dev: /dev/sdb1
           maj-min: 8:17 label: NO_LABEL uuid: CDDC-5789
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
           ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 210 Uptime: 15h 32m wakeups: 6 Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages:
           pacman: 1235 lib: 340 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.09

Hi @andrewysk,

Just a thought: have you tried the player/browser/whatever using the dedicated graphics? Because, as you said, the laptop is quite old and that is a very high resolution video.

Yes, I noticed it is a high res video… I believe this is the first time i encountered such high res video…
Never have such issue ever on this laptop before.
Is it possible to switch video card ? This laptop has dual video card …

if you check the info-center, what is the info of the graphicprocessor (gpu). is it a nvidia or something else like “llvmpipe” etc. ?

Operating System: Manjaro Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.10.79-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-4210H CPU @ 2.90GHz
Memory: 15,6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

It appears to be on build in Intel card now.
Should i try to play the video again and check simultaneously to see if it auto switched to Nvidia card ?

well there is the “bug”, you have a system with the nvidia and the integrated intel-graphics. actually you’re using the intel-graphics that must compute everything with the cpu. you must switch to nvidia-mode to reduce the payload of the cpu.

Please provide the output to:

mhwd --list

And also:

which prime-run

I don’t think it happens automagically.

Is this happening with any other media player say VLC?

$ which prime-run
$ mhwd --list
> 0000:01:00.0 (0302:10de:1347) Display controller nVidia Corporation:
                  NAME                       VERSION             FREEDRIVER         TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime      2021.11.04               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee  2021.11.04               false            PCI
video-nvidia                               2021.11.04               false            PCI
video-nvidia-470xx                         2021.11.04               false            PCI
video-nvidia-390xx                         2021.11.04               false            PCI
video-linux                                2018.05.04                true            PCI

> 0000:00:02.0 (0300:8086:0416) Display controller Intel Corporation:
                  NAME                     VERSION               FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime      2021.11.04               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee  2021.11.04               false            PCI
video-linux                                2018.05.04                true            PCI
Video-modesetting                          2020.01.13                true            PCI
video-vesa                                 2017.03.12                true            PCI

Try launching the video player with prime-run, like this:

prime-run <player-command>

Where <player-command> is obviously the command for the video player.

Just tried the same video on vlc… it runs on 75%cpu loading… but the quality is much much better than mpv… at least it is watchable.

Have you turned on any video filters in smplayer Video > Filters?

See this issue:


use optimus and change to your nvidia-card, that*s the better and stable alternative. you should also do the major update.

Optimus causes a lot of issues, IIRC. So don’t do that.

Hmm. Running mpv with prime-run is same at 80%cpu… but it is not as laggy as before.

Terminal shows this :

$ prime-run mpv 'The Best Webcams of 2021 had BIG Surprises.mp4' 
 (+) Video --vid=1 (*) (av1 3840x1920 60.000fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
AO: [pulse] 44100Hz stereo 2ch float
VO: [gpu] 3840x1920 yuv420p
AV: 00:00:04 / 00:21:16 (0%) A-V:  0.450 Dropped: 85

Audio/Video desynchronisation detected! Possible reasons include too slow
hardware, temporary CPU spikes, broken drivers, and broken files. Audio
position will not match to the video (see A-V status field).

AV: 00:00:30 / 00:21:16 (2%) A-V:  0.000 Dropped: 386

Exiting... (Quit)

Nope. I Never use any filter on smplayer. Nor do i know how to use it… just yet.

Well, that’s as good as I can get it. If there’s anything else, I don’t know about it.

i don’t wonder. use your nvidia-card as fixed, all the other “alternatives” will break and are unuseable and btw. installing optimus isn’t that easy but all other “solutions” are garbage.

I have update phobia . EVERYTIME i update/ upgrade on manjaro or other arch based os, i faced breakage somewhere. i have really phobia of it… although i know i can’t escape from upgrade.

My last upgrade , broke mpv on the other desktop, and messed my locale setting, and changed by login shell ( from bash to zsh) … i have not yet know or have time to fix it.

i agree the last 3 major updates caused me pain in the ass too, but that’s as it is.