Corrupted packages/invalid keyrings during update

Hello. I’m facing a problem with corrupted packages/invalid keyrings and cannot update. I followed this wiki guide, but I got more invalid keyrings.

Could someone please provide assistance? Should I run
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
?

you will likely want to ensure your keyring packages are up to date first.

Try this

sudo pacman -Sy archlinux-keyring manjaro-keyring #installs keyring packages
sudo pacman-key --populate archlinux manjaro #updates keyring database with new files
sudo pacman-key --refresh-keys #Refresh all keys

It’s from my post over here,

Hello, thank you for your suggestion.

Unfortunately, I am getting errors with
sudo pacman -Sy archlinux-keyring manjaro-keyring

warning: Public keyring not found; have you run pacman-key --init?
error: keyring is not writable
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occured, no packages were upgraded.

I attempted to go through the wiki guide once more.
The packages archlinux-keyring and manjaro-keyring showed up as 0.00MiB. I downloaded them and saved them (refused to remove them).

At step 5

sudo pacman -U $HOME/.cache/pkg/*.tar.zst
sudo pacman -U $HOME/.cache/pkg/*.tar.xz

I got errors in both commands:

error: ‘/home/user/.cache/pkg/*.tar.zst’ : could not find or read package

That means I can’t install the keyrings somehow?

try these commands:

sudo rm -rf /etc/pacman.d/gnupg
sudo rm -R /root/.gnupg/
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
sudo pacman-key --refresh-keys
sudo pacman -Sc
sudo pacman -Syyu
2 Likes

You’re awesome! I run exactly this sequence of commands and I’m all set!

:beers:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.