Correct way to downgrade mesa

what is the correct way to downgrade mesa drivers on manjaro plasma?

after the recent system upgrade i have issues with mesa drivers (i assume). again.
blender was crashing on start, and after few hours of investigation, i’ve deleted userpref.blend and got blender back to work. but now it crashes when i try to activate few addons with the only output in terminal:

Aborted (core dumped)

addons are: principled baker and modeling cloth.
whats interesting, is that despite the fact every single 2.8+ release i’ve tried was crashing, the newest 3.0 is working fine.

in the past i’ve had huge issues with mesa. my work just stuck bc substance painter was unusable:

at the time of substance painter issue, at first i was able to downgrade mesa easily with
$ sudo pacman -U /var/cache/pacman/pkg/mesa-…-x86_64.pkg.tar.zst
$ sudo pacman -U /var/cache/pacman/pkg/mesa-vdpau…-x86_64.pkg.tar.zst

i was also able to upgrade the system fully and then downgrade mesa as many times as i wanted, everything worked fine for me.
but then some major update came, and i simply couldn’t downgrade mesa anymore.
when i tried, i got black screen after reboot.
so i had to wait until mesa got fixed in mesa-git, and then in stable branch in order to continue using substance painter.

i was stupid enough not learning how to use timeshift app, so i could just roll back to working state of the system.

and now it happened again but with blender.
rolling release can be a huge pain.

so, can somebody please explain how i should downgrade mesa correctly?

Downgrading packages is not supported. Downgrading is never a solution on a rolling release distribution. However, it may be a possible temporary stopgap measure until an upstream bug is fixed.

Always make backups.


P.S. Did I mention backups? Because you should always make backups.

I’m looking for the answear to the same question.
I’m having problem with Blender and it has been reported that Mesa 21.2.5 driver worked fine with this software.
It’s a fresh Manjaro instalation so I don’t have previous Mesa drivers.

What are the steps for me to downgrade Mesa?
Bear in mind I am fresh Linux user.

what exactly is your issue with blender?
in case you are trying to render with amd gpu on a card like rx580 or lower, then i have bad news for you:

and also i strongly recommend to start using Timeshift right about now, with no delay.
as a 3d artist i can say, that rolling release is a unreliable, i can’t even recall how many time it has let me down.
rolling release is just .

Timeshift runs like crazy - no worries :slight_smile:

Problem with Blender is flickering screen in Viewport on my laptop - Dell XPS 9350 (It’s not my working machine - I just like to model something when being away from studio )
It’s been reported that flickering is related to recent Mesa driver and rolling back to 21.2.5 solves the problem.
However all methods of driver downgrade I found - didn’t work…

So I can see there is no solution to my problem?
Or is it too tough for a rookie?

I already know how to create directories through terminal so don’t tell me I wan’t handle this task!