Convert Compiled Debian Kernel to Arch Kernel?

I can’t imagine it’s possible, but as I’m slowly moving my machines to Arch, I have one device running a MX 21 ahas kernel customized to produce internal sound and sound-after-suspend.

Kind people had to hold my hand for me to compile in Debian and I was amazed that I got it to work (kernel compiling is usually above my paygrade).

Is there any way to convert a *.deb kernel to an Arch kernel, or is it apples and oranges?


Wrong approach to a problem that you might not even have.

Does that mean that the standard Manjaro kernel does not work for you?

Since you now know what you did - what you needed to change -
and why(!)
it is easy to apply to a custom kernel build in Arch/Manjaro.

The (altered) config can stay the same and serve as a template, for instance.

First make sure that this is even necessary.

Second: tell us what they told you what you had to do,
so we may assist you how to do that same thing here.

The difference isn’t large.

… if a custom kernel is even necessary in the first place

Many thanks for your quick post and you reaffirm all my doubts about such an approach.

I have one of those no-name 7" devices that go by multiple names (eg Topton L4) and its essx8336 audio chip is a pita ( custom-kernel/sof-essx8336 at main · yangxiaohua2009/custom-kernel · GitHub ) with patched drivers that then need a second version to provide sound after resume. Plus, the developer’s rolled kernel isn’t 32-bit capable, which I need for WINE.

I have the .config from my successful compile, but I’m not sure I want the hassle of a start-from-the-bottom compile, especially since there’s absolutely no support for the machine, no forum, etc.

Again, thanks for your post.

Although this is a side issue, not the topic at hand, but to that I’d say that there is likely a misunderstanding here.
Wine can support 32 bit and 64 bit prefixes - it’s just a matter of how you create a wine prefix for some program(s).

I did not find that to be true in my trouble-shooting. 32-bit WINE programs worked with all other tried kernels and not with the develper’s. I explored/searched in vain for command/prefix solutions until discovering that 32-bit was not enabled in his .config.

Once I recompiled with 32-enabled, all was well.

Just try a live manjaro, and report :wink:

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )