Computer boots onto (kernel?) hardware log

My computer (not the one I’m writing from) whenever turned on boots onto hardware log. It’s updates when USB devices are connected/disconnected.

Because other tty’s are available I’ve confirmed that the computer still connects to Ethernet, and that files appear to be intact. It does not seem to be a problem with the hard drive as I ran a smartctl test and from what I could decern there were no reported issues.

commands like poweroff and ‘shutdown’ do not work properly, they just seem to turn off the ttys instead of the main screen with the hardware log. In order to actually turn off the computer, a long-press on the power buttion to force a shutdown is needed.

Sorry that I can’t give any more details as I’m not really sure what other tools are available for diagnostics

can you report

inxi -Fza 
sudo mhwd-kernel -li
sudo mhwd -li

I’m not able to give the raw output as I can’t copy-paste from there
CPU is: quad core Intel Core i7-4790 (-MT MCP-)
GPU is: AMD Navi 24 [Radeon RX 6400/6500 XT/6500M]
Primary drive is LITE-ON IT model LCS-256L9S-11 SSD

but mhwd-kernel shows 5.15.118-1-MANJARO
mhwd: video-linux version 2018.05.04

Please post the complete /etc/default/grub file of said machine here, as well as the complete /etc/systemd/journald.conf.

Paste the output of each file between two horizontal rows of three backticks, like so… :arrow_down:

file content goes here

Alternatively, paste the contents in your post, select what you just pasted, and click the </> icon in the toolbar of the post editor.

The main problem is that currently only command line is available. I do not know how to get those files from the command line onto this forum.

Is it not possible to manually start the GUI from one of the ttys?

1 Like

I’ve tried startx and it appears to be in a loop

waiting for X server to begin accepting connections

and so on until it gets to

xinit: giving up
xinit: unable to connect to X server: connection refused

waiting for X server to shut down  ...........
xinit: X server slow to shut down, sending KILL signal

waiting for server to die...
xinit: X server refuses to die

might be relevant, that i was previously fiddling with a game (Vintage Story) which refused to exit properly and required SIGKILL to actually end the process

Thank you!, here’s the outputs as requested

#  This file is part of systemd.
#  systemd is free software; you can redistribute it and/or modify it under the
#  terms of the GNU Lesser General Public License as published by the Free
#  Software Foundation; either version 2.1 of the License, or (at your option)
#  any later version.
# Entries in this file show the compile time defaults. Local configuration
# should be created by either modifying this file, or by creating "drop-ins" in
# the journald.conf.d/ subdirectory. The latter is generally recommended.
# Defaults can be restored by simply deleting this file and all drop-ins.
# Use 'systemd-analyze cat-config systemd/journald.conf' to display the full config.
# See journald.conf(5) for details.


GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Uncomment to disable submenus in boot menu

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

( and respectively )

In /etc/systemd/journald.conf, change these lines… :arrow_down:


… into… :arrow_down:


… and issue… :arrow_down:

sudo systemctl daemon-reload.

This will route the system log output to tty12 so that you can watch it in real-time by switching to that console via Alt+F12.

Do however bear in mind that this is only part of the troubleshooting process. Your issue is that for some reason, the X server dies while trying to start. And barring any serious misconfiguration, this is usually the result of graphics driver issues.

You did however say that this problem started after running a game, and it is possible that this game has messed up your graphics configuration. Normally it shouldn’t be able to do that, unless of course you were running the game as root, because only the root account has write access to the system-wide configuration, and in Manjaro, the X11 server does itself not run with root privileges.

It does in many if not most environments - Gnome/GDM is a notable exception.
(If a number of criteria are met - namely kernel mode setting)
SDDM for example cannot launch X rootless unless you have a newer version, ex: sddm-git.

( see a way to make sddm launch X rootless :point_right: )

With kernel mode-setting and systemd, the X11 server only runs with root privileges for running the display manager session — this is necessary because the display manager has to be able to read /etc/shadow — but as soon as the user has logged in, the user session starts X11 under the user’s own UID, and the root-owned session with the display manager exits. :man_shrugging:

I’m not sure this is the case … at least not in all circumstances.
See for example:

ps -o user= -C Xorg

If rootless then it will display your user.

I contend this is not the case by default in many if not most manjaro editions … I can specifically speak to KDE. As this is technically more on the display manager I guess I should say I can speak to SDDM … I am relatively sure lightdm cannot launch X rootless either.

Yup … heres the archwiki entry: Xorg - ArchWiki

Note that some popular display managers do not support rootless Xorg (e.g. LightDM or XDM).

And as I already mentioned SDDM is not capable either until more recent versions, which are not present in the repos, let alone the configuration.

But … I’ll pop off to test an ISO again just to check.

I did say that the display manager — in this case, sddm — runs X11 as root. :wink:

[aragorn] >   ps aux | grep -i sddm
root         598  0.0  0.1 144408 21800 ?        Ssl  Jun20   0:00 /usr/bin/sddm
root         604  2.6  1.1 1497684 189096 tty1   Ssl+ Jun20 227:36 /usr/lib/Xorg -nolisten tcp -background none -seat seat0 vt1 -auth /var/run/sddm/{c261db4e-0e0d-4a1a-a19b-5060fbc06733} -noreset -displayfd 17
root         686  0.0  0.1  67988 20064 ?        S    Jun20   0:00 /usr/lib/sddm/sddm-helper --socket /tmp/sddm-authb1819af3-f2b7-46c5-8ac9-398a1f65fdae --id 1 --start /usr/bin/startplasma-x11 --user aragorn
aragorn    81013  0.0  0.0   6684  2656 pts/3    S+   00:18   0:00 grep --color=auto -i sddm

However, the X11 process underneath your user session runs with your own UID, not as root. :wink:

I mentioned the game because I repeatedly had to SIGKILL and figured there might be some issues with that.

for some reason I’m only able to get up to tty6 so I routed the output to there instead of tty12, beyond that there doesn’t seem to give any output to there on reloading the daemon.

It could just be graphics drivers but there’s also the issue of shutdown not turning the system off properly, which by my very limited understanding would be quite strange for that to be a graphics issue.

This has gotten rather OT … but … I dont follow how that shows X running rootless.
It shows your user starting sddm. ok.
I dont understand how the steps outlined in Archwiki are refuted … if you run the above command … it will tell you if X is running rootless or not.

$ ps -o user= -C Xorg

If I do follow your logic … I get expectedly different output from yours:

root         757  0.0  0.3 152124 23028 ?        SNsl 11:30   0:00 /usr/bin/sddm
root        1128  0.0  0.3  79788 21192 ?        SN   11:30   0:00 /usr/lib/sddm/sddm-helper --socket /tmp/sddm-auth-8b8a6e53-fdcd-47f3-9f3b-71d3d4b71c87 --id 1 --start /usr/bin/startplasma-x11 --user USER --display-server /usr/bin/X -dpi 120 -background none -seat seat0 -noreset -keeptty -novtswitch -verbose 3
USER        1184  0.0  0.1  54072 12288 tty2     SNs+ 11:30   0:00 /usr/lib/sddm/sddm-helper-start-x11user /usr/bin/X -dpi 120 -background none -seat seat0 -noreset -keeptty -novtswitch -verbose 3 /usr/share/sddm/scripts/Xsession "/usr/bin/startplasma-x11"
USER       15709  0.0  0.0   6580  2404 pts/1    SN+  15:39   0:00 grep --colour=auto -i sddm

(you may note, among other things, /usr/lib/sddm/sddm-helper-start-x11user, which again, does not exist in the repo version of sddm)

I never said that it did. In fact, I contended (and still contend) that the display manager runs a root-owned X11 session because it needs to be able to read /etc/shadow.

But as you say, this is off-topic, so let’s just drop it. :wink:

(obtained through
inxi -Fza output

  Kernel: 5.15.118-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64 root=UUID=cc5f1a2f-5b0c-4cc9-8a32-b23cdadd0883
    rw quiet apparmor=1 security=apparmor udev.log_priority=3
  Console: tty 2 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 9020 v: 00 serial: <superuser required> Chassis:
    type: 6 serial: <superuser required>
  Mobo: Dell model: 0N4YC8 v: A00 serial: <superuser required> BIOS: Dell v: A24
    date: 10/24/2018
  Info: model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell gen: core 4 level: v3
    note: check built: 2013-15 process: Intel 22nm family: 6 model-id: 0x3C (60) stepping: 3
    microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3593 high: 3596 min/max: 800/4000 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 3592 2: 3593 3: 3593 4: 3593 5: 3593 6: 3595 7: 3596 8: 3592
    bogomips: 57488
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 24 [Radeon RX 6400/6500 XT/6500M] vendor: ASUSTeK driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:743f
    class-ID: 0300
  Display: server: v: driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu tty: 240x67
  Monitor-1: DP-1 model: Dell S2421NX serial: <filter> built: 2021 res: 1920x1080 dpi: 93
    gamma: 1.2 size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080
    min: 720x400
  API: OpenGL Message: GL data unavailable in console. Try -G --display
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 8 driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28 class-ID: 0403
  API: ALSA v: k5.15.118-1-MANJARO status: kernel-api with: aoss type: oss-emulator
    tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.71 status: off with: pipewire-media-session status: off
    tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: off with: 1: pulseaudio-alsa type: plugin
    2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel port: f040
    bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb v: 0.8 type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-11:4 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: <filter>
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020 bus-ID: 00:1f.2
    chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 1.14 TiB used: 227.99 GiB (19.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: LITE-ON IT model: LCS-256L9S-11 2.5 7mm 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 10D scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST31000340AS size: 931.51 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: LC11
    scheme: MBR
  ID-1: / raw-size: 238.47 GiB size: 233.67 GiB (97.99%) used: 171.09 GiB (73.2%) fs: ext4
    dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 26.0 C mobo: N/A gpu: amdgpu temp: 26.0 C mem: 26.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 198 Uptime: 1m wakeups: 0 Memory: available: 31.29 GiB used: 1.94 GiB (6.2%)
  Init: systemd v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: 1717 pm: pacman pkgs: 1692 libs: 465 tools: pamac pm: flatpak pkgs: 17 pm: snap
  pkgs: 8 Shell: Bash (login) v: 5.1.16 running-in: tty 2 inxi: 3.3.27

sudo mhwd-kernel -li output

e[32mCurrently running:e[0m 5.15.118-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515

sudo mhwd -li output

e[1me[31m> e[mInstalled PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

e[1me[31mWarning: e[mNo installed USB configs!

have you tried with others kernels ?
you can add more ans select in advanced menu Grub
( see GRUB Menu Not Showing On Boot, Boots into Default Kernel Instead - #4 by stephane)
can you add

sudo mhwd-kernel -i linux510
sudo mhwd-kernel -i linux61
sudo mhwd-kernel -i linux63

Kernel 510 does not boot into the the log, does get stuck after journal recovery. Power button works normally on 510 unlike 518.

startx fails claiming no screens found

now testing with 61 and 63