[closed] NTFS, fstab, and mounting with read, write, and executable permissions

I checked all the articles I could find on the Manjaro forums related to my issue, but no luck.

I am trying to mount a Windows drive with read, write, and executable permissions in fstab. It was working before with my fstab entry as such:

UUID=43FBFFD71AD3FC68 			  /home/USERNAME/d_drive ntfs defaults,noatime 0 0

All that does now is give me read permissions.

I have tried several different fstab ntfs and ntfs-3g options, such as uid=1000, gid=1000,dmask=022,fmask=133,windows_names etc. Nothing is even given me read write access, let alone executable.

Suggestions are appreciated. Thanks.

Try changing the ownership with:

sudo chown -R $USER:$USER /home/USERNAME/d_drive

I tried that before, but I keep getting that it is a read-only file system.

Also, I have already ensured that ‘‘fastboot’’ is disabled in Windows.

Unless USERNAME is your real username you have to replace that in fstab… :rofl:

Also the directory


needs to be created with mkdir.

Furthermore, install ntfs-3g

Then replace ntfs with ntfs-3g in your fstab entry and use the right options:

UUID=43FBFFD71AD3FC68 /home/{username}/d_drive ntfs-3g uid=userid,gid=groupid,dmask=022,fmask=133 0 0
1 Like

Haha, yes. I replaced my actual username for privacy reasons. I have already made the d_drive using mkdir, and have ntfs-3g installed. The drive has worked fine for the past month or so (which is how long I have had windows installed). It just recently became read-only for some reason.

How have you switched-off “Fast Startup” in Windoze? Better double-check if this has been done right.

I’ll double-check. I usually disable it by going to power options and unchecking it from there. Also, I tried replacing ntfs with ** ntfs-3g** and still have the same issue.

I forgot to update this. For whatever reason, rebooting Windows fixed the problem. No other changes were made.