Clone hdd to ssd

,

My current Manjaro-cinnamon system run off a 1tb hdd (Seagate Barracuda st 1000DM003) It’s a bit old and while ‘GSamrtControl’ found no errors with it, I want to transfer it onto a 1tb ssd.
I own a hard drive cloner (Welland Turbo Leopard). I used it in the past to successfully clone hdd to hdd, but I’m not sure if it also works for hdd to ssd as ssd need trim and I’m not sure if they even have ‘sectors’
Furthermore my motherboard is old and does not support UEFI The hdd to be clone has only Manjaro installed (no dual-boot) partitioned as follow: Legacy BIOS, AHCI, GPT partition table. 8mb unformatted partition (hack to install MBR), 8gb swap, 10gb free space, 100gb /, 40gb free space, 250gb /home, 390gb free space. The free space is to make it easier is in case I need to change things.
The other options would be: Software cloning, or simply fresh install on ssd and transfer of data.
What would you recommend. Thanks

What file system does the HDD use?

For Btrfs, I recommend to reinstalling OS on SSD and copy your data back or using btrfs send | btrfs receive

You can use gparted to format the ssd and copy the partition to the new drive, then give the copy a new UUID. Afterwards, disconnect the hard drive and boot into the system to repair grub as shown here. After testing you can reconnect the hard drive and reformat it to use as storage.

If the copy doesnt work you can always reinstall to it and copy data from the old one.

1 Like

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

CloneZilla
https://clonezilla.org/

1 Like

The method I gave earlier will work with your setup.

If you follow this method the cloned partition will likely have the same UUID. Make sure to unplug the old hard drive before booting into the ssd to test the system. You will also likely have to boot into clonezilla or a manjaro install disk to format the hard drive for storage after reconnecting it. Two partions with the same UUID might cause the system to not boot, or boot into the hard disk. You may also have to reinstall grub as linked in my previous post.

1 Like

In response to ‘andreas85’ I tried to quote you by highlighting the portion of your post that I want to quote and usually a ‘quote’ link appears and I can then insert the quote in my reply, but for some reason highlighting some text does not make ‘Quote’ appear anymore? has something changed? Anyway as suggested I run inxi… and here is the output.

Drives:
  Local Storage: total: 1.36 TiB used: 14.29 GiB (1.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1CH162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC43 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500413AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: JC4B scheme: MBR
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SH-222AB rev: SB01
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 96 GiB size: 93.93 GiB (97.85%) used: 13.13 GiB (14.0%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 1bbcd301-42b9-497a-b018-36db090a3a5e
  ID-2: /home raw-size: 256 GiB size: 250.92 GiB (98.02%)
    used: 1.16 GiB (0.5%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: 4ae37b52-e04c-49f5-ba90-e4f0048d6ebc
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-2: swap-2 type: partition size: 7.85 GiB used: 0 KiB (0.0%) priority: -3
    dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 2c14b0b1-444f-4331-a99d-cf58591be87e
Unmounted:
  ID-1: /dev/sda1 maj-min: 8:1 size: 12 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-2: /dev/sdb2 maj-min: 8:18 size: 1 KiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/sdb5 maj-min: 8:21 size: 226.79 GiB fs: ntfs label: DataB
    uuid: C0DCB437DCB42A14
  ID-4: /dev/sdb6 maj-min: 8:22 size: 238.97 GiB fs: ntfs label: DataP
    uuid: 76601AA8601A6EDD
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.4:3 info: Logitech Unifying Receiver type: Keyboard,Mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c534 class-ID: 0301
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 25.0 C gpu: nvidia temp: 35 C
  Fan Speeds (RPM): cpu: 2428 fan-2: 0 fan-3: 0 fan-4: 0 gpu: nvidia fan: 40%
  Power: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.14
Info:
  Processes: 220 Uptime: 4h 44m wakeups: 44 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1266 libs: 336 tools: pamac,yay pm: flatpak
  pkgs: 0 Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.23
[jp@jpmanjarohome ~]$ 

So none of you liked the ‘hardware’ transfer method (using the Wellard Turbo Leopard)!? is that because of hdd to ssd? It certainly works hdd to hdd in the past I copied (cloned) a hdd with dualboot Windows XP and Linux Mint on it (in various partitions).

CloneZilla is a bit scary for me, I use RescueZilla for imaging/backup - I suppose it can do the same job as CloneZilla I may give that a try or I just re-install.

If you use RescueZilla, the same instructions I gave for Clonzilla apply. If you use the hardware method you will likely have to disconnect the hard drive when done, then reinstall grub like with every other method mentioned. The reason is that the grub loader is in the mbr of the disk and not the partition.
Instead of using multiple disks/hardware you might want to try a one shot method. An up to date Manjaro install media using gparted, which is included, will let you clone and reinstall grub. Likely in one boot. If it doesnt work then you have an up to date install media to install with.

I ended up using ‘RescueZilla’ and all went fine. I could have used the Clone function (hdd to hdd) but I wanted a backup anyway so I used the Backup/Restore function. I was surprised on how easy and fast the whole operation was - after booting Rescuezilla from a thumb-drive, backing up the hdd to an external hdd took less than 5 minutes, turn off the computer, swap hdd for ssd, boot back into Rescuezilla and restore to ssd took less than 5 minutes, re-start (disconnect thumbdrive and external hdd first), Grub show up as normal and everything seems to work as before.
For anybody not confident with the terminal, I highly recommend Rescuezilla

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.