Chrome refusing to open suddenly - help appreciated

google-chrome
chrome

#1

Hi there.

I recently completed a fresh reinstall/upgrade to Chrome to 61. It was working beautifully smoothly for a couple of days but this morning it refuses to open. I really need it for work today, so would appreciate your assistance.

google-chrome-stable gives the following output:

[2336:2399:0920/071547.902452:ERROR:connection.cc(1964)] History sqlite error 5, errno 0: database is locked, sql: DELETE FROM meta WHERE key=?
Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
[2336:2366:0920/071547.929877:ERROR:connection.cc(1964)] Passwords sqlite error 5, errno 0: database is locked, sql: PRAGMA auto_vacuum
[2336:2366:0920/071547.929921:ERROR:connection.cc(1964)] Passwords sqlite error 5, errno 0: database is locked, sql: PRAGMA journal_mode = TRUNCATE
[2336:2376:0920/071548.908125:ERROR:data_store_impl.cc(131)] Failed to open Data Reduction Proxy DB: 3
[2336:2362:0920/071548.930323:ERROR:gcm_store_impl.cc(312)] Failed to open database /home/ruziel/.config/google-chrome/Default/GCM Store: IO error: /home/ruziel/.config/google-chrome/Default/GCM Store/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
[2336:2366:0920/071548.932202:ERROR:connection.cc(1964)] Passwords sqlite error 5, errno 0: database is locked, sql: PRAGMA cache_size=32
[2336:2366:0920/071548.932413:ERROR:connection.cc(1964)] Passwords sqlite error 5, errno 0: database is locked, sql: SELECT name FROM sqlite_master WHERE type=? AND name=? COLLATE NOCASE
[2336:2366:0920/071548.932585:ERROR:connection.cc(1964)] Passwords sqlite error 5, errno 0: database is locked, sql: SELECT name FROM sqlite_master WHERE type=? AND name=? COLLATE NOCASE
[2336:2366:0920/071548.932674:ERROR:connection.cc(1964)] Passwords sqlite error 5, errno 0: database is locked, sql: CREATE TABLE meta(key LONGVARCHAR NOT NULL UNIQUE PRIMARY KEY, value LONGVARCHAR)
[2336:2366:0920/071548.932746:ERROR:login_database.cc(556)] Unable to create the meta table.
[2336:2366:0920/071548.932895:ERROR:password_store_default.cc(46)] Could not create/open login database.
[2336:2362:0920/071549.933042:ERROR:gcm_store_impl.cc(422)] Destroy failed: IO error: /home/ruziel/.config/google-chrome/Default/GCM Store/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
[2336:2372:0920/071549.933165:ERROR:gcm_client_impl.cc(828)] Failed to reset GCM store
[2336:2399:0920/071647.906510:ERROR:connection.cc(1964)] History sqlite error 5, errno 0: database is locked, sql: INSERT OR REPLACE INTO meta (key,value) VALUES (?,?)

This makes no sense to me, so I would appreciate not having to reinstall Chrome again if possible & risking it happening all over again, if there is a deeper machine issue.

Thanks,

Ruziel :slight_smile:


Google-chrome don't start after update
#2

Lots of database is locked errors. Have you tried a fresh reboot?


#3

Hi Strit.

Yes, I have rebooted my machine a couple of times already.

I also uninstalled Chrome (not including my profile & configs - just a simple -R google-chrome) & then “downgrade google-chrome” & reinstalled 61.

I’m fresh out of ideas.

Thanks,

R.


#4

maybe key-ring related? what happens if you
google-chrome-stable %U --password-store=basic


#5

Steanne.

Thanks. Interesting - that opens Chrome. But if I close it & then try clicking my icon in the panel to start, nothing happens. I can only restart if I kill all the Chrome processes & then re-enter that command.

Any ideas?

Thanks,

R.


#6

…not from me. i had a theory on what the problem was and a temporary work-around, but not enough knowledge to actually fix it.


#7

Steanne.

That’s fine - at least I can work today now, without having to reinstall the lot.

One question: do you know the command to completely uninstall something like Chrome, including all it’s config & profile info - go give a 100% clean start? Last time I just looked for it in the system files & deleted, which is not good! :slight_smile:

I might do that later today.

Thanks,

Ruziel.


#8

I noticed that I was signed out of my Chrome account - once I signed back in, Chrome reverted back to normal.

I’m not sure why that caused an issue with opening the app, but it’s sorted for now.

Thanks to both of you for your assistance - much appreciated!

More power to you.

Ruziel :slight_smile:


#9

pacman -R google-chrome

but i don’t think that will get all the remnants. look in your own home folder under .config and .cache as well.


#10

Thanks Steanne.


#11

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.