Choosing sound-output from audio devices manually

Hi, I am a new Linux user. I am on Manjaro KDE Plasma.
In Windows, all the sound devices were visible from the taskbar’s volume icon. And I was able to change my PC’s sound output from the taskbar manually.

Note that, I have a built-in speaker on my desktop. This works fine in Linux.
When I plug a headphone into my PC. The output automatically shifts to the headphone.
But while my headphone is plugged in I can’t change the output to the built-in speaker and in settings, it says, speakers are unavailable.

So, I have to unplug my headphone to use the built-in speaker. Is there any way to change audio output manually while headphone is plugged-in?

(Really loving Manjaro, but this function would help me a lot)


Hi @sha_R

are you using pipewire or pulseaudio to handle your audio output?
I haven’t switched to pipewire, yet, which is supposed to the way to go for the future, so I can’t help you with that, but you might want to have a look here

If you are using pulseaudio, it’s possible to configure, in various config files, what should happen when something is plugged into the audio jacks
Please check the documentation here

for general information. I have installed pavucontrol and use it when I need to change the audio settings.

1 Like

Laptop users usually want speakers mute when headphones are plugged in
Auto Mute in ALSA is usually enabled by default in Linux for this function

Auto-Mute can be disabled in alsamixer
or with a command like amixer --card=0 sset 'Auto-Mute Mode' Disabled
(but you may need a different card number for onboard audio device)

Disabling auto mute on startup - Advanced Linux Sound Architecture - ArchWiki


Hi, @nikgnomic,

I disabled auto-mute and it worked!!

But yet the unavailable sign after speaker stays. So, I can’t change it from the taskbar audio volume icon, the ports option doesn’t appear. Every time I need to go to the settings to change it. How to fix it?:grinning:

However, What I actually did is-

alsamixer in the terminal-

  • F6 to find my audio device
  • to locate ‘Auto-Mute Mode’(right corner)
  • to change setting from Enabled to Disabled
  • Esc to exit

and then wrote this command to save changes to ALSA settings-
sudo alsactl store

Found this on your another comment–(Audio doesn't toggle automatically between speaker & earphone - #2 by nikgnomic)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.