Changing shell themes with Tweaks


so I’m really new but I have changed the theme in Ubuntu before, I am struggling with manjaro though:
at first I wanted to use the catppuccin theme (can’t use links in my posts?) and installed it via the AUR. figured it doesn’t work because it needs Gnome 43 and manjaro stable is running on 42.5?

then I tried the everforest gnome shell theme (to be found on gnome-looks, can’t post links)
but with all the files in /.themes I still can’t change the theme via gnome tweaks. Am I doing something wrong or does the second theme require gnome 43, too?

side question: why are the gnome-extensions separated from gnome-tweaks? I remember that in ubuntu the extensions were listed in tweaks, too.

thanks for your help

Hi, the everforest theme states it works with gnome 42, so you should be good. I found it pretty and just try it via the everforest-gtk-theme-git aur package.
To your side question: gnome changed the default handling of extensions in the newer releases, but for the theme I simply switched drop-downs in tweaks/appearance for it to work. edit: after install, logout/in again for the drop-down to appear.

thanks for your reply! very stupid question? what’s the command line to install it?

pamac install everforest-gtk-theme-git

does not work

Sure it does.

❯ pamac install everforest-gtk-theme-git
Warning: everforest-gtk-theme-git is only available from AUR
Checking everforest-gtk-theme-git dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  everforest-gtk-theme-git  r17.aba45df6-1    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] 

Fehler: Ziel nicht gefunden: everforest-gtk-theme-git

in english

error: target not found: everforest-gtk-theme-git

do i need to access the AUR beforehand somehow?

You wrote in your first post that you already started to install the other theme from the AUR. That catpucchin package was found, but everforest not? Odd.
Perhaps the problem described in:
I use yay on this machine (see the thread)

Did you enable AUR support in Add/Remove Software (Pamac)?

Using a terminal prompt does not require any changes - you need to use the correct command

pamac install <repo-pkg-name>


pamac build <custom-aur-script>

i downloaded the files and copied them in the .themes directory. i did not use the terminal for that

@Yochanan that was precisely the problem. thanks for your help!

worked like a charm

Ubuntu likely uses an older Gnome, extensions were moved at lease two versions ago. This was done by Gnome, not Manjaro.