Changing default terminal in KDE

I want to change the default terminal from Konsole to Terminator. I tried changing via the settings, but when I press Ctrl+Alt+T it still opens Konsole. Clicking on “Open Terminal here” in dolphin also opens Konsole. I am using Manjaro KDE with the Linux58 kernel.

It’s probably starting Konsole because you explicitly have Ctrl+Alt+T set up to launch Konsole instead of Terminator. Check your key bindings in System Settings:arrow_down:

Workspace → Shortcuts →Custom Shortcuts → KMenuEdit →Launch Konsole → Trigger