Changed system language from French to English, but it remains partially in French

So, my first language is French, but I generally use English as my system language. A long while ago, I switched my system language to French, mostly just to see how well-supported it was. It’s quite good! But even after switching my system language and all locale settings back to Canadian English, some applications (which appear to use system settings and do not have their own language options) are still in French, even though most things seem to have correctly switched back to English.

This isn’t a huge problem, but can be a pain in some cases. I don’t mind too much when it comes to simple applications, but when it comes to software like Ardour, I’d really rather be able to use English documentation and tutorials without having to guess at how highly specific terms were translated.

Rather few applications are affected. Off the top of my head, I can think of Add/Remove Software and Ardour, but there’s a handful of others. System Settings and most other software still correctly display English.

At first, I suspected this might be a side effect of keeping one specific locale setting in French (I’ll never put the dollar sign before the amount, fight me), but even after changing it and restarting, the problem still remains. I’ve tried several different fixes for locale-related problems, but none of them have worked. So far it seems like all my locale files are correctly set to English.

Here is a screenshot showing that my system language and all locale options are set to Canadian English, that most things display in English as they should but that Add/Remove Software (as an example) displays French:

The contents of /etc/locale.conf :


The contents at the end of /etc/locale.gen :

# Locales enabled by Calamares
en_US.UTF-8 UTF-8
en_CA.UTF-8 UTF-8

The contents of ~/.config/plasma-localerc :



This is a minor annoyance, but one that really shouldn’t exist, and I’d really like to solve it.

Did you not notice this? Try Manjaro Settings Manjaro Language Packages and remove any us french ones.

I don’t think there are any, as far as I can tell:

I’m not sure what the “translations” section actually affects? I certainly want/need to be able to type French and Japanese, and ideally to have applications display those languages correctly if necessary.

Sorry I meant Local Settings and details?

Is “Local Settings and details” a KDE thing? Because I’m watching this thread from Manjaro XFCE where the same thing happens – some programs still in one language after you change to another without seemingly any hint to be found in either home-directory or e.g. /etc – hoping for a hint that I can also use…

Well, the problem here is I’m not seeing anything called “Local Settings” or “details” anywhere on KDE, either.

FWIW, the only places where languages other than English show up is in my input methods and spellcheck (Canadian French spellcheck, Canadian French keyboard + Anthy to type Japanese), which I can’t imagine is supposed to have any effect on system language.

I see. My current problem is that I can’t even now find an example of a misbehaving application even though I’m very, very sure I ran into a few. I’ve also seen the subject pass by on the forums before: it seems likely to be one of those long drawn out issues with poor-quality threads both as to reporting (well, by me anyways it would seem) and poor reproducibility by others.

Has been pissing me off though. I’m new to Manjaro and ever since I used that Manjaro Settings Manager thingy to play with switching back and forth this has been happening. Sometimes. On and off. Maybe. Yesterday. Or tomorrow…

No its in Manjaro Settings Manager which is included with all manjaro iso’s

FWIW then, for me that’s all set fine; English (United States) / en_US.UTF-8 for “Display Language” with on the “Detailed Settings” tab all four under that header set such, and a non-English choice for “Formats” with again all 9 set such in “Detailed Settings”.

This was set from install and worked fine until I sometime ago switched back and forth the Display Language there. Ever since then the display language in some applications has been the non-English one. Once again sorry that I can’t at the moment be more precise as to which. Can’t at the moment find the issue again but am sure I’ll run into it later again (believe it was in fact while I was logged in over SSH).

No, also switching the “Formats” to en_US.UTF-8 didn’t then help; I’ve grepped through my home-directory to find an e.g. ~/.config/ file but each time I noticed I did not in fact have lots of time available to look for it. My /etc/default/locale is also all fine and in correspondence with the Manjaro Settings Manager.

Something’s bust as to that settings manager…

I had already seen that post and tried most of the potentially relevant fixes, however it did turn out to be helpful since I looked them all over, tried one more possible fix found on the Arch Wiki, and it turned out to be the right one!

Just to reiterate in case anyone has a similar problem on KDE, everything pointed to my locale being correctly set, so many of the fixes did nothing, but some applications still showed up in the wrong language. Deleting /home/.config/plasma-localerc fixed it. It also turns out that @robin0800 was probably correct, as the new version of plasma-localerc that was automatically generated on restart doesn’t include the [Translations] section.

1 Like

Same comment from me as to Aragorn post, i.e., does not help, and …

… damn, since that then isn’t applicable to my XFCE install.

Hope to have more time to pay attention next time I run into it.

Found it: pam or logind (I believe/guess) setting the LANGUAGE environment variable from /etc/locale.conf when logging in over SSH

That is; I have two systems with newish Manjaro XFCE installs on both of which all is fine when logged in locally; neither has LANGUAGE set in its local environment and as per the output of locale, but when SSH-ing from one to the other my SSH session did. Since neither had LANGUAGE set as such it’s not a matter of SSH forwarding environment: turns out that the server’s /etc/locale.conf is applied when logging in over SSH, presumably then by pam or logind; not sure.

In my case server’s /etc/locale.conf did in fact contain the unwanted LANGUAGE even though it also did the wanted en_US.UTF-8 for LANG and LC_*. Client’s /etc/locale.conf did not and I just now after deleting it manually on server verified that it doesn’t return when switching either “Display” or “Formats” locale through Manjaro Settings Manager on it.

I’m also pretty darn sure I never touched that file on the server manually so unsure what in fact ever set it; it may have been from install I guess with me just starting to notice the issue directly after having played with Manjaro Settings Manager; I do not in fact always consciously notice language of e.g. error messages until I do. In that case it would be some sort of installer issue/buglet/oddity I guess.

Anycase, solved simply by manually deleting LANGUAGE from server’s /etc/locale.conf. If LANGUAGE returns in it at some point I’ll probably remember the issue and might be able to report what put it there.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.