Change display scale automatically depending on monitor

Hi all,
I have an HP Elitebook G6 with a 14" screen and 1920 x 1080 resolution. Display scale of my Manjaro KDE works nice at 150%. But I also use this laptop with a docking station and a bigger monitor, where the best scale is 125%. I would like to know if there is any procedure to automate the scale change when I change the screen. So far I do it manually whenever I change my screen, and then log off and log in again. Any chance?

Hi @talestomaz :wink:

To clearify: I am not a KDE-User.

But i believe there are no profiles like on XFCE, where you can save the screens and if a screen gets plugged in or plugged out, it will auto detect, which profile should be used. On KDE there is only “set as default” button or maybe I am wrong…

If you want it done automatically, there is such a setting in KDE:

So you can save a global scale per display configuration, but you cannot:

  • automagically change
  • set a different Display Scale per monitor


1 Like

In fact, this option “For only this specific display arrangement” is selected by default in my distribution. I have always wondered if this shouldn’t mean that things had to be different for different monitors (as they are different “display arrangements”), but, as it didn’t work, I thought maybe I was getting something wrong. It seems that this should indeed force different display scales. Any tip why this isn’t working here?

No, it’s a global scale for all monitors in that monitor configuration.


  • If you have a 17" FHD monitor and a 21" UHD monitor a global scale makes sense.
  • If you have a 17" UHD monitor and a 21" FHD monitor, instead of using a scaling setting per monitor, you can just set the 17" UHD to FHD resolution as well and that would solve your problem too.

So KDE doesn’t support individual monitor scaling as you can accomplish the same using other means. :man_shrugging: It’s a design decision.

As we don’t have your xrandr output, we can’t give you specific instructions on how to accomplish what you want.


Can you elaborate what other means there are (besides changing display resolution or buying different hardware)?



Cool, thanks. :sweat_smile:

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This doesn’t work though :unamused:, at least in experience and this post.

Can you confirm this setting is working for you? Just out of curiosity for me to know if my system is broken or this is a bug.

My apologies: I can confirm it’s a bug: it does not survive a reboot.


So head over here and file a bug report.


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.