Ceph-libs build problem

-- Ceph/.git directory not found, parsing /var/tmp/pamac-build-gerry/ceph/src/ceph-16.2.7/src/.git_version for CEPH_GIT_VER and CEPH_GIT_NICE_VER
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Java (missing: Java_JAVAC_EXECUTABLE Java_JAR_EXECUTABLE
  Java_JAVADOC_EXECUTABLE Java_JAVAH_EXECUTABLE Development) (found version
  "1.8.0.345")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindJava.cmake:314 (find_package_handle_standard_args)
  src/java/CMakeLists.txt:1 (find_package)


-- Configuring incomplete, errors occurred!
See also "/var/tmp/pamac-build-gerry/ceph/src/ceph-16.2.7/build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/pamac-build-gerry/ceph/src/ceph-16.2.7/build/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
    Aborting...

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

1 Like

Welcome, please do not hijack threads.

Proably you don’t even need ceph-libs and can remove it.

2 Likes

Indeed not.

I ran into the same issue — well, sort of, because the machine got stuck during the compile and I had to kill it with the Magic SysRq keys to get my system back — and it turns out that ceph-libs was only a build-time dependency of something that got pulled in, and that you don’t need it. So I’ve uninstalled it.

3 Likes

One of my machines locked up every time I allowed ceph-libs to update. I uninstalled it and now all seems well.

2 Likes

I uninstalled ceph-libs too and i have no Problems.

Another reason to first update with pacman, and only then do AUR. You quickly notice new AUR packages and take a closer look.

1 Like

That’s what I always do. :wink:

2 Likes

Do you use KVM/QEMU? Still running? (Figuered out, that ceph-libs comes wth qemu…)

Edit: Removed qemu-block-rbd (and so ceph-libs) and my VMs are still running. So it’s all fine…

1 Like

My system kept hanging during the build as well.

Removed ceph-libs.

Thanks!

1 Like

This helped me. Thank you!

1 Like

I uninstalled ceph-libs too and i have no Problems.

Thanks!

Same here.