Can't upgrade the system because it breaks a dependency required by an EOL kernel (linux59)

Hello people!

After being two stable updates behind, I’ve tried to upgrade my current version of Manjaro, but the terminal keeps telling me this:

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (460.80-1) breaks dependency 'nvidia-utils=460.73.01' required by linux59-nvidia

Digging for a bit, I’m now aware that the kernel that I’m currently using (5.9.16-1) is EOL, so I should have switched to a more recent one. Problem is, I cannot install a new one because it tells me to update the system first:

sudo mhwd-kernel -i linux510
:: Synchronizing package databases...
 core                                              165,3 KiB  1559 KiB/s 00:00 [---------------------------------------------] 100%
 extra                                            1910,3 KiB  4,18 MiB/s 00:00 [---------------------------------------------] 100%
 community                                           6,5 MiB  5,92 MiB/s 00:01 [---------------------------------------------] 100%
 multilib                                          178,1 KiB  13,4 MiB/s 00:00 [---------------------------------------------] 100%
The following packages are out of date, please update your system first: adwaita-icon-theme alsa-card-profiles android-tools android-udev aom at-spi2-core attica baloo bash bashrc-manjaro bluedevil bluez-qt botan breeze breeze-icons btrfs-progs bubblewrap device-mapper faudio ffmpeg file firefox flac frameworkintegration fwupd game-devices-udev gegl gimp glslang gnome-desktop gnustep-base gst-plugins-bad gst-plugins-bad-libs gtk-update-icon-cache gvfs gvfs-afc gvfs-gphoto2 gvfs-mtp gvfs-nfs gvfs-smb harfbuzz harfbuzz-icu hdparm imagemagick iproute2 iputils js78 kactivities kactivities-stats kactivitymanagerd karchive kauth kbookmarks kcmutils kcodecs kcompletion kconfig kconfigwidgets kcontacts kcoreaddons kcrash kdbusaddons kde-cli-tools kde-gtk-config kdeclarative kdecoration kded kdelibs4support kdeplasma-addons kdesu kdnssd kdoctools kemoticons kfilemetadata kgamma5 kglobalaccel kguiaddons kholidays khotkeys khtml ki18n kiconthemes kidletime kimageformats kinfocenter kinit kio kio-extras kirigami2 kitemmodels kitemviews kjobwidgets kjs kmenuedit knewstuff knotifications knotifyconfig konsole kpackage kparts kpeople kpty kquickcharts krunner kscreen kscreenlocker kservice ksshaskpass ksysguard ktexteditor ktextwidgets kunitconversion kwallet kwallet-pam kwayland kwayland-integration kwayland-server kwidgetsaddons kwin kwindowsystem kwrited kxmlgui less lib32-at-spi2-core lib32-faudio lib32-glib-networking lib32-gtk3 lib32-harfbuzz lib32-libepoxy lib32-libglvnd lib32-librsvg lib32-libva-mesa-driver lib32-libxcrypt lib32-libxkbcommon lib32-mesa lib32-mpg123 lib32-nvidia-utils lib32-readline lib32-systemd lib32-vulkan-icd-loader libass libepoxy libfdk-aac libglvnd libheif libimagequant libinput libkscreen libksysguard libldap libmanette libmicrohttpd libnm libplacebo libreoffice-still librsvg libsidplayfp libtool libupnp libva-mesa-driver libwacom libxcrypt libxkbcommon libxkbcommon-x11 linux-firmware lvm2 mailcap manjaro-release md4c mesa mhwd-nvidia milou mjpegtools modemmanager-qt mpfr mpg123 nano ncurses networkmanager networkmanager-openconnect networkmanager-pptp networkmanager-qt nvidia-utils oath-toolkit openexr oxygen oxygen-icons pavucontrol-qt perl-libwww pipewire plasma-desktop plasma-framework plasma-integration plasma-nm plasma-pa plasma-workspace plasma-workspace-wallpapers polkit-kde-agent poppler poppler-glib poppler-qt5 powerdevil ppp prison protobuf purpose python python-chardet python-pep517 python-pillow python-pulsectl python-reportlab python-setuptools python-six qpdf qqc2-desktop-style qt5-base qt5-webengine readline samba sddm sddm-kcm shaderc smbclient snapd solid sonnet spirv-tools srt svt-av1 syntax-highlighting systemd systemd-libs systemd-sysvcompat systemsettings threadweaver ttf-liberation unarchiver vi vlc vte-common vte3 vulkan-icd-loader wayland-protocols webkit2gtk wine-staging wpebackend-fdo xdg-desktop-portal xdg-desktop-portal-kde xorgproto yay zsh-completions 
Do you want to continue anyway? [y/N]

Saying yes (I presume I should have not), it tells me the same as before:

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (460.80-1) breaks dependency 'nvidia-utils=460.73.01' required by linux59-nvidia

Here is my inxi output:

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=92df1057-74e1-4d7e-b9b7-18efcc00c590 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 2 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: MSI model: B150M MORTAR (MS-7972) v: 2.0 
  serial: <filter> UEFI: American Megatrends v: C.90 date: 11/03/2016 
  Message: No system battery data found. Is one present? 
  RAM: total: 7.72 GiB used: 2.37 GiB (30.6%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake 
  family: 6 model-id: 9E (158) stepping: 9 microcode: DE cache: L2: 6 MiB 
  bogomips: 27208 
  Speed: 2862 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2862 2: 3172 
  3: 3103 4: 3071 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia 
  v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c03 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 101 s-size: 966x272mm (38.0x10.7") 
  s-diag: 1004mm (39.5") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 
  size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
  Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 102 
  size: 476x268mm (18.7x10.6") diag: 546mm (21.5") 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
  direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
  chip-ID: 8086:a170 class-ID: 0403 
  Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f1 
  class-ID: 0403 
  Device-3: C-Media Blue Snowball type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2 chip-ID: 0d8c:0005 
  class-ID: 0300 serial: <filter> 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 1.02 TiB used: 216.28 GiB (20.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-21WN4A0 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A120G 
  size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: BBF0 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSD1 rev: LE00 
  dev-links: cdrom 
  Features: speed: 12 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 29.3 GiB size: 28.71 GiB (98.00%) used: 17.47 GiB (60.8%) 
  fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 92df1057-74e1-4d7e-b9b7-18efcc00c590 
  ID-2: /boot/efi raw-size: 511 MiB size: 510 MiB (99.80%) 
  used: 320 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 03C4-58A3 
  ID-3: /home raw-size: 550.84 GiB size: 541.19 GiB (98.25%) 
  used: 198.81 GiB (36.7%) fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: c9b8a5d8-d00d-4e6c-b5ce-2a5ad660faea 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 3.91 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 22100c29-09a2-46a6-aecd-ca613b8a8957 
  ID-1: /dev/sda4 maj-min: 8:4 size: 346.97 GiB fs: ntfs label: N/A 
  uuid: 0CEC4D7D3AA0FDF6 
  ID-2: /dev/sdb1 maj-min: 8:17 size: 529 MiB fs: ntfs 
  label: Recuperaci\xc3\xb3n uuid: CA763F4C763F3891 
  ID-3: /dev/sdb2 maj-min: 8:18 size: 100 MiB fs: vfat label: N/A 
  uuid: F43F-F792 
  ID-4: /dev/sdb3 maj-min: 8:19 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-5: /dev/sdb4 maj-min: 8:20 size: 111.16 GiB fs: ntfs label: N/A 
  uuid: 96026018025FFF9B 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-4:2 info: C-Media Blue Snowball type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 0d8c:0005 class-ID: 0300 
  serial: <filter> 
  Device-2: 1-9:3 info: SINO WEALTH USB KEYBOARD type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  power: 100mA chip-ID: 258a:0001 class-ID: 0300 
  Device-3: 1-10:4 info: Trust GXT 144 Gaming Mouse type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  power: 256mA chip-ID: 145f:026d class-ID: 0301 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 44.0 C mobo: 29.8 C gpu: nvidia temp: 52 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 173 Uptime: 36m wakeups: 0 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 Packages: pacman: 1368 lib: 429 flatpak: 0 
  Shell: Bash v: 5.1.0 running-in: konsole inxi: 3.3.04

How should I proceed so I can use a new kernel and update my system?

go to tty mode and now disable your display manager.
now remove nvidia-utils and linux59-nvidia.
install linux kernel 5.10 and reboot.
now remove both linux59-rt and linux59-nvidia.
now install linux510-nvidia.
now enable display manager and reboot.

1 Like

Hi, thanks for your help! but I’m a bit confused about some of the things that you suggested:

go to ttv mode and now disable your display manager.

By ttv, you really mean tty right?

now remove nvidia-utils and linux59-nvidia.
now remove linux59 linux59-nvidia.

In these 2 lines you mentioned linux59-nvidia on both, is it intentional?

Sorry if my questions are too obvious, but I really want to make sure that I’m doing it right

EDIT: Original text changed!

i edited my text.
now refer to it again.

Also, at which point can I update the system? Should I do all of your steps first before updating?

Hi @Xathech ,
I agree with @alireza138812 but I wonder whether you wish to read the following post in order to understand how the problem was solved.


1 Like

After verifying that everything is working, I can safely say the process has been a success!

System update:

sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

Current kernel:

mhwd-kernel -li              
Currently running: 5.10.36-2-MANJARO (linux510)
The following kernels are installed in your system:
* linux510

Since I can’t mark more than one comment as the solution, I want to thank both @alireza138812 for the steps and @j8a for the additional information provided by the post :+1:

Make sure to learn the lesson. If you do not have only LTS kernel(s) installed, make sure your kernels never reach End Of Life (read the update announcements it is always listed there), always get rid of kernels being marked as EOL immediately (LTS can become EOL, but this is pretty rare as they are supported for generally 5 years). This way when the kernel disappears from repositories, you don’t have such issues.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.