Installing nvidia-utils (460.80-1) breaks dependency 'nvidia-utils=460.73.01' required by linux59-nvidia

I was upgrading my system with pacman -Syu and it gave me this error. I tried changing pacman mirrors and pacman -Syyu but with same result.

:: Starting full system upgrade...
warning: gnome-initial-setup: local (40.0-1) is newer than community (3.38.4-2)
warning: pamac-cli: local (10.1.2-0.1) is newer than extra (10.0.6-2)
warning: pamac-common: local (10.1.2-0.1) is newer than extra (10.0.6-2)
warning: pamac-flatpak-plugin: local (10.1.2-0.1) is newer than extra (10.0.6-2)
warning: pamac-gnome-integration: local (10.1.2-0.1) is newer than extra (10.0.6-2)
warning: pamac-gtk: local (10.1.2-0.1) is newer than extra (10.0.6-2)
warning: pamac-snap-plugin: local (10.1.2-0.1) is newer than extra (10.0.6-2)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (460.80-1) breaks dependency 'nvidia-utils=460.73.01' required by linux59-nvidia`

Then I came to know that kernel 5.9 is no longer supported. So I run pacman -S linux512 and I tried to remove linux 5.9 kernel with pacman -Rs linux59. But it showed me this

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux59 breaks dependency 'linux59' required by linux59-nvidia

After that I ran pacman -Syu anyway but got the same error. How can I fix this?

linux59 has been EOL for a while and no longer exists in the repo.

Please change kernel to latest LTS or supported kernel, before you update.

That’s because you still have kernel modules installed that needs the old kernel. Which is all handled by Manjaro Settings Manager’s Kernel management. So use that. :slight_smile:

4 Likes

I removed the older kernel by using sudo mhwd-kernel -r linux59. But it seem to have removed linux59-nvidia also. Do I need to do anything else? Should I install linux512-nvidia?

I don’t get this need to not use the provided GUI that actually does all this for you…

But yes. If you installed linux512, changes are you need linux512-nvidia if you have an nvidia GPU.

1 Like

Thanks :grinning:

I had linux 59 and I installed the latest update with 460.80… resulting in the system not bootable, can you please tell me what commands (in terminal)to use to start the system. I am new to Manjaro

Hi,
I’m trying to do this as well and I’m confused. I’m in the GUI, and it’s showing me that 5.9 is running and installed. So I try hitting install on the LTS 5.10.36-2. it’s saying changes were made successfully, but this is in the details
The following packages will be installed:

linux510

linux510-nvidia

Starting

resolving dependencies…

looking for conflicting packages…

:: installing nvidia-utils (460.80-1) breaks dependency ‘nvidia-utils=460.73.01’ required by linux59-nvidia

Done …

I tried restarting my computer but 5.9 is still installed. What am I doing wrong?

Thanks!
Travis

You haven’t switched to 5.10, only installed it.
When your computer is booting, press Esc, until you see your GRUB menu. You can choose the newer kernel under advanced options.

Hi,
So I actually went through and uninstalled 5.9 and then installed 5.10. Now I broke my system. When I go to boot after I select Manjaro on the grub menu I just get stuck in my splash screen. I tried the advanced screen but my only option is Kernel 5.10.36. Any idea how I can get it working?

Did the Nvidia drivers install without errors this time? And by “my splash screen”, do you mean the desktop environment or UEFI/BIOS one?
If latter, you’ll likely need to reinstall the Nvidia drivers through a live environment.

I didn’t run the system update before restarting my machine. I used the GUI to remove the old kernel and install the new one, then restarted.

By splash screen, I mean the manufacturer logo splash screen. (AlienWare).

I run a dual boot with windows and manjaro. The PC boots to the grub menu, and when I try to go to manjaro from there it just gets stuck in the splash screen.

So, I’m not sure how to reinstall Nvidia drivers through a live environment. I am going to do some resarch on that now, but if you don’t mind helping me understand that a little more I’d be super grateful. I’m hoping to avoid doing a fresh install.

Not through a bootable USB right? I tried that once but it didn’t seem like the operating system on that USB knew about the operating system on my hard drive.

I’m off to the manual.

That is often a recipe for a bad time.

Quite the opposite, you need a bootable USB. Using chroot while in the live environment: GRUB/Restore the GRUB Bootloader - Manjaro
After a successful chroot, you wanna perform a full system upgrade.

Thank you for all your help, it’s really appreciated. I got a bootable usb and got into chroot and then did a full system upgrade as well as grub. However, I still have the same problem. I went back into the live environment and chrooted again, and it says my system is up to date. Any idea where I should go from here? Is there any information I need to post?

Did you try reinstalling the Nvidia drivers using mhwd?

I did not but I just ran the comman mhwd -a pci nonfree 0300 and got the output

Skipping already installed config ‘video-nvidia’ for device: 0000:01:00.0 (0300:10de:1f02) Display controller nVidia Corporation TU106 [GeForce RTX 2070]

Adding -f should force reinstallation.

Ok thanks trying that. It’s running I’m going to restart my machine and try booting. Thank you so much for the help

I’m back in business. Thank you SO MUCH!