Cant start virtualbox Win7 guest after guest additions update 7.0.10

Iv been using VB on Manjaro KDE for quicken for years, but today i tried to update the guest additions to 7.0.10 and now the win7 guest I use won’t boot. It just locks up on the boot screen. It looks like a graphics diver problem. Its display was messed up (reduced to minimal resolution) after the update but when trying to reboot it won’t.

Had to go back to a previous VM snapshot of before guest additions update.

I have had a search but must have missed anything relevant.

current working guest additions 6.1.16
VB Version 7.0.10 r158379
Host Linux kernel 5.15

❱yay -Qs virtualbox
local/linux515 5.15.122-1
The Linux515 kernel and modules
local/linux515-virtualbox-host-modules 7.0.10-3 (linux515-extramodules)
Virtualbox host kernel modules for Manjaro Kernel
local/virtualbox 7.0.10-1
Powerful x86 virtualization for enterprise as well as home use
local/virtualbox-guest-iso 7.0.10-1
The official VirtualBox Guest Additions ISO image
❱inxi -b
Host: greg-inspiron5767 Kernel: 5.15.122-1-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.6 Distro: Manjaro Linux
Type: Laptop System: Dell product: Inspiron 5767 v: N/A
serial: <superuser required>
Mobo: Dell model: 03XWWJ v: A00 serial: <superuser required>
UEFI-[Legacy]: Dell v: 1.5.0 date: 06/11/2021
ID-1: BAT0 charge: 42.0 Wh (100.0%) condition: 42.0/42.0 Wh (100.0%)
Info: dual core Intel Core i5-7200U [MT MCP] speed (MHz): avg: 2438
min/max: 400/3100
Device-1: Intel HD Graphics 620 driver: i915 v: kernel
Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 driver: X:
loaded: modesetting dri: iris gpu: i915 resolution: 1920x1080~60Hz
API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel HD Graphics 620 (KBL
Device-1: Intel Wireless 3165 driver: iwlwifi
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
Device-3: Intel Bluetooth wireless interface driver: btusb type: USB
Local Storage: total: 931.51 GiB used: 163.25 GiB (17.5%)
Processes: 242 Uptime: 2d 23h 55m Memory: total: 16 GiB note: est.
available: 15.45 GiB used: 6.66 GiB (43.1%) Shell: fish inxi: 3.3.28

Well iv been reading all the threads in this virtualization section, im not sure what’s relevant and what’s not. I don’t use any 3d acceleration, i untick it from the installation of the guest additions. I don’t have Nvidia, but i tried the GRUB_CMDLINE_LINUX_DEFAULT added “ibt=off” but didn’t work.

I suppose it’s not too much a stretch to just ignore the pop-up notification saying to update the guest additions every time i load the windows guest. I used to keep it right up to date all the time, but I can live with ignoring it.

I shall just leave it from here on out at guest additions 6.1.16.

ATM if i try to install the GA update i get this warning, then on re-boot the guest windows screen locks-up and then locks-up again on attempted boot.


I cant update my host (Manjaro) kernel as any change to that makes my laptop’s “suspend on lid close” fail. so im stuck on this LTS. Not that i know if it would help anyway.

You must use the guest additions matching the vbox version as described in [root tip] [How To] VirtualBox - Installation - USB - Shared Folder

Yes i understand that. It is when i try to install the same version guest additions (7.0.10) that it all locks-up.

It is working with guest additions 6.1.16 at the moment but as soon as i try to update it to 7.0.10 thats when it fails :frowning:


My apology - I misunderstood - I was referring to the extension package.

That is a Windows issue - has nothing to do with Manjaro - so your question is better asked at VirtualBox Forum. It could be a bug in the guest additions.

On your host Install the package virtualbox-guest-iso.

Restart your guest and use the built-in upgrade function as illustrated in the screenshot below



If that doesn’t do it - you should use the VirtualBox Forum.

hmm, well it did seem to get a bit further. It does at least load, but the screen resolution is now gone very low and i have tinkered with the view option to try to fix it, but i can’t get it back to being the full screen rez it was before.

It did this before when i first installed these guest additions but that time it wouldn’t boot after this, but it is booting repeatedly now, just can’t figure this screen rez.

Any ideas? thx.


Hi, I’ve found the same issue as you: what did you do to make it load?

Your VM should use vboxsvga.

The simple to resize is to set the resolution inside Windows.

You can use the Host+F to go full screen


I even run WinXP


Well i just followed @linux-aarhus suggestion of using the host Install the package virtualbox-guest-iso. and then using the guests pull-down-menu “upgrade Guest Additions” Dont ask me why it worked any better than before, but it does seem to be loading now at least.

Nop, tried all that. It is VboxSVGA (iv tried just VGA but nop) & iv tried every method to change the rez to something higher than 1280x960, it does list them, but nothing works.


Click the View → Autoresize guest display → then drag your window corner to resize

I just installed a Windows 7 - installed guest utils - resizing works as expected.

Test Windows 7


Then via View menu → resize to 1920x1080

This voice is grey for me, so I can’t use it. Why?

Now is active.

Iv got the rez up to a maximum of 1600x900 by "walking the “view/virtual screen 1” up the resolutions listed) but even though it lists more it will not go any higher. If i do as your suggestion above i can make the window bigger but the virtual OS just stops getting bigger at that point and just leaves black/blank areas around the edges.


I don’t think the extension pack has been properly installed in your guest.

Did you choose to trust Oracle driver signing upon install?

Im prob not the best one to try and help but does your host have virtualbox-guest-iso 7.0.10 installed?

No, you’re right, it never installed properly. I remember thinking to myself when it was installing that it had not even asked about them Oracle install things.

So this is all a no-go then :frowning: O dear


@D.Dave @jackdinn

You can remove from your guest using the Add/Remove programs from conrol panel.

Then reinstall them - but remember to reboot the vm in-between.


But as I try with the option inside VirtualBox "upgrade Guest Additions”, I got this:


I can install the iso file inside Windows 7 without errors, but then I have the problem as you described: Windows 7 stuck at loading screen.

Yea, It is looking like mine never even installed properly at all so i wouldn’t go to far worrying about getting this installation method to work as i think it will do exactly the same thing anyhow (lock-up on boot)

For now I will stay with VBoxGuestAdditions_6.1.16.iso which works without problems.