Cant see my fan under sensors! fancontrol.service; disabled; vendor preset: disabled

Hi community!

I’m having trouble trying to get some information about the fans of my laptop, they start working only above 80ºC (been doing some gaming but now I dont think I can until I fix this) and I would like to change this so they start earlier, maybe around 60 degrees, my laptop is prone to overheating and I’m trying to safeguard it from itself…

I’ve searched around how to do this, installed lm_sensors and ran sudo sensors-detect, I typed yes to every time… but to an specific nvidia adapter, fun-fact it freezes when I responded yes to NVIDIA GPU I2C adapter (i2c-0) adapter, the only adapter that returned success is Intel digital thermal sensor

  * Chip `Intel digital thermal sensor' (confidence: 9)

but when I run sensors there is no fan speed along the ISA adapter, as I have seen is the normal thing to happen…

Adapter: ISA adapter
Package id 0:  +46.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +46.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +43.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +45.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +43.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +45.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +42.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: ACPI interface
in0:          12.88 V  

Already read multiple posts from people who had their fanservice not working but I couldnt find any that showed a similar behavior.

When I run systemctl status fancontrol this is what I get:

○ fancontrol.service - Start fan control, if configured
     Loaded: loaded (/usr/lib/systemd/system/fancontrol.service; disabled; vendor preset: disabled)
     Active: inactive (dead)

I’m kinda of a newbie around (first post) so I dont know what else should I add… i can just think of inxi -Fxxz (next formated text), I’d be more than thankful if I can get some hint on how to enable the fan control service and get to change the way it works. greetings!

System:    Kernel: 5.10.60-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 81SX v: Legion Y540-15IRH serial: <filter> Chassis: type: 10 
           v: Legion Y540-15IRH serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter> UEFI: LENOVO v: BHCN41WW date: 11/30/2020 
Battery:   ID-1: BAT0 charge: 48.4 Wh (99.0%) condition: 48.9/57.0 Wh (85.8%) volts: 12.9 min: 11.5 model: SMP L17M3PG2 
           serial: <filter> status: Unknown 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A cache: L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 1100 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 1100 2: 1100 3: 1100 4: 1100 5: 1099 6: 1100 7: 1100 
           8: 1100 9: 1101 10: 1100 11: 1100 12: 1100 
Graphics:  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Lenovo driver: nvidia v: 470.63.01 bus-ID: 01:00.0 
           chip-ID: 10de:1f11 
           Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo bus-ID: 1-6:3 chip-ID: 5986:2113 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia resolution: 1920x1080~144Hz 
           s-dpi: 143 
           OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:a348 
           Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:10f9 
           Sound Server-1: ALSA v: k5.10.60-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus-ID: 07:00.0 chip-ID: 10ec:8168 
           IF: enp7s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-14:6 
           chip-ID: 8087:0aaa 
           Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
Drives:    Local Storage: total: 953.87 GiB used: 564.01 GiB (59.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HBLR-000L2 size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> temp: 39.9 C 
Partition: ID-1: / size: 117.54 GiB used: 51.75 GiB (44.0%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-2: /boot/efi size: 256 MiB used: 31 MiB (12.1%) fs: vfat dev: /dev/nvme0n1p1 
           ID-3: /home size: 73.07 GiB used: 16.66 GiB (22.8%) fs: ext4 dev: /dev/nvme0n1p6 
Swap:      ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p4 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A gpu: nvidia temp: 49 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 298 Uptime: 6m Memory: 15.55 GiB used: 2.47 GiB (15.9%) Init: systemd v: 248 Compilers: gcc: 11.1.0 
           alt: 10 Packages: pacman: 1477 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.06 

Not all laptops expose the fan control.

Does Fn+Q toggle fan modes? It may not work on Linux. On Windows it requires Lenovo’s Vantage program.

1 Like

For clarity, does the GPU have a dedicated fan irrespective of system/CPU temperature?

Is it your GPU that reaches concerning temperatures, or is it your CPU?

Just in case, you can have a look at this ExtremeCooling4Linux by odintdh

You have it on AUR too AUR (en) - extremecooling4linux

1 Like

this kinda worked! This is the closest I’ve been to manually deploying the fans, installed it with yay, and it lets me turn on the fans by a switch, but it seems to overdoit since they start fixed at maximum capacity when i use it (lol it makes sense because its extremecooling) and no way to decrease RPM’s.

doesnt do anything on linux!

it is CPU temperatures concearning me! GPU not that much, from what Ive seen in heatsink unmounts there is this big integrated chassis with two fans, one by the GPU and one by the CPU…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.