Can't scan Documents from hp printer

I am a new Linux user and I loved Manjaro but this problem bother me
I have an HP_LaserJet_Pro_MFP_M125nw printer that have a scanner
the printing is working fine but i can’t scan any document
i tried a lot of scanning programs and they gave me the same message :
(Error opening device: opening device ‘hpaio:/usb/HP_LaserJet_Pro_MFP_M125nw?serial=CNB6GDR4Z9’: Error during device I/O)
i used Gscan2PDF , Xsane , Skanlite , Simple scan and utsushi they all give the same message
Except Vuescan it is the only program that worked but it puts a watermark and need to purchase it to remove the watermark

Outputs of:

scanimage -L

scanimage -T

There a couple of hp scanner issues on the now archived forum.

1 Like

this first command gives this
device hpaio:/usb/HP_LaserJet_Pro_MFP_M125nw?serial=CNB6GDR4Z9' is a Hewlett-Packard HP_LaserJet_Pro_MFP_M125nw all-in-one device hpaio:/net/hp_laserjet_pro_mfp_m125nw?ip=’ is a Hewlett-Packard hp_laserjet_pro_mfp_m125nw all-in-one
the second one gives that
Output format is not set, using pnm as a default.
scanimage: open of device hpaio:/usb/HP_LaserJet_Pro_MFP_M125nw?serial=CNB6GDR4Z9 failed: Error during device I/O

note"the printer is connected wirlessly"
and the scaning programs gives the their is two printers with the same name

i installed gnome DE and i saw that the printer scanner exist but it isn’t collaborate can someone tell me how to collaborate it

Don’t know anything about gnome…but this:


hpaio:/usb/HP_LaserJet_Pro_MFP_M125nw?serial=CNB6GDR4Z9 failed: Error during device I/O

Shows what is wrong. Can you access the printers’ web setup? Or, re-run hp-setup.

Thanks for your support but i finally solved it it seemed that it needed to download the plugin for hplip so when i downloaded it, it works well :+1: