Can't run games on manjaro

Hello, I tried everything possible to run some games on steam, I tried Metro exodus and the witcher 3, I don’t know what could be the problem because some times the games even opened, but they crashed after a couple of seconds, it crashed even steam, it could be some problem with amd softwares? I think it is beacuse some lighter games, that don’t need a gpu, like “chess” worked well.

I am using the latest version of manjaro at the moment,
AMD 5 4600g, 8gb Ram.

2 Likes

If that is the hardware that serves you graphical functionality, you will probably not run many Proton (Windows) games. It might work, but it will probably not. As said you need to provide relevant information about the system, and other logs (for example the log from Steam when you start it from terminal so we know what happens when you click Start game).

The 4600G has the same integrated gpu as the 5600G and that can run games like GTA V @ 1080p. It will struggle with more demanding recent games but they should at least run.

Source: I used a 5700G myself for about 6 months when I first switched to Manjaro (because GPU prices were still astronomical at the time) and had no problems at all with Steam+Proton.

Without further info from OP it’s just guessing but crashing as soon as the igpu is asked to do serious work indicates a possible hardware problem. Overheating perhaps, or a motherboard with crappy VRMs that struggle when both the cpu + igpu want full power.

Also, 8GB RAM is not enough for demanding games because it is shared with the igpu which will take at least 2GB for gaming (limit depends on bios settings). I’d suggest testing with older games which are less demanding. Anything from about 10+ years ago should work fine (I ran games like GTA V, Bioshock Infinite, Borderlands 2 at 1080p without any problems).

OK I might have underestimated the capabilities of this integrated video chip, but still integrated chip were mostly not supported at all in the Proton early days, they might have better support now especially on recent CPU with Vulkan support and high OpenGL version support.

I usei House of DaVinci for recreation (Steam) - and it runs fine - so it is not constraints of Manjaro as operating system but - as others already pointed to - more likely hardware constraints.