Can't run conky templates after system update

When I run conky from terminal I see conky simple black window,yes. But when I choose my templates in conky manager I can’t see them, also conky doesn’t autostart, while in autostart settings I have conky-startup.sh with ‘conky’ command. That all happened after manjaro update. Have any ideas?

1 Like

Is this helpful in any way?

Do you try with that?

wget https://github.com/brndnmtthws/conky/raw/master/extras/convert.lua

sudo chmod +x convert.lua

sudo ./convert.lua .conkyrc

This convert to the new syntax.

not work for me

I am getting htis error

./convert.lua .conky/conky.conf
/usr/bin/lua: ./convert.lua:147: attempt to index a nil value (local ‘settings’)
stack traceback:
./convert.lua:147: in main chunk
[C]: in ?

Not conky.conf
U need convert .conkyrc

1 Like

I have files named conkyrc in every conky template, I also used convert.lua for one of them, but it doesn’t work!

First, put file in /home

The archive name must be: .conkyrc

example:

wget https://github.com/brndnmtthws/conky/raw/master/extras/convert.lua
sudo chmod -x convert.lua
./convert.lua /.conkyrc

Here’s some background info from Conkyland: https://github.com/brndnmtthws/conky/wiki/Configurations#converting-old-configs-to-110 Hope this is of use now and in the future :smile:

doesn’t work

Excuse me this is just configuration, but it doesn’t show how to resolve my issue

If the convert.lua script doesn’t work for your config, you need to convert the old conky style config in the new conky style config manually by hand. This is not easy but your only choice.

The link @wordler posted shows what you need to know and what you need to do to convert manually a old config into a new one.

Of course you also could simply write a new config in the new style from the ground up.

1 Like

The lua script didn’t work for me on any of my 3 configs, and solving the issue looked complicated. I found it easier to manually convert my old configs by following the online instructions. It took a little time but it worked and I had learnt something new by doing so. :smile:

At first the new way of writing the config seemed harder, and a bit crazy, but once you get moving and more used to it then it is just as easy really.

Something that helped me was downloading a new conky config, any one, and comparing it to my old conkys. That made things a bit quicker. I’ve just looked online and here’s a modern conky you can download and use as a reference (I’ve had to remove part of the address because I can’t post links): slinkyvagabond/c5ae637c033ee70b869e56e60e26d83a. It’s at GitHub :wink:

The main thing to note is the conky is divided into two parts, the configuration and the text. The syntax is different within each one. The other thing to note is that within the configuration section every line ends with a ,

I hope this extra information is of use to people. :smile: :crossed_fingers:

For some reason I can’t get that “example conky to run”. The syntax is correct though. I’d post my own config but I’m only at Basic/Trust Level 1 on the forum at the moment :roll_eyes: :confounded:

conky configurations using the old syntax structure do not work after recent upgrades

conky has supported the old syntax for a few years
and made this conversion script
but many people have not bothered to convert their configurations

suggest you post the contents of your conky-startup.sh script
and your conky configuration file

then we can look for the error in the region of line 146/147

I posted old versions of .conkyrc and new versions of conky.conf in the earlier discussion @bogdancovaciu has already linked to (post #16)

The conversion script is basically changing the text format and adding some extra characters
so an old configuration file can also be updated manually if the new style and structure is understood
Configurations · brndnmtthws/conky Wiki · GitHub

I don’t want to run a conky conversion service because people would miss out on learning it for themselves. but as you are struggling to get it converted, I will try and work out your configuration as another example

I might also be able to improve on the boot process - you might not need a bash script
but i have to see the script first

2 Likes

Tnx, I’ll try to look at code and recover it myself. However if I’ll fall I’ll share conky code. Anyway I’ll report about results.

1 Like

after some tries I decided to reinstall both conky and conky manager, so now I have updated version of those, but strange thing is that default templates in conky-manager doesn’t work when I choose them. When I run conky_startup.sh it opens simplest conky window, but still conky-manager templates doesn’t work. One more thing, I can’t find any .conkyrc files in templates in the ~/.conky folder to convert it via convert.lua file.

I stumbled about the same issue and also had that problems coming from the new syntax. Conversion with that script left me with a strange conky where fonts and their sizes did not work anymore. Reinstalling the conky-related software did not help me, either.
What did the job for me was to download a working conky script and apapt it to my use-case. The result now looks like this:

conky
    conky.config = {
--### Gotham theme Reworked ###
	use_xft = true,
	font = 'GE Inspira:size=8',
 	xftalpha = 0.1,
	update_interval = 3,
	total_run_times = 0,
	own_window = true,
	own_window_type = 'desktop',
  	own_window_argb_visual = true,
	own_window_transparent = true,
	own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
	double_buffer = true,
	maximum_width = 600,
  	minimum_height = 400,
	draw_shades = true,
	draw_outline = false,
	draw_borders = false,
	draw_graph_borders = false,
	default_color = '#EAEAEA',
  	color1 = '#17D1A1',
	alignment = 'bottom_right',
	gap_x = 0,
	gap_y = 0,
	no_buffers = true,
	uppercase = false,
	cpu_avg_samples = 2,
	net_avg_samples = 1,
	override_utf8_locale = true,
	use_spacer = 'right',
};

conky.text = [[
${font :pixelsize=12}${goto 320}${color 17D1A1}Machine ${goto 465}$color${nodename}
${goto 320}${color 17D1A1}Kernel ${goto 465}$color${kernel}
${goto 320}${color 17D1A1}RAM ${goto 465}$color$mem / $memmax
${goto 465}${color 17D1A1}${membar 5,112}
${goto 320}${color 17D1A1}CPU ${goto 400}$color${cpu cpu0}%${goto 465}${color 17D1A1}${cpubar cpu0 5,112}
${goto 320}${color 17D1A1}Akku ${goto 400}$color${battery_percent}%${goto 465}${color 17D1A1}${battery_bar 5,112}
${font :pixelsize=12}
${goto 320}${color1}Root ${goto 430}$color${fs_used /} / ${fs_size /} / ${fs_used_perc /}%
${goto 320}${fs_bar 5,255 /}
${goto 320}${color1}Home ${goto 430}$color${fs_used /home} / ${fs_size /home} / ${fs_used_perc /home}%
${goto 320}${fs_bar 5,255 /home}
${goto 320}${color1}Downloads ${goto 430}$color${fs_used /home/bran/Downloads} / ${fs_size /home/bran/Downloads} / ${fs_used_perc /home/bran/Downloads}%
${goto 320}${fs_bar 5,255 /home/bran/Downloads}
${goto 320}${color1}Doc ${goto 430}$color${fs_used /home/bran/Dokumente} / ${fs_size /home/bran/Dokumente} / ${fs_used_perc /home/bran/Dokumente}%
${goto 320}${fs_bar 5,255 /home/bran/Dokumente}

${voffset 7}${color EAEAEA}${font GE Inspira:pixelsize=120}${time %H:%M}${font}${voffset -84}${goto 320}${color1}${font GE Inspira:pixelsize=42}${time %d} ${voffset -15}${color EAEAEA}${font Ge Inspira:pixelsize=22}${time  %B} ${time %Y}${font}${voffset 24}${font GE Inspira:pixelsize=52}${goto 320}${time %A}${font}

]];

Maybe this helps a bit…

1 Like

thanks for resonse, but this code also doesn’t work for me

so they are probably not converted

~/.config/conky.conf is the default location for using conky without conky-manager

if conky is launched from terminal with just

conky

conky looks for the home folder configuration file ~/.config/conky.conf first
if that is not available conky will use one of two basic configurations in system files
/usr/share/doc/conky-1.11.6_pre/conky.conf or /usr/share/doc/conky-1.11.6_pre/conky_no_x11.conf

once conky can find the correct configuration folder to run from terminal, an autostart .desktop file can be created with a time delay included

~/.config/autostart/conky.desktop (XFCE)
[Desktop Entry]
Type=Application
Exec=/usr/bin/conky -p5
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name=Conky

(-p5 option adds 5 second delay which could be reduced for an SSD, or may need to be increased for a slow HDD)

I do not use conky-manager and do not have a folder ~/.conky on my system so configurations may in there somewhere in the sub-folders

conky-manager should show where configuration files are located and be able to access and edit the configuration file, so you might be able to extract the configuration from the GUI