Can't play CNN videos in any browser

I can’t play videos in any browser and it seems only CNN videos are affected. I installed firefox specifically to test so I have no extensions, etc that would block the videos and they still don’t play. I tried all the options on How to Fix Videos not Playing in Firefox? with no help. Specific to firefox, I’m running 125.0.1(64bit) for Manjaro - 1.0. I checked and I have h264 and ffmpeg installed. Am I missing some other codecs that only CNN uses or something? Are they still using flash? I don’t get any info on the player they use as where the video should be only shows up as an image.

Welcome to the forum! :wave:

CNN? No loss, there. :rofl:

Sorry, couldn’t help it.

No. Flash is long dead.

Back on topic, do you have a specific video link so we can attempt to reproduce it?

1 Like

Yea, it’s been like this for more than a year and I haven’t missed anything but occasionally it would be nice to view one of their videos. I also don’t know if this affects other sites. This is the video I’m trying to watch so I can’t post it to my friend, a trumper.

That video works fine for me even with AdGuard blocking 36 things (probably mostly trackers).

Taking a look (and trying to turn off possible blocking things) I think its the same here.
And also the same using --safe-mode.

Well I wonder what it could be then… :thinking:


Maybe its DRM ? @gnuorder can you ensure that DRM is enabled in settings?

I think I’m in safe mode but it doesn’t say but I still can’t play the video.

DRM is controlled in the settings.

Ok, DRM was on by default. I turned it off and tried and no help. I turned it off again and no help. I turned it on again and no help. The only plugins are openh264 and widevine and they are always activated.

I do have a DNS based ad blocker on my router but I think CNN videos worked in Ubuntu. I will check that next after dinner.

I similarly forgot my hulking hosts file.

Not all of these are CNN proper, but some are..

$ grep -i cnn /etc/hosts

Let us know what you find (because I dont feel like turning off more things :-P).

Well, there ya go. What software and what blocklists are you using?

I have diversion on ASUSwrt-Merlin. I tried disabling DNS direct which points to it to no effect. I added and to the white list to no effect. rebooting the router next.

I can play that video just fine - as I can anything else
and always could any video from there

ublock origin in the browser

BBC and other deliberately localized content is a different matter.

I normally use Opera and have Chromium and a few other browsers installed but I installed firefox specifically to remove ublock or other extensions as a factor. The video doesn’t play on any browser. Also the video doesn’t show up as a video or media player. Normally you can right click and see what player it is but It shows up as an image which I think is a clue. Let me check BBC.

They just often have content inaccessible if you are not actually at the right physical location
(or use a VPN which fakes it)
Probably not the issue here.

Yea, BBC works fine. I figured I would check to see if there are other sites that don’t work. So far it’s just CNN.

Indeed. That means it’s an HTML5 player. :wink:

Spoiler alert, you can also watch CNN Video’s on youtube.

Just use ublock origin extension and you can watch add free :sunglasses:

I couldn’t view the video on Firefox (possibly due to one or more of the gazillion extensions I have installed - I didn’t use safe-mode). However, I could view it on Falkon browser. It ran quite a lengthy ad before displaying the video, so my guess is that the topic starter’s ad-blocker on their router is the culprit.

A possible fix could be for @gnuorder to open Firefox’s settings (about:preferences in the address bar), search for DNS (or select the Privacy & Security section on the left of screen) & change the DNS over HTTPS settings from Default Protection to Increased or Max Protection, so that Firefox uses Cloudflare or NextDNS instead of the router’s DNS.

I am running Diversion and uBlock Origin. That CNN video runs fine here. My diversion hostlists are as follows:

I haven’t specified anything regarding CNN in my allowlist or denylist. Maybe your list(s) are too aggressive. DRM is never enabled here . FF Nightly x64 , No Proxy, DNS over HTTPS is “off”.
DNS Provider is OpenDNS (ipv4 only)

That worked. I set DNS over HTTPS to max and it plays now so I gather it is the router. I’ll work on the router to see if I can allow CNN on all browsers and post back the results.

1 Like