Can't Open GNS3 in Manjaro after an update

Hi, I was using the program just fine a while a go.
I posted this issue in the official forum of the application but they tell me to ask in the Manjaro forum.
Unfortunately I don’t know exactly what update that broke the application for me because it’s been a while that I used the GNS3 application.
This week, I tried to run it, but I’m getting this output in terminal:

/usr/lib/python3.10/site-packages/pkg_resources/ PkgResourcesDeprecationWarning: 2.0.5-build-libtorrent-rasterbar-src-libtorrent-rasterbar-2.0.5-bindings-python is an invalid version and will not be supported in a future
Traceback (most recent call last):
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 573, in _build_master
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 891, in require
needed = self.resolve(parse_requirements(requirements))
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 782, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (psutil 5.9.0 (/usr/lib/python3.10/site-packages), Requirement.parse(‘psutil==5.8.0’), {‘gns3-gui’})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/bin/gns3”, line 33, in
sys.exit(load_entry_point(‘gns3-gui==2.2.28’, ‘gui_scripts’, ‘gns3’)())
File “/usr/bin/gns3”, line 25, in importlib_load_entry_point
return next(matches).load()
File “/usr/lib/python3.10/importlib/metadata/”, line 162, in load
module = import_module(‘module’))
File “/usr/lib/python3.10/importlib/”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1050, in _gcd_import
File “”, line 1027, in _find_and_load
File “”, line 1006, in _find_and_load_unlocked
File “”, line 688, in _load_unlocked
File “”, line 883, in exec_module
File “”, line 241, in _call_with_frames_removed
File “/usr/lib/python3.10/site-packages/gns3/”, line 40, in
from gns3.utils.get_resource import get_resource
File “/usr/lib/python3.10/site-packages/gns3/utils/”, line 21, in
import pkg_resources
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 3266, in
def _initialize_master_working_set():
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 3240, in _call_aside
f(*args, **kwargs)
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 3278, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 575, in _build_master
return cls._build_from_requirements(requires)
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 588, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File “/usr/lib/python3.10/site-packages/pkg_resources/”, line 777, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The ‘psutil==5.8.0’ distribution was not found and is required by gns3-gui

I didn’t manage to figure this out, can someone help me?

See if this helps… :arrow_down:

Hi Aragorn, thanks for your quick response!
I tried that and it didn’t work, BUT you pointed me to the right direction.
I uninstalled and reinstalled both gui and server application, and that did the trick (shame I didn’t think of that simple solution before).
I lost some configs but that isn’t a big deal for me.
Thanks again for the help!

sudo pip3 uninstall gns3-gui
sudo pip3 uninstall gns3-server
sudo pip3 install gns3-gui
sudo pip3 install gns3-server

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.