Can't mount mtp

Hello everyone
I wanted to add it at the end of the previous post but I thought it would be better if I opened another post for it
So as before:

I’m using manjaro KDE, so I guess it should have something to do with kde
Result of mtp-detect :

libmtp version: 1.1.17

Listing raw device(s)
Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
   Found 1 device(s):
   Samsung: Galaxy models (MTP) (04e8:6860) @ bus 1, dev 14
Attempting to connect device(s)
error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device
Unable to open raw device 0

I searched a lot. Even tested different ways such as gvfs-mtp and simple-mtpfs. But no luck with it
I just want to access my phone in terminal and run some simple commands like deleting empty folders using find and so on

1 Like

I needed the android-udev package as well to get MTP to work

1 Like

I have it installed
But still it’s not working

Here it says kio-extras needs to be installed when using dolphin…

There are also some possible solutions of kio:

1 Like

That’s not needed at all.

Did you install gvfs-mtp in any way?
If so uninstall that one and it not already installed install mtpfs or jmtpfs in which the last one is in AUR.

pamac install mtpfs


pamac build jmtpfs

Or try to install kio-extras when using dolphin as @megavolt is saying.

Ok now I uninstalled gvfs-mtp and rebooted
Also I reinstalled mtpfs, jmtpfs and kio-extras
Now I’ve got interesting result
First, I should make the phone show “allow” message pop up using mtp-detect
After accepting, I can mount my phone using jmtpfs *mount-point*
But exactly when I open dolphin file manager, I can’t go directly to my phone directory(the phone name on the left panel).

It is install mtpfs or jmtpfs or kio-extras.

So if you use a filemanager other than dolphin you install mtpfs or jmtpfs.
When you use dolphin you install kio-extras.

I think you misunderstood me :smiley:
I wanted to access my phone storage through the terminal
When using dolphin, I can’t run commands on my phone
So I should mount it before that
I want a way to access my phone both with my file manager and terminal
Just like other DEs such as cinammon or gnome

1 Like

I’m having this issue as well I installed mtpfs but I still don’t see it when I run lsblk. I’m using kde so I can’t use dolphin because of the known bug so trying to just use konsole but can’t see it with lsblk.

Solved with youtube help. Stupidly I had to turn MTP off and on from the phone. Dolphin can now see it and access the files. However weirdly I still don’t see it as a mounted device in the lsblk output. Even though I can do what I need to do with dolphin does anyone know why lsblk doesn’t see it?