Can't install Manjaro KDE 20.1.1 on an UEFI 32bit hardware

Hello everybody,

I tried to install Manjaro KDE 20.1.1 on an usb key (using as an usb key for testing) for my 2-in-1 PC with an UEFI 32bit. The installation worked until the installation of the bootloader. It failed. I received these messages:

Installation Failed

Boost.Python error in job “bootloader”.
Command ‘grub-install --target=i386-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force’ returned non-zero exit status 1.
Installing for i386-efi platform. Could not prepare Boot variable: Input/output error grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

Traceback:
File “/usr/lib/calamares/modules/bootloader/main.py”, line 476, in run
prepare_bootloader(fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 448, in prepare_bootloader
install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 310, in install_grub
check_target_env_call([libcalamares.job.configuration[“grubInstall”],

File “”, line 6, in < module >

  • Secure boot is disabled.
  • Usb key have GPT table and I create manually 2 partitions: One fat32 for efi (/boot/efi) and one Ext4 for /.
  • Under calamares, I made the partitioning manually.
  • I used gparted to create the GPT partition table and the 2 partitions with esp boot flag on efi partition.

So, what’s wrong ?

Thanks for your help.

Manjaro does not support 32-bit.

If the system is 64bit, but its a 32bit EFI, I think I remember a hacky workaround existed.

Something like this maybe:
https://www.ldx.ca/notes/intel-mac-efi32-linux.html

I followed the solution of jbMacAZ here and the liveusb works, but it failed during installation.

Note: I made some search and a workaround is to use that option in the kernel command line at boot (only for the installation in my case): efi_no_storage_paranoia

Is it a good solution ?

News 1st November: I tried many thing but each time the bootloader must be installed it fail.
I don’t have CSM in the BIOS.

Is there anyone here who has successfully installed Manjaro on a pc with uefi 32bit ?
I will try to install grub manually.

Thanks.

News 2st November: I tried to install grub manually after the installation error. The good news is it works. I can use Manjaro KDE 64bit on uefi 32 bit hardware. I added some kernel parameters on one of the liveusb config file to see if I can install the system without error. For now, I haven’t yet tested it. So the problem is half solved.

1 Like

You should consider changing that : “Developed in Austria, France, and Germany, Manjaro provides all the benefits of the Arch operating system combined with a focus on user-friendliness and accessibility. Available in both 32 and 64 bit versions, Manjaro is suitable for newcomers as well as experienced Linux users. For newcomers, a user-friendly installer is provided, and the system itself is designed to work fully ‘straight out of the box’.” in the download page :slight_smile: Downloading File /kde/20.2-pre3 - Manjaro Linux - OSDN

It used to.
But I agree … and had already raised this issue.

Nowadays, laptops with a 32bit uefi are very rare. They all have 64 bit uefi. I have had mine for a few years. But I’m happy that I can use Manjaro (KDE) on my 32bit uefi hybrid laptop with the help of Manjaro community. :wink:

I’m coming back to you.

The option (efi_no_storage_paranoia), put in the kernel command line at boot, didn’t change anything.
The i386-efi won’t install during installation. So you have to go through the command line to manually install the i386-efi in the liveusb mode on the ‘hard disk’. After that, Manjaro 64bit system works on the uefi 32bit.

Note: I would like to know one thing. At the end of the installation, the bootloader is installed, but what’s happens after that (because in my case I’ve got an error since it could not be installed) ?

I close the subject.

Hello AlanP,
I’m also trying to install Manjaro on my Asus X205TA, could you please be more specific on which command you used to install the i386-efi in liveusb mode?
Thank you very much in advance!

Hi,

I tried to install Manjaro KDE with i386-efi live usb on an usb key (for test) before installing on the flash disk of my computer (EMMC).As the usb key is a removable hardware, So that’s why I’ve got these errors above (That’s what I think). So, I found a workaround to avoid this problem when I want to install the system on usb key with uefi 32 bit hardware. I must modify the /usr/lib/calamares/modules/bootloader/main.py file on the liveusb session and change this line to: check_target_env_call(…[grubinstall] --target … “–no-vram”, “removable”]). But for now, I didn’t test it.

Otherwise, to install grub on uefi 32bit, the following command is:
sudo grub-install --target=i386-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force
If it give you an error, try again.