Failed install: Boost.Python error in job “bootloader”

I’ve tried multiple ways of partitioning according to internet ‘experts’ and I haven’t been successful installing so far. My BIL is a real expert but also really busy- but he did mention that this has to be fixed by command line. A walkthrough would be amazing - especially as a noob! Thanks for any help!!

Installing on Lenovo B575

I can’t seem to upload a photo otherwise I’d post the error screen. Error is the following;

Command ‘grub-install—target=x86_64-efi—efi-directory=/boot/efi —bootloader-id=Manjaro—force’ returned non-zero exit status 1.

There is more to it if that helps I’ll put the rest.

Edit: full Error message is as follows -

Boost.Python error in job "bootloader’

Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force’ returned non-zero exit status 1.
Installing for x86_64-efi platform. Could not prepare Boot variable: No space left on device grub-install: error: efibootmgr failed to register the boot entry: Input/output error.


File “/usr/lib/calamares/modules/bootloader/”, line 476, in run prepare_bootloader(fw_type)

File “/usr/lib/calamares/modules/bootloader/”, line 448, in prepare_bootloader install_grub(efi_directory, fw_type)

File"/usr/lib/calamares/modules/bootloader/", line 310, in install_grub check_target_env_call([libcalamares.job.configuration[“grubinstall”],

File “”, line 6, in

1 Like

Hi @Blmoe :wink:

The command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force

is correct so far, but did you do this in chroot?

Open a terminal on a live disk (not local):

  1. type manjaro-chroot -a
  2. type the grub-install command
  3. type update-grub
  4. type exit

Then the bootloader should be fixed if the kernel is listed.

Thanks megavolt, I appreciate the help!

after putting in the grub install command I got the error message:

Could not prepare Boot variable: No space left on device
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

Hi @Blmoe :wink:

Then you need to expand the efi partition with gparted for example. Keep sure the UUIDs are the same in:

sudo blkid


sudo nano /etc/fstab

I’ve tried a 1GB EFI and I still get the same error. I tried a different hard drive and installing on that and still the same thing. I’m at a complete loss at this point.

@Blmoe Sorry i guess i misread that:

Please check if your UEFI is 32bit:

Boot a Manjaro Boot Disk, then open a terminal:

sudo modprobe efivarfs


mount -t efivarfs efivarfs /sys/firmware/efi/efivars

and then

cat /sys/firmware/efi/fw_platform_size

It should display 64 for 64bit, if it is 32, then unfortunately it is not officially supported. But there is way to install it with 32bit UEFI.

Maybe this guide you to a solution: Can't install Manjaro KDE 20.1.1 on an UEFI 32bit hardware

Thanks again @megavolt I just checked and it is a 64bit.

I sent my laptop home with my brother-in-law and he was able to figure out that the problem was with the NVRAM. He added a line to the installer and got it to work.

I am having this same problem. If you’ve found a solution, I would greatly appreciate if you could post it. Thank you.

Exactly the same problem here. A clear step-by-step solution would be greatly appreciated.

This problem is caused by nvram.
You need to use this process with this grub-install command:

grub-install --target=x86_64-efi --bootloader-id=GRUB --efi-directory=/boot/efi --no-nvram --removable


The correct file system type for /boot/efi is fat32 not ext4.change file system type to fat32


Thank you! After looking and tinkering for hours, your post fixed everything. Switched partition to fat32 and all is good now.

Hai, for this case make sure :

  • disable secure boot
  • disable legacy
  • enable AHCI

and than I follow instruction on this link

Scenario 2:

1: Wipe old partition table with
sudo wipefs -a /dev/sda
sudo sgdisk -Z /dev/sda

  1. run installer
    sudo pkesec calamares

  2. set up partition manually

  • UEFI System → 512 Mib – fat32 – boot/efi – boot
  • Root → 204800 Mib – EXT4 – / – root
  • Swap → 4096 Mib – linuxswap – swap


1 Like