Can't install gPodder

Tried to install gPodder from the official repo, but got this error:
Failed to prepare transaction
target not found: youtube-dl

couldn’t install.

This happens whether I select the optional packages or not.

youtube-dl is listed as optional dependency and also is not available
sudo pacman -Syu gpodder
doesn’t even ask for it - and does install just fine

The command above should take care of pending updates as well.
Don’t install just one single package when you are not sure that the system around it is up to date.

The command line does work, but error happens on the gui Pamac

I never use pamac - you just presented me with one more reason for not using it. :grin:

I use Pamac for better search and discovery. But it’s not the topic to discuss here. The point is since it’s provided by the system, many people use it and, installing gPodder failed there.

The package youtube-dl is not in the repos - so selecting it will cause the install to fail.

 $ pamac search youtube-dl
yt-dlp  2024.03.10-1                                              extra
    A youtube-dl fork with additional features and fixes
plasmatube  24.02.0-2                                             extra
    Kirigami YouTube video player based on QtMultimedia and

The gpodder package is package by arch linux package.

As the dependency on youtube-dl is optional - you have to figure out how to satisfy the requirement - should it be.

It is quite possible that installing the yt-dlp package provides the necessary dependency - but you will have to try yourself.

In the pamac GUI it is also listed under optional dependencies
and during preparation you are asked whether you want the optional dependencies
youtube-dl and python-mutagen
Just select it - or not … your choice.
Not the fault of pamac.
I just looked … :man_shrugging:

1 Like

whether you select the options or not, it results in the error

… for me it doesn’t - works as expected and as intended :man_shrugging:
This time I did not just look but actually went through and installed it using the pamac GUI.
I cannot reproduce it - I cannot help.

Are you sure you are synced, with good mirror and up to date? And you have to provide the full log, not just “not working”

When the Pamac GUI pops up the window asking for you to select the optional dependencies, if you choose none of them, make sure that you press the “Cancel” button, not the “Choose” button:

The “Choose” button should only be pressed if you have selected at least one of the offered optional dependencies. When you “Cancel” the optional dependencies, Pamac will take you to the next stage of the installation process:

1 Like

This might be it. at the popup, I pressed Choose even when I chose nothing. Cancel sounds like to cancel the download.

I dropped a line at the packager to fix it. But interestingly, i can advance if i choose “choose” without clicking anything. This is on xfce with the gtk4 pamac version.

My Pamac appears ruined by this. Now when I try to remove gPodder (installed on comandline), or add other apps, including some updates from AUR, it shows the error and will not do anything. I did refresh database, it went through but does not solve the issue. How to resolve?

Certainly not ruined by this. Probably something from aur. My advice is not to try to update repo and aur at the same time. Maybe you can start another topic for your update problem and post error logs.

Yesterday, I tried to install gPodder on the gui Pamac, but got the error:
target not found: youtube-dl
and couldn’t install, as I already reported here:

Someone suggested to install it from command line, which I did and it installed.

But then pamac appears ruined. It can’t remove gPodder, or install other apps, nor update packages. Whenever an operation is performed, it shows:
target not found: youtube-dl
and abort.

I tried to install youtube-dl from the command line, it failed with error:
One or more PGP signatures could not be verified!

I tried refresh the database, it went through but does not solve the problem.

How can I resolve this?

It doesn’t make sense and recommending it seems a bit like advocating for magic, but:

sudo pacman -Rns gpodder

remove it like you installed it -
the graphical pamac GUI should definitely pick up that gpodder and it’s dependencies are no longer installed.

After that, I have no idea - I don’t know the tool, I don’t use it, I don’t trust it.

Hi @XJia,

Considering this:

…and considering mine works just fine:

$ pamac search youtube-dl
youtube-dl  2021.12.17-2                                                                                                                                                                                                                                  AUR
A command-line program to download videos from and a few more sites

I suspect your package lists are either not up to date, or corrupted. So I’d suggest removing them:

sudo pacman -Sy

And see if that helps.


:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

I did:

but still got the same error when trying to update a few packages.

I did:

and indeed, gpodder is removed together with 2 dependencies.

But then I try to update from the gui pamac, it still shows the same error and does not proceed.