Can't get firewalld to work

When I try to start firewall it opens, then pops up with a message that says:
“Trying to connect to firewalld, waiting…”
Then after a minute a popup window appears with this message, “Failed to connect to firewalld. please make sure that the service has been started correctly and try again”
I have tried both the firewalld-git and firewall (firewalld), and I get the same message.

I just ran sudo firewalld in terminal and that fixed it

That’s not the right way to do it.

:arrow_down:

sudo systemctl enable --now firewalld

huh
well then I don’t know why that worked

It worked because you started firewalld, but you started it from an interactive shell, and it will only be running until you shut down the computer.

The command I gave you enables it in present time and also makes sure that it is started at boot time.

1 Like

now I seem to be getting an error when I try to add any kind of entry to the firewall:

COMMAND_FAILED: ‘python-nftables’ failed: internal:0-0-0: Error: Could not process rule: No such file or directory

there is also a JSON blob, but since I can’t copy and paste from the error dialog I have to type it by hand and the message is rather long and complicated, but if you need it I will provide it

rebooting my system seems to have fixed it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.