Cant enable wayland

Its just says x11, how does manjaro disable wyland ?

/etc/gdm/custom.conf. If wayland isn’t disabled there, then something is wrong. Can you cat /etc/gdm/custom.conf here?

# GDM configuration storage

[daemon]
AutomaticLoginEnable=False
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

It should not matter, but try the setting

WaylandEnable=true

And reboot

tried that but it didn’t change anything.

Maybe my gnome-session isn’t configured how its supposed to ?
I have no gnome on xorg session…

my gdm says:

Gnome
Gnome Classic

and it still logs in to x11

Do you have xwayland installed? Though it should be pulled as dependency…

Does journalctl -xe gdm show anything interesting?

that command doesn’t work, i did a reinstall on gnome-session… didn’t help either

im about to reinstall my laptop just to enable wayland… cant be that the people at manjaro changed some of the code why i cant enable wayland… it used to work on popos

Our gnome packages come from Arch. The wayland session worked the last time I checked. @Ste74 do you have any further ideas?

Manjaro-Hello ask’s for a permission when trying to change the wayland setting? why is this ?

Because it is a system wide setting. In the background it edits /etc/gdm/custom.conf and sudo rights are needed to do that.

so */ usr / bin / sed * is used to edit the gdm config and nothing else ?.. i cant understand why wayland doesnt work

stefano@ste74 Linux 5.8.1-3-MANJARO x86_64 20.1 Mikah
~ >>> echo $XDG_SESSION_TYPE                                                                            
wayland
~ >>>  cat /etc/gdm/custom.conf                                                                         
# GDM configuration storage

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=true

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

# Enable automatic login for user
[daemon]
AutomaticLogin=stefano
AutomaticLoginEnable=False%                                                                              ~ >>>                                                                                                   

i m always on wayland and all is fine. All work as expected…

only one thing is if the iso is very old and you have installed this pkg
manjaro-gdm-check wich disable wayland if nvidia is detected. but is an old routine, was made before gnome-dev integrated a check in gdm code…

I noticed this today too. I suspect it’s been the case for a few days because I may have observed (x11 style) screen tearing recently. /etc/gdm/custom.conf has WaylandEnable=true. journalctl -xe gdm returns “Failed to add match 'gdm ': Invalid argument” ", so I’m going to assume I’m using that wrong. ‘echo $XDG_SESSION_TYPE’ returns “X11”.

On boot my options are “gnome” and “gnome classic”. I’m pretty sure that wayland used to be an option.

Intel HD Graphics 620 using video-linux driver. Nothing about my system has changed recently, but I did a large update (pacman -Syu) recently

New to the forum, I hope my markup is ok.

Try enablingKMS Early Start. This fixed it for me

2 Likes

Recommenting the WaylandEnable=false line in /etc/gdm/custom.conf worked for me. For some reason it was uncommented by default.

After a while without using my Manjaro installation, I got a huge update and also Wayland stopped working in Gnome: only two options available to login (Gnome and Gnome Classic, no Gnome on Xorg) and it would always run on Xorg.

I have checked custom.conf, tried KMS Early Start, nothing worked. Then I found this post in the Arch forum:
bbs.archlinux.org/viewtopic.php?id=258520

and it worked. I also changed StandardOutput to journal in the original gdm.service module to fix some startup error messages.

Cheers

2 Likes

For me, the problem was nvidia. Gnome disables wayland when it detects nvidia. I just had to disable it in some rules config.

To let GDM use Wayland, copy 61-gdm.rules from /usr/lib/udev/rules.d/ to /etc/udev/rules.d/ (where the latter file will override the former) and comment out the related line:

# DRIVER=="nvidia", RUN+="/usr/lib/gdm-disable-wayland"

source: arch wiki on GDM. (I can’t include the link in here. Idk why.)

There’s no need to bump old threads when there is already a known workaround for the issue on topic.

See [Howto] Use wayland with propietary nvidia drivers