Cant enable wayland

Try enablingKMS Early Start. This fixed it for me

2 Likes

Recommenting the WaylandEnable=false line in /etc/gdm/custom.conf worked for me. For some reason it was uncommented by default.

After a while without using my Manjaro installation, I got a huge update and also Wayland stopped working in Gnome: only two options available to login (Gnome and Gnome Classic, no Gnome on Xorg) and it would always run on Xorg.

I have checked custom.conf, tried KMS Early Start, nothing worked. Then I found this post in the Arch forum:
bbs.archlinux.org/viewtopic.php?id=258520

and it worked. I also changed StandardOutput to journal in the original gdm.service module to fix some startup error messages.

Cheers

1 Like