Can't download anything for plasma

I can’t download anything for plasma like widgets, themes and etc.
When I do that I get an pop-up saying:

Download of item failed: no download URL for “name of the item”.

I’ve tried restarting my pc but it didn’t fix it.

1 Like

Can confirm.

However, I highly doubt it’s a Manjaro problem, as it worked earlier…


same with me this error started showing today only

Might be related… :arrow_down:

It’s not the first time has had network problems, though.


I’m in Arcolinuxb right now and can confirm this. Thought it might be Arco, but now it looks to be a Plasma issue regardless of distro. I’ll login to Manjaro in a few minutes and see if I get the same.

My money wouyld be on that since they have had issues in the past.

1 Like

I am getting a popup on downloading anything from the kde store, be it a global theme or a desktop effect.

The popup says:
Download of item failed: no download URL for “”.

Any help is appreciated, thanks in advance.

1 Like

That happens sometimes, if you need to download something go to KDE Store website until it is fixed on their side. You can install the OCS URL handler for simplified installation, or manually place the files in your home in the proper folder.


Thanks I’d forgot about that. Also if one wants they can install pling-store which has the KDE store in it so one doesn’t have to launch their browser and navigate to the KDE store. It’s a Appimage.