Can't create usb for iso

I have downloaded image writer and everything and I am at a loss of how to download this. I have put sudo dd bs=4M if=/path/to/manjaro.iso of=/dev/sd[drive letter] status=progress oflag=sync in the terminal and it tells me dd: unrecognized operand ‘letter’
try dd – help for more information. I am a rookie with linux but, I simply took the clipboard copy and paste into the terminal. It should have been recognized shouldn’t it? I am really interested in manjaro as my new main linux and any help you might have would be awesome thank you!

Try ventoy.

i have no idea what ventoy is but it doesn’t show up in the software repository

Latest ventoy has a GUI. Or you can use from CLI. This is their website:

Ventoy OR:

switch to folder where you have extracted ventoy:

Install ventoy to the USB disk:
sudo sh -i /dev/sdb

copy the .iso file (s) to the USB drive. Ventoy can handle multiple .iso

For the GUI:

To run it, all you have to do is double-click the VentoyGUI executable corresponding to your OS architecture (if you're a desktop user, chances are you're using an x86_64 architecture, so double click VentoyGUI.x86_64).

In case double-clicking the executable doesn't work, open a terminal, navigate to the folder where you've extracted Ventoy and run it using, e.g. for the x86_64 architecture:


It is also available in the repositories (community)

I always use Suse Studio Imagewriter. Search for imagewriter in pamac. All you do is drag and drop, no cli (command line interface, ie. typing commands) needed.

i’m a rookie. I don’t know what any of those three letter words means folks. I just done as your guide said to clipboard(copy and paste) the code i provided above and it errored on me. This was supposed to be a user friendly manjaro I thought. Can someone please break into english for me? Thank you

Download what?

From where? Never copy and paste into the terminal especially with sudo unless you know exactly what the command does.

See the following tutorial for help with dd:

Sure it does, open Add/Remove Software and search for it. Where did you look? :thinking:

Via terminal:

❯ pamac search ventoy
ventoy                                                         [Installed] 1.0.56-1  community

Are you talking about the words GUI and CLI? They are very common words in the computer world; they aren’t just Linux words. Heck, I learned them from playing video games in the 90s and early 2000s.

GUI = Graphical User Interface
CLI = Command Line Interface

If you downloaded image writer (which is mentioned in Manjaro First Steps), why not use that instead of typing dd in the terminal?

This is now more confusing because image writer is a Windows program, but you’re saying you’re typing sudo dd which is a Linux command.

It is definitely in our repo. Unless you mean you’re using a different Linux distro currently or using windows currently. You never explained it to us.

Because you never put in the drive letter. You kept it as [drive letter] instead of something like /dev/sda. You can find out the correct drive letter by typing sudo blkid. And if you just copied and pasted it, you didn’t put the correct path for the Manjaro ISO.

Honestly… I don’t know if you’re trolling or not now… It says /path/to/manjaro.iso, which means to put the path to the manjaro iso there…

Also, no matter what, you should never blindly copy and paste any commands. You should look into it beforehand. Doesn’t matter if it’s Windows, MacOS, Linux, Android (adb), etc.

From the above comments, it sounds like you aren’t using Manjaro currently? You never told us what you’re using, which is heavily confusing everyone. Because you typed if=/path/to/manjaro.iso, which sounds like you’re trying to write the Manjaro ISO.

We cannot help you if you only provide fragmented details.

Putting Manjaro ISO on a USB Stick is super easy. On Windows, you can use Image Writer or Rufus. On Linux, you can use Ventoy. All 3 are GUI programs.

For some reason my header topic disappeared guys. I am a rookie and the only reason I used those sudo commands is because I have tried to move from linux mint 20.2 to manjaro plasma and was prompted by your site to put the sudo commands into my terminal to download onto my usb card and I was also prompted to download image writer specificalluy from your installation guide to download this so if I have to go through strange hoops and bounds i’m being run off from something so hard. I specifically tried every version specific to manjaro and every one of them errored on me after I just simply clipboarded what it told me to put into clipboard with my password and it wouldn’t work friends. It should have worked. I just copied and pasted everything into the terminal as your installation guide said in plasma several times because it’s the one I want and it say on my linux cinnamon mint 20.2. So I also tried every other manjaro system hoping and praying it was just a typo on one site but,every one is doing the same thing. I was told manjaro was very usual friendly but, if I can’t get the basics to work from the actual site right to put it on my usb stick like I was easily able to do on linux mint I am unfortunately being run off from this wonderful desktop experience. Please break it down for a rookie in English.

I have read the original post Can’t create usb for iso - Support / Installation & Boot - Manjaro Linux Forum

As I am not a native speaker of English, I can understand every word instead of rookie :sweat_smile:

You should not print "letter"

  1. Check the device name it got associated with:ls -l /dev/disk/by-id | grep usb
    output: […] usb-Flash_USB_Disk_37271228A5E0216322818-0:0 -> …/…/XdA
  2. Start the write process with dd:sudo dd if=manjaro.iso of=/dev/XdA bs=1M oflag=sync status=progress

You should replace /dev/sd[drive letter] with your device name like “/dev/disk/the_USB_of_taterofwedges, which can by found in the output of ls -l /dev/disk/by-id | grep usb

It should have been recognized shouldn’t it?

It should not, sorry, because you do not have a USB device called /dev/sd[drive letter], do you?

1 Like