Can't boot to GUI

Hello, I’m having trouble getting to my KDE GUI after an update.
So I was updating my system and after a few minutes my system froze so I had to reboot. On reboot i had this error : missing /boot/vmlinuz57
So I checked some solutions and in fact the kernel 5.7 was not installed even though that is the one I was using before reboot. So I booted in a live USB and in chroot I tried to install the 5.7 kernel but the command :
sudo pacman -S linux57
returned that there was no target by the name linux57 (my system is up-to-date)
So I installed the 5.10 kernel and in the grub menu, since the boot img for 5.10 wasn’t there, I modified the 5.7 one to 5.10. So now I don’t have the missing /boot/vmlinuz error but I still can’t get to my GUI, when I boot in 5.10 it’s stuck on the screen displaying my pc manufacturer’s logo (ASUS) with a usable mouse. I can access tty but I couldn’t solve the issue there. When I try installing nonfree drivers for my Nvidia GPU, the mhwd command always returns mhwd: error while loading shared libraries: /usr/lib/ file too short, when I try starting X from tty it says that there is already a X server running on tty1 (which is my stuck screen) and when I kill it, it immediately restarts it and gets stuck again. So I’m asking for some help, thank you very much :slight_smile:

As kernel 5.7 is End Of Life (it’s been a while), your update had removed it. It should have put instead a newer kernel. Could you try instead linux59 (even if it’s EOL) or linux510? Linux54 is Long Term Support, you could give a try also.

As for

Kernels 5.7 and 5.8 have been removed from Manjaro repos, so you cannot install them with pacman.

Thanks for your reply, I’ve tried linux59 and linux510, both get me stuck at the ASUS screen. Same for linux54

Check the solutions in post #2 on [Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

I hope you’ll find something there.