Can't Boot Past LUKS Passphrase - Device is too small, Invalid keyfile Error

Failing to boot once my passphrase is entered for my LUKS encrypted nvme drive.

I applied recent updates to everything (Kernels, programs, everything). Everything was running fine before applying and rebooting after this update. Everything went smoothly with the update and no errors were reported. Upon rebooting, I can enter my passphrase to decrypt the drive, the manufacturer splash screen then appears as normal, but then I will receive the error:

Device: /dev/nvme0n1p2 is too small.
Invalid keyfile. Reverting to passphrase.

A password is required to access the luks-f14fcfce-89e5-4750-a45f-24e24c8a4bc8 volume:
Device /dev/nvme0n1p2 is not a valid LUKS device.
Device /dev/nvme0n1p2 does not exist or access denied.

It then keeps looping “Device /dev/nvme0n1p2 does not exist or access denied.”

Very rarely, it will boot all the way to the Cinnamon login screen but upon entering my password, everything freezes. If I try to do a minimal login ([HowTo] Reach a minimal system), I get:

[FAILED] Failed to start Virtual Console Setup.
[FAILED] Failed to start Virtual Console Setup.

I created a live USB to chroot but I’m having trouble accessing the drive. I attempted to access the encrypted drive with various commands like:

sudo cryptsetup luksOpen /dev/nvme0n1p2 encrypted_device

But I receive the response:

Device /dev/nvme0n1p2 is not a valid LUKS device

If I attempt to open the drive via the file manager, I get the error:

Unable to mount location
Can't mount file

lsblk output:

loop0         7:0    0  65.4M  1 loop /run/miso/sfs/livefs
loop1         7:1    0   1.2G  1 loop /run/miso/sfs/mhwdfs
loop2         7:2    0   1.5G  1 loop /run/miso/sfs/desktopfs
loop3         7:3    0 658.4M  1 loop /run/miso/sfs/rootfs
loop4         7:4    0     0B  0 loop 
sda           8:0    1  14.6G  0 disk /run/miso/bootmnt
├─sda1        8:1    1   3.5G  0 part 
└─sda2        8:2    1     4M  0 part 
nvme0n1     259:0    0     0B  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part 
├─nvme0n1p2 259:2    0 229.4G  0 part 
└─nvme0n1p3 259:3    0   8.8G  0 part 

Nvme0n1 is the 256GB SSD with Luks / Manjaro.

The laptop is a Dell XPS 9560 running Manjaro Cinnamon with the kernels 6.1.55 and 5.15.133.

I can access Grub upon booting and decrypting the drive.

I am able to decrypt / access external drives with a live USB.

Maybe partition is almost full?

That’s what I am thinking. It has a 256 GB SSD. I tried to access it to delete files but as mentioned, I couldn’t get chroot or a minimal login to work with what I’ve tried thus far on my end. Wondering what to try / where to go from here.

chroot is not needed to get access to the device

Just open the encrypted container and access the data within
Check whether the drive is indeed (almost) full.

System information obtained at that point would likely also be helpful.