Can't boot LUKS encrypted install after 2023-03-31 stable update

Installed Manjaro like 6 weeks ago.

Got hit by this issue after the 7gb update but only with the “click button to continue” thing. Since i rarely reboot i did not do anything in this thread but keeped a very close eye on it.

As of the update 15min ago the issue is fixed.

Instead of the warning i will now see the boot menu for 3 seconds and then Manjaro loads with no issues. I also updated to the 6.2 kernel in the process.

Dont get the crypt error msg anymore.

@boustanihani well. You may want to post the content of your /etc/fstab file and compare it with the cryptomount llines of your /boot/grub/grub.cfg file. If you have dashes in the grub.cfg file for the UUID remove them in all the lines you find the word cryptomount and save the file. That is what the updated /usr/bin/update-grub does. You can re-read my more lengthy posts, as I explained the issue in rich details. Only updating the grub packages won’t update the grub install on you MBR/EFI. So you have to call grub-install ... at some point to fix it properly.

Thank you Philip, I was able to solve two of the errors.

Removing the dashes in /boot/grub/grub.cfg and calling grub-install fixed the “no such cryptodisk found…” error.

In “/etc/default/grub” I changed:




This is how I fixed the “sparse file not allowed…” error.
Check: GRUB error: sparse file not allowed

Caution: Calling grub-mkconfig -o /boot/grub/grub.cfg regenerates the dashes in /boot/grub/grub.cfg

Now, I am only getting the “out of range pointer…” error , but after entering the password twice, the system boots correctly =>

452: out of range pointer: 0x95d6a020

Aborted. Press any key to exit.

nearly same thing ; since the “crypto bug” last day of march
I did several things but my computer was able to mount finaly (Sorry for my english language. Media items -screenshots- can’t be uploaded) :

Now at boot my PC prompts 2 times hd1, gpt2 UUID without dashes…

result :
sparse file not allowed…” error.
452: out of range pointer: 0x95d67020
Aborted. Press any key to exit

the third time, it prompts hd1,gpt2, UUID with dashes
and it’s OK

NB : no such a crypto disk message disappear with Philm command (sudo pacman etc Great Thanks to Philm !)

For information :

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=0118-AEE6                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-bab359ae-44e6-42f6-89ec-7d25913c7c37 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

NB :

  • I dare not to delete dashes from cfg (because I get impression system is mounting when it prompts UUID with dashes)
  • I dare not make this change (I had seen before boustanihani post) because He still has to put 2 times the PW (me 3)




A post was split to a new topic: Error no such cryptodisk found

Yes, that is why you should use /usr/bin/update-grub script which removes the dashes again. Anyhow, if you installed it to your MBR/EFI your new grub install supports also the value with dashes.

Thanks Philip, I did this, just wondering why all those errors happened at once…

Do you have an idea what could be causing the “452 out of range pointer…” error?

You forgot the option where you use and test FDE+sboot because it’s not the 1990s any more :stuck_out_tongue:

But seeing that I can use a initramfs hook to accomplish FDE instead of grub there may be too many ways to skin that cat for testing…

I don’t know if this might help.
I have an older PC with an Intel i7-3770 CPU with the latest Manjaro using the LTS Kernel 6.1.49-1 an no bott problems.

I bought a modern Mini-PC with a Ryzen 7 4800U CPU and used Clonezilla to do (automatic) full disk cloning of my old SSD to a the new SSD.

When I try to boot the new PC, I get the "452: out of range pointer" error and I also need to enter my password twice…

I noticed I have two Boot Priorities in my Bios on my Manjaro SSD.
I switched to the other boot option, simply named “manjaro” (not UEFI).
This magically solved all issues, the “452: out of range pointer” error is gone, and I no longer need to enter the password twice.

Is it the non UEFI mode that solved the problem?

Below are some screenshots for my BIOS and my partition on the SSD.