Can't boot live DVD


I’m trying to install Manjaro on my Apple pro (2009) x86_64. I mainly want to run it headless and ssh in. I can’t get it to boot from the live DVD. I tried making a live USB, live DVD, a live DVD with another WM. I also tried using Gentoo. Gentoo booted and installed, but Gentoo didn’t support lots of software I wanted to use, so I’m back here.

What happens: I go to the manjaro screen where I can edit boot options, I select “boot with open source drivers” or “boot with proprietary drivers”. Whatever I pick, then the monitor goes blank and I never see any more output.

I tried adding “rw 3” to the end of the boot line per [HowTo] Reach a minimal system and it, again, just went to a blank screen. First the screen goes blank. Then the DVD starts reading and the screen turns off, then the DVD stops reading and still nothing on the screen.

I can’t boot to check inxi and that command doesn’t run in GRUB.

I have a ATI Radeon HD 4870, perfect for a computer that I never intend to attach a monitor to.

I would prefer to boot to a command line than a graphical environment, but I’ll take whatever I can get.

After I edit it, the command in grub is

linux /boot/vmlinuz-=$2 driver=free nouveau/modeset=1 i915.modeset=1 radeon.modeset=1 rw 3

then I hit f10 and… nothing. I can also run it without that and… nothing. or use the proprietary.

My best idea now is to try to load Manjaro from another linux’s live cd, but do you have another idea?

Try a different distro - or even just plain Arch (there is EOS, which is essentially a pre-configured Arch).
They all have the same possibility to enter the Grub commad line.
You could see and compare what they use - and whether one just works …

It might be just the kernel version.

is not exactly recent - there is likely some info on the Arch wiki or elsewhere on the interwebs

If it has not got Nvidia you could remove all reference to driver=free and to nouveau

I think it’s probably the graphics card. Gentoo was fine because it just use a CLI. The window managers probably don’t like using as little as 256 MB, like I have on my card. Is there a way to boot Manjaro into a CLI instead of launching a window manager?


adding the number 3 to the grub command line - like in your example - should (and does) achieve exactly that

But then you can’t run the Manjaro installer (Calamares) - because it is graphical, does not have a TTY mode.

Speculation isn’t very useful - and testing it is quite easy.

So: you know it works.

Speculation again - it might not be very performant, but it should not be a show stopper. Actually: it isn’t.

I tried again with a 3 at the end and it did not work. Same result, screen just goes blank.

If memory serves, an Apple machine of that vintage – despite being 64-bit – still used a 32-bit boot loader. That factor alone may have been problematic.

Using rEFInd or perhaps OpenCore to effectively chain load GRUB might be worth some consideration.

Of course, this assumes you can overcome any Nvidia-related issues.

It had 4 cores. The first multi-core CPU came long after 32 bit started being phased out.

(But I know nothing about Linux on Apple.)

The 32-bit boot loader was still used long after, as I said. Some research will discover this; there were many online rants and some more serious articles (about Apple artificially preventing foreign OS installs on Apple hardware) at the time. That said, I’m not entirely certain of the timeline (from memory) but the brouhaha was certainly around the time of UEFI introduction to the market.

Irrespective of this, if you can (manually) install rEFInd to a newly created $ESP, this might be sufficient to allow booting a Manjaro Installer DVD or possibly a USB. I should point out though that UEFI implementations were not overly reliable in the earlier years.

I know there was a Debian distribution for use on Apple machines, which, as I understand it, is no longer available/maintained.

Debian still provide resources for those interested in a manual approach; your Mac Pro (2009) seems to be well within the target range:

I’ve never attempted installing an Arch-based distribution on an Apple machine, so have nothing overly constructive to offer within this scope.

Best of luck.

I don’t know how I misread that. UNDO UNDO!

I was only here to see how much of pain it is for Linux on Apple hardware, then laugh in my head.

1 Like

I’ve seen some threads where some have had success; many more that haven’t. It seems to be a crapshoot, either way.

there is no problem with the imac itself. it can trouble if you wnat to purge the original mac-os and replace it with linux due to the mac-os itself. but i would always recommend to clean up the imac first, renew the cooling-pads and thermal-paste and replace the harddisk with a clean,new ssd/nvme. problem solved…

1 Like

Have you verified the checksum of the downloaded ISO?
Have you checked the burnt disk?
What ISO file did you try, exactly?